Problem with the X & Y Axis?

It happens when printing the brim, does anyone know why it happens?

I use Luban to generate gcode files, ABS filament and I use sticker tape on the bed.

Do you use a PC, with Snapmakerjs, or a USB-Stick, to run your Snapmaker? I had a simelar problem in milling-mode, but with Y-axis. It happend sometimes when I had a lot of traffi on the USB (copying files…). Now I you an old Laptop and everything is fine. Maybe you got the same issue.

looks like layer shift to me, what speed are you printing at?

I use USB stick, it’s not a large item, when I tried to reprint again with exact same gcode file, it worked fine

I use 10 mm/s for the brim, to make sure the ABS stick well on the tape.

do you mean “layer shift” as in the gcode? because I tried to print again with same gcode, and worked well, so I thought it’s hardware issue

Layer shift can be caused by a number of reasons, sometimes is a controller issue which can be caused by overheating, or cross talk, other times it can be a hardware issue where if you try to print too fast the stepper motors skip steps resulting in the layers being shifted.

What is your first layer print speed as the part that looks shifted seems to be the bottom of the part itself

In Luban, go to turn off the door detection first if you did not use the enclosure.

Bottom speed is 30 mm/s, it happens from time to time, but if I repeat it works well

It is OFF by default, and I dont have enclosure

Test your power supply.

this FAQ may help https://support.snapmaker.com/hc/en-us/articles/360040938094-What-should-I-do-if-the-layers-of-a-3D-printing-models-shift-to-the-side-

1 Like

Thanks, I will try the suggested solutions