PLA parts looks nice but don’t fit

Three attempts:

1 Fast print.

2 Adjust E-steps fast print. 212 → 249

3 Reset E-steps normal print. back to 212

First one is the only one that almost fits.
Second (at 249) looks sloppier.

The normal print looks good,
but the slots still don’t fit and seem worse
(a downloaded part, designed for PLA)

I could readjust E-steps back to 249 and print normal,
but I’m not optimistic as it seemed to make it worse last time.


*forum won’t let me post multiple photos.

Did you take shrinkage into account? Set scale in Luban, after importing the model, to a value over 100%. Actual value is difference in dimensions between design and printing result.

@DrQt are these items that you designed yourself? If so, you typically need to design in a gap of ~0.250mm between objects that need to fit together. Shrinkage CAN be an issue as well, but it doesn’t work in the way that you might think that it does, and will vary on each axis. You might want to read up on designing 3D printed parts, and how to compensate for variations.

If this is for something that someone else designed, see if there are any notes on how to print the objects. Most designers will include these types of notes for a limited set of materials. You can try to contact the creator if you need to use a material that is not discussed, and are have a tough time with.

I’ve definitely had things I download from Thingiverse print up the wrong size. Particularly older models that were designed to be printed on rep raps and first gen 3D printers. Those things were notorious for needing the models to be adjusted to print correctly. That’s why the X/Y/Z calibration cube is one of the first things printed, before Benchy.

Usually you can print it once, then scale it in X/Y/Z by the percentage (you’ll probably need to disable uniform scaling). If you have access to Cura, it’ll let you scale by a percentage OR just type in the X, Y, and Z dimensions you want the final part to be, and it’ll scale it for you.

Scaling can be tricky on more complex parts, because it changes based on part orientation. I use it a lot, because the print volume of the original is so tiny.

Sorry for the delay.
Took a moment to get back to the studio.

Filament is whatever came with the SnapMaker.
Measures around 1.6mm with some 1.5 and 1.7 mixed in.

Default cube printed at 20.1mm, maybe 20mm.

That would suggest scaling it down, but wouldn’t that make the problem worse?

E-steps are currently at 212.21.
Larger values seems to make the issue worse.
Haven’t tested all the combinations though.

The design is public, for PLA and only a year old.

I tried to run a calibration, measured 100mm the top of the feeder, left with 14mm — starting at around 146 got 187 esteps.

No bueno.

Attempting again now starting from 212.21

this time 5mm from 100mm so 223.38
test cube is printing and then another attempt at the downloaded design.

Test cube was 20.1

I cropped the print for faster iteration so 17hr is now 27min.

Still no dice.

Any ideas what to try next?

The failed print looks like you’re trying to print Pan_Mount.stl from DSLR Camera Pan Tilt Mount (Stepper Motor Driven) by isaac879 - Thingiverse . The second print looks like it’s a different part? I can’t really tell, but I don’t see how you’d crop Pan_Mount.stl into that shape.

One thing I notice in the Pan_Mount.stl photo, under the pile of filament is the plate touching the bed isn’t complete. I can’t really tell underneath the big pile, but the rear left is missing a chunk. Looks like your first layer didn’t completely adhere in the back left corner. It either failed right way, or pulled off shortly after. I’ve occasionally had a print complete well enough when some of the first layer failed, but it’s not something I’d count on. Start the print, and just watch until it starts laying down the surface of the first layer. Pay attention to that rear-left portion of the bed when it’s doing the outer and inner walls. A uneven enough bed can pass calibration, but still cause adhession issues.

The cropped print looks ok. I don’t see any saggy briding. Does the dimensions of the print match the dimensions in the slicer?

Modifying the E-Steps doesn’t scale down the model, it just changes how much filament the machine extrudes to fill a given volume. By having more E-Steps, you’re pushing more filament into the same volume. That can give you a better bed adhesion and better fill micro gaps inside layers.

I generally recommend that people print some kind of bed calibration piece after changing E-Steps. You want to see a good even thickness across the whole bed. Because your bed is so large, try something like an X-shape. Or something that focuses just on the rear left corner (center to edge).

Increasing E-Steps it should improve your bed adhesion, but it’s possible to overextrude on the first layer and ruin the print too. If the print head is too tight, the extruder will ooze out sideways and push previously deposited filament up off the bed. I don’t see any examples of that, but they could easily be buried.

I print 0.05mm Calibration.stl (684 Bytes)
whenever I recalibrate or switch filament. I mostly print 0.04mm layer height now, not 0.05. So I scale the Z axies down 80% to be 0.04mm. You can scale and position the X and Y to cover whatever part of the bed you want.

My goal is to get a consistent bead all the way around that appears to have the same height. While the machine is printing, I’ll use a flashlight at a 45º angle, and examine the shadow of the inner and outer walls. If one corner looks squished or not touching the plate, stop, recalibrate, and start over.

Then let the print run. Sometimes I’ll end up with a corner that is squished (the texture is rough, and I can hear the filament being pushed off the bed), even though the outer walls look good. Give that corner a big more height, and try again.

The Original has a small plate that’s a lot more consistent than the v2. You could have a myriad of problems if the bed isn’t very even.