Luban not loading


I keep on thinking that there is something that I am missing, I have installed Luban version 3.10 double click on the icon and nothing happens the software does not load up. My printer has connected to the Wi-Fi ok not sure why the program is not loading. When I try to reinstall the program, it tells me that a version is already running. I keep thing that there is something simple that I am missing but I am at a lost.

Can anyone help?

Thank you.

1 Like

Same issue - brand new user here and Luban just sits in my Processes list doing seemingly nothing…

v3.10.0 and v3.10.1 both do this. Trying v3.9.0 now…

Windows 10 x64 is the platform - I tried v3.10.0 on 32-bit but no difference.

1 Like

v3.9.0 opens fine - seems like there is a problem with the build for Windows for v3.10.0.

Yep, that is what I am thinking of doing trying an older version. The program has loaded but nothing on screen tried it on a mac book could see the menu but again unable to do anything with it most of the options were greyed out.
I am also a new user only got my A350 yesterday after completing the build which was really easey I thought by now I would have had something printed.
Let me know how you get on with the older software I am going to try a few things first before trying older version.

Sorry for the inconvenience, there is a bug there when choose the right display for Luban.
I’m working on it and will release a fixed version later.

1 Like

Thank you for the quick response… its nice to see staff in the forums again.

I can confirm the re-released version v3.10.1 works just fine on Windows 10 x64

1 Like

v3.10.1 was updated on the original post: Snapmaker Luban Downloads and Updates

Yes, v3.10.1 is working, can I just ask is it best to uninstall the old software then install the new or just install on top of the previous version.

Symantec Endpoint Protection sees WS.Reputation.1 risk and keeps quarantining the app. Anyone else experiencing this problem? with Luban 3.10.1

Installed 3.10.0 64 bit (deb) for linux on my machine (Running Pop!OS, a type of Ubuntu). Seemed to install fine, but won’t start up. Completely uninstalled. Tried again with 3.10.2, still no luck.

Haven’t run the Linux version, but did you follow the special instructions for Linux?

There was an issue with 3.10 with it not opening in windows but it was fixed in3.10.1 maybe its a similar issue

@parachvte any insight?

1 Like

I have an original Debian 10 (buster) system which I keep updated on a very regular basis. I tried to install the latest snapmaker-luban-3.10.2. This gave me 2 minor issues:
ldconfig and start-stop-daemon aren’t by default in the PATH any more (no /sbin in PATH, not even when root), but that is easily fixed. The other issue was the missing libappindicator3-1, but I could install that via the package manager. After that, the software was installed

I use the gnome desktop, and there is a menu entry created under ‘accessories’ (I expected ‘Graphics’ but that is just my 2 cts).

I am unable to start (nothing happens).

When I try to start luban from the command line, I get the warning I need to chmod 4755 chrome-sandbox. After that change, Luban still doesn’t work. I also found I need the user to be member of the group ’ dialout’. That was already the case.

The last 3 error messages I found in dmesg are:

[1210122.379437] traps: snapmaker-luban[29094] trap int3 ip:5563a4037cd3 sp:7fff43045d10 error:0 in snapmaker-luban[5563a21b4000+53d6000]
[1210380.470285] traps: snapmaker-luban[29212] trap int3 ip:56048509798f sp:7fff08186100 error:0 in snapmaker-luban[560481c9d000+53d6000]
[1210387.769145] traps: snapmaker-luban[29215] trap int3 ip:5583c199798f sp:7ffd86fd2380 error:0 in snapmaker-luban[5583be59d000+53d6000]

When I install Luban on Windows, the program starts and is functional (just started a print job without problems).

Can anybody give me a good pointer to resolve this?


I am still seeing that Luban does not start right away on 3.15.1, eventually it does after reclicking on the program

I just got my A350 , please which software version should i download
please advise
my Laptop windows 10, 64bit
thank you.

Hello, everyone,

i just load the luban software, finally without any issues.
my Case here is closed.