Luban does not connect with Snapmaker Ray

Hello everyone,

A few weeks ago, I purchased the Snapmaker Ray and, after some initial difficulties, I’m fairly satisfied with it. Unfortunately, the door sensor sometimes doesn’t work properly. The laser moves, but it intermittently stops cutting/engraving. I use Lightburn, which generally works flawlessly, but to disable the sensor, I need to access the laser with Luban.

Now, the major issue: Luban recognizes that the laser is connected at COM4, as well as COM5 and COM6, but it doesn’t connect to the laser.

I’ve already updated the driver, and once, when it briefly worked, I also updated the laser. I keep Luban up-to-date, but it still won’t connect.

What could be the cause of this?

Thanks in advance!


I have the exact same problem. It used to work perfectly the day before and I have been trying to do some work today and it does not connect. I tried the lightburn as well but still nothing. Have you managed to find a solution?

Unfortunately, I don’t yet know how I could solve this. Lightburn works very well for me, but Luban still won’t connect.

Hi @Florian721

Sorry to hear that. May I ask have you contacted our support team before? If not, you can submit a ticket, and we will assist you in resolving the issue.