Issues with generating g-code?

Im having trouble generating g-code. It takes an hour after clicking the generate g-code button for the, slicing 100%, screen to go away. After it loads, it stays on the loaded model successfully and won’t let me click anything other than the export model button. How I fix these issues?

Could you post your file here? We will see if we could reproduce the problem. Currently the Snapmaker Luban doesn’t handle extremely large files well.

Im having trouble uploading the file. It is saying that new users can not upload files. Do you know how long your account needs to exist for it to not be considered a “new user”?

The default setting for promoting to the next tier from a new user on a Discourse forum is enter 5 topics, read 30 posts, and read posts for 10 minutes. Feel free to send me the file through PM.

Grand Krunk (1).stl (684 Bytes)

Here is the file I’m trying to print. It gets stuck at slicing 100% and loaded model successfully after you hit generate g-code. When it gets stuck at loaded model successfully, Load g-code to workshop/export g-code to file both have a little red circle with a line running through it over them.

Worked ok for me. Do you know that you have to scroll the workspace over to actually see what is loaded? What you’re seeing is the origin. On a Mac you control-click to scroll the window over to the right to see the GCODE path. On a PC I think it is a right-click. Not sure.

This is how it ends up. I’m using the original snap maker in the 3D printing section. It is currently stuck on the slicing 100% screen and won’t let me tap the load g-code to workspace or export to file. I’m not sure how to get it into the flash or workspace.

Ok, I see. You’re not even getting past the Generate Gcode.
I see that you’re on a Windows machine. What OS version?
What version of Snapmaker software you using? Luban? SnapmakerJS?

That file is not that large. My Mac takes about 3 seconds to generate gcode.

For me on Win10 (8core Ryzen7, Gforce GTX970) using Luban 3.3.3 gcode generation works in seconds.

OS: Windows 7 professional and snapmakerJS 2.5.2

Please try the newest version of the Snapmaker Luban, it is compatible with Snapmaker Original now.

Ok so ive tried it and the CNC and Laser work fine, however there isn’t even a section for the 3d printer? Is it supposed to be like that?

No that’s strange. Luban should have a section for 3D printing and a page for the 3D printer. You can change your printer model in Settings highlighted in the lower left corner on the screenshot.

This is how it looks for me. I went to settings and restored default settings but nothing happened. I’m on version 3.3.3

Luban doesn’t have the 3D printing section for 32-bit systems. Are you using a 32-bit or a 64-bit system?

im using 32-bit. anyway to get the 3d printer section? Another version perhaps?

Hi, we dropped support for 3D slicing back when we released the Snapmakerjs V2.5.3. You could try the versions before V2.5.3. But you might run into stability issues with the previous versions. Hope that helps.

how do I find the older versions, are they on your site?

We just reuploaded the installation file for version 2.5.2 (the latest version that still supports 3D slicing for 32-bit systems.). A minor issue was fixed in this reupload.
You can download the older versions here.