G Code for Bed Level Visualizer

how can you perform a 11x11 grid bed leveling with BV?

G1029P7 ;Grid 3x3 5x5 11x11
G1029A ;leveling;
G1029S ;save data;
G1029D0 ;end leveling
M420V ;get data

that’s the g-code im using do I have to take out the other grids (3x3 5x5) ?

this is how mine looks

Thank you! After using this app for 4 months and not being able to figure out my error, this was it! Nice to FINALLY see my bed’s mesh!

Change that to

G1029P11 ;Grid 3x3 5x5 11x11

The number after P is the number of points to use.

anyone know what gcode to use for the dual extruder module (no for retrieving the mesh data, but for initiating the bed leveling itself on a 11x11 grid?)

Or how I could go about determining this, not sure if there’s a way to view what gcode is being sent to the controller.

1 Like
G28 ;home
M190 S90 ; wait for bed temp
;Auto Level
G1029 P11 ;set 11x11 leveling mesh
G1029 A ;start leveling

Then manual z offset via touchscreen

Then connect back with luban and

G1029S ;save calibration
G1029D0 ;finish calibration
M140 S0 ;turn off bed heater

This is complete procedure with g-code for 11x11 calibration. I didn’t see anything specific in g-code reference for SM2.0. so it should work with double.

Yes this is what I tried, and the output:

Recv: ok
Send: G1029 P11
Recv: leveling OFF
Recv: X:52 - 28
Recv: Y:43 - 30
Recv: leveling ON
Recv: Set grid size : 11
Recv: ok
Send: G1029 A
Recv: cannot do auto leveling without 3DP
Recv: ok
Send: G1029S
Recv: nozzle height: -234.000
Recv: echo:Settings Stored (1185 bytes; crc 39524)
Recv: ok
Send: G1029D0
Recv: leveling OFF
Recv: leveling ON
Recv: ok
Send: M140 S0
Recv: new B target temp: 0
Recv: ok
Send: G28
Recv: leveling OFF
Recv: leveling ON
Recv: Apply hotend[0] Z offset: 0.00
Recv: X:-32.00 Y:335.00 Z:50.00 E:14.91 Count X:0 Y:57566 Z:134542 B:0
Recv: ok

it seems something else is necessary for the new module.

I see. It looks like firmware issue.

ecv: cannot do auto leveling without 3DP

Dual extruder is not being recognized as 3DP toolhead. I guess you tried 5x5 with the same result?

@Riskey should be able to shine some light on this.
Or open a ticket - Support Ticket Form

Ran into this too, submitted an issue.

Thanks! subscribed to the github issue

Issues at the GitHub are less effective then tickets submitted via form I posted.
According to - Discussion of Snapmaker 2.0 Firmware Updates - #690 by Riskey

1 Like

When I do the 11x11 leveling when I come to calibrate with the touch screen I can’t do it accurately. I can’t go down .05mm.

Thanks, also opened a ticket, and referenced the github issue.

1 Like

That is not my experience, I’m able to use any increments for Z, when doing 11x11 leveling. Maybe check your firmware for updates?

when you do the 11x11 calibration which option do you go to? calibration or just control? because when I start the calibration from the computer and then I go to calibration for the z offset, it starts the auto leveling again with the 5x5. I have v1.15.23

for 11x11 calibration you have to use g-code I posted here - G Code for Bed Level Visualizer - #30 by nweolu
I’m on 1.15.23 firmware too, so there should be no difference. Unless you’ve updated your firmware wihtout 3dp toolhead attached.

yes this is the code i am using. what section do you go to in the touch screen because when I go to calibration it restarts the calibration with the 5x5 and if I go to control I cannot go down more than .1mm which is not very precise

I’m in the middle of a big print. Once it’s done, I’ll go ahead and do the 11x11 to give you precise info on how it goes on my side.

Me the other way that I found is to start a manual calibration and once arrived at the first point I switch on the pc and I start the command line for the 11x11

Hey sorry it took me a while.
So I just run the 11x11.
Running first portion of commands via luban, after

G1029 A

I waited until it settled in the center waiting for the z-offset calibration.
I hit the disconnect button on the touchscreen, this took me to regular controls, where I set the z-offset. 0.1, 1 and 10mm increments availible.
After adjusting Z, I hit the connect button in Luban and continued with second part of the commands.
Calibration complete.
Is this not your case?

no because I was afraid that its “scrap” to disconnect during the leveling. so i was going to leveling first on the touchscreen and once at the first point (in manual mode) i connect with octoprint or pronterface and run the 11x11. by doing that I find myself on the touch screen with the leveling controls so I can do .5mm .1mm and .05mm. Also I can be more specific.

1 Like