Extrusion Problems Number 2

Well, I found that replacement hot ends I received recently (~3 weeks ago) were much better than the ones I received both with the machine and as replacments in about April. The thermistor being the big difference: cementing the thermistor in place should repair the flakey ones. I also used a smear of thermal paste (wiped off with a rag to leave a thin layer) on the hot end where it enters the heatbreak. Not saying you’re having the same problem I was, but if these are easy things for you to try out, might as well go for it.

Did you replacement seem to have a smaller (or larger) heater block?

I noticed a difference between the two extras I got and the two that came with it.

Nope, they measure the same. Really the only difference is the thermistor not popping out readily. Looking at the second new one more closely, the fix is that they shrink-tube the wires together so that the thermistor doesn’t pop out.

Major update, snapmaker support is seeing the same issue, looks like this is something that isn’t related to the print head.

They are still investigating and, again, I will provide any updates they have.


Have you tried printing slower? I think you may be running out of heat, is the thermocouple in the hot end pushed all the way towards the nozzle, the wires seem to hold it out so the heater wires need a little bend to ensure it can sensor in the correct spot.

I see some really weird things when my filament is old/water logged. You didn’t mention anything about trying brand new filament from a reputable source.

Just an idea,

1 Like

Indeed, it is a good idea however I have used several different filament times from several vendors and the result is the same.

Now that the support crew have make the same part and found the same issue makes me think that it is a slicer error somewhere or a configuration error in the printer. Changing to 95% flow make it better but that could only be due to the support showing the vast amount of the issue.

1 Like

Indeed it is pushed all the way in, that guy isn’t moving. As for speed it doesn’t seem to make a difference, I have tried both putting the speed higher to less the time between the move and slowing it down to give it more time, neither seemed to make a difference.

1 Like

I’m always spit balling. I’m glad you’ve got it down to a slicer error. Downsides to free files… you never know if it’s gonna slice ok.

So, as a small update, I have been working with support and they see the issue, they gave me a beta firmware to test with and, while it did improve the issue somewhat I still see it in several places, most noticeably with supports in my last few test runs.

It did seem that turning the flow to 95% helped more than anything so far, however I will wait to hear back from snapmaker support to see if they have any other ideas as to what could be going on.

Another minor update, there has been no real change and no major updates from support, I think they might be stumped as well.

So I will keep playing with settings and see if I can find something that eliminates the whole issue but I am losing hope that this is something that can be fixed, the temptation now is to just buy the V2 print head and see if maybe that will solve it, but if they can reproduce it then I am not sure if there is anything that can be done.

@tracer300 is your issue with the first 5 yellow pictures, or the last yellow picture. The pattern in the first 5 is most likely related to the extruder gearing, which exists on all printers, and there currently is no solution for any 3D printer. If you’re asking about the support structure in the last picture, I’m not sure what you are asking. Support structures are not supposed to look pretty.

No, I don’t overly care about the support, I was only pointing out that the odd under extrusion was appearing in other places.

Of course there are limitations to what a printer can and cannot do, the issue is that this reduces the integrity of some of the printed parts and only happens when the head has to do some level of traveling, a simple box has no issues but one of my player trays for a board game will show it.

I am just not sure if there is any way to reduce it, to me it seems like a delay in the extrusion. I have had many people say that it could be a clog that passes, but the support staff printed the same part and got the same thing. I was hoping that there was a setting or a change that I could make that could remove or mitigate the issue, still kind of am.

It sounds like the issue that I touched on with the extruder. It was only recently (<1 month) that it was brought up by a member of the Voron team, as he had never seen the pattern before. A long story short, he discovered that the pattern frequency exactly matched the the size of his extruder gear. Since then, everyone started to notice the exact same pattern, which varies from machine to machine.

While the stepper motor movement of the extruder may be smooth, the filament does not actually move in a smooth manner. It jerks and stalls as the teeth of extruder grip onto the filament, and lose grip of the filament throughout it’s rotation. Linear Advance and Pressure Advance do not correct for this, and based on the current discussions, there most likely will not be answer anytime soon, if it all.

I can 100% agree that both Linear and Pressure do nothing as I have missed with both, the only thing that made the pattern change was upping the flow rate to 95% from 91.61%.

I am glad that, at least, I am not alone in seeing this issue, should this be the nature of the beast then, so be it. My greatest worry was that it was something that I had done to cause the issue, as it didn’t seem to be present before.

Thank you, this does seem to sum up the issues and that it is a known problem with the gearing, and I would also agree that this will not be something that can be solved soon.

There was a firmware that I was given by support that tweaked some things but it didn’t appear to make much difference. However if others have noticed it and brought it to the attention of the team then all I can hope for is that sometime down the road it can be solved.

1 Like

Hi everyone, as posted above I check my printer once again and see a similar, if not same behavior in my printed parts. This time I used some transparent PETG filament. (I used the Luban settings for PETG with normal print settings (slightly increased speed for inner walls and retraction). S. Picture different results in different heights…^^
Any ideas what to optimize or check?

@m2001s your issue looks like over extrusion coupled with wet filament.

1 Like

Good hint, Artezio. The filament was dried before printing. Over extrusion could be, e-steps I will calibrate again. Are there any other parameters I should keep an eye on?

How would you explain the different areas? (red, yellow, green markings) Especially the change from the green (good quality) to the yellow area.

@m2001s looking at it months later and having more knowledge about printing in general, it might be just slicer and/or settings. Have you tried using Cura?

1 Like

Hi Artezio, I have now calibrated E-steps. I will try a different slicer and print without Luban. Let’s see how it goes…