Extruder Calibration a must

Atom I have export the error log to the usb and there are 3 files on it FW-0, SC_0 and SC_1 which one should I look in and what exactly am I looking for or should I upload the whole file?

Would flashing a new firmware replace all the settings?

1 Like

Sorry I couldn’t tell you what to look for, if you post them one of us may notice something wrong however. And no flashing firmware does not reset all settings. But I think m502 does.

Hi Atom, here are the three files. (I had to rename them to upload)
FW_0.doc (214.3 KB) SC_0.doc (1000.0 KB) SC_1.doc (204.9 KB)
Also the question about the software was more about the terminal side.
For some reason both my Mac and PC don’t like the USB connection through Luban.
I’ve been 3D printing for years and had many Makerbots and Printbots but this printer is very different.
Thanks for all your help to.

have you tried any other machine interfaces, such as S3D, Ponterface, or 3d Fox (android)
also have you made sure you have the drivers, some PCs do not have the drivers for the SM2 preinstalled, that can cause USB connection issues. also gcode can be issued without a connection. just make a gcode file with the only line being “M502” then run it like it was a print on the SM2 via the touchscreen and that would reset all the marlin FW settings.

It can, and with the 1.9.0 update it did. See the notice near the bottom regarding the EEPROM: Snapmaker 2.0 Firmware Updates and Downloads

Generally though, it will not update unless they change the memory layout in the EEPROM.

Just thought I’d mention for others who aren’t intentionally trying to erase all settings during an upgrade. It’s smart to take a backup of your M503 before a firmware upgrade, just in case.

1 Like

Ok so I can run file off the usb or send it wifi from Luban.
So how do I make the file?
Also I’m using 10.1 firmware.

@LordKain
based on the log i would say you should contact support:

1602402600038,2020.10.11 07:50:00.038,INFO,SC-FW,new E target temp: 200 1602402600042,2020.10.11 07:50:00.042,ERROR,SC-FW,ERROR: System Fault[0x40080]! NOW cannot heat hotend! 1602403574310,2020.10.11 08:06:14.310,INFO,SC-FW,SC get env: 4 1602403574311,2020.10.11 08:06:14.311,INFO,SC-FW,live z offset: 0.000 1602403574312,2020.10.11 08:06:14.312,INFO,SC-FW,SC req enclosure sta 1602403574454,2020.10.11 08:06:14.454,INFO,SC-FW,SC req START work 1602403574455,2020.10.11 08:06:14.455,ERROR,SC-FW,System Fault! Now cannot start working! 1602403574457,2020.10.11 08:06:14.457,INFO,SC-FW,SC req -> failed 1602403639691,2020.10.11 08:07:19.691,INFO,SC-FW,SC get env: 4 1602403639692,2020.10.11 08:07:19.692,INFO,SC-FW,live z offset: 0.000 1602403639693,2020.10.11 08:07:19.693,INFO,SC-FW,SC req enclosure sta 1602403639854,2020.10.11 08:07:19.854,INFO,SC-FW,SC req START work 1602403639855,2020.10.11 08:07:19.855,ERROR,SC-FW,System Fault! Now cannot start working! 1602403639863,2020.10.11 08:07:19.863,INFO,SC-FW,SC req -> failed 1602404099122,2020.10.11 08:14:59.122,INFO,SC-FW,SC get env: 4 1602404099124,2020.10.11 08:14:59.124,INFO,SC-FW,live z offset: 0.000 1602404099125,2020.10.11 08:14:59.125,INFO,SC-FW,SC req enclosure sta 1602404099316,2020.10.11 08:14:59.316,INFO,SC-FW,SC req START work 1602404099321,2020.10.11 08:14:59.321,ERROR,SC-FW,System Fault! Now cannot start working! 1602404099322,2020.10.11 08:14:59.322,INFO,SC-FW,SC req -> failed 1602404435449,2020.10.11 08:20:35.449,INFO,SC-FW,SC req enclosure sta 37081,1970.01.01 00:00:37.081,INFO,SC-FW,success to create marlin task! 37134,1970.01.01 00:00:37.134,INFO,SC-FW,SC req Exception 37137,1970.01.01 00:00:37.137,INFO,SC-FW,SC req enclosure sta

looks like it tried to heat the hot end several times without success, then went into a system failure error of some kind. maybe there was a short with the heating resistor? hard to know but, i’m out of ideas.
support@snapmaker.com

Sorry way over my head can you numb it down a little.
Things seem very slow today so you think it’s not a settings problem?

no i dont think it is a settings problem. if you want to try resetting the firmware you can (i doubt it will hurt anything). to make the file just open up notepad, type “M502” then save it. after that in file explorer change the name to “reset.gcode” transfer it to the SM2 using a USB (dont think luban will do it but you can try) and run the code from the touch screen.

and i might have broken @brent113, i see him trying to reply but nothing is coming out :rofl:
if i did something wrong dont be afraid to call me out, i wont take offense :slight_smile:

@LordKain This won’t help simplify, this is more for @Atom. Atom, you definitely broke me, I’m reading the firmware and it’s past bedtime. Trying to make sense of those errors.

Looked through the firmware to see what can throw that specific error of “NOW cannot heat hotend!”

  1. No toolhead on the canbus (with additional error “cannot detect executor!”)
  2. Connection to the toolhead lost (with other errors also thrown, like “Executor Lost!”)
  3. Bad sensor (with error “Detected error in sensor of Hotend! temp: %.2f”)
  4. Temperature overrun (with “current temp [%.2f] of hotend is more higher than MAXTEMP”)
  5. Abrupt temp drop (with “temperature of hotend dropped abruptly! temp: %.2f”)
  6. “Sensor Come Off” error, (with “Thermistor of hotend maybe come off! temp: %.2f”)

The other error is “Now cannot start working!” That has all of the above causes, and additionally these causes, with associated additional error messages:

  1. No Linear Module (“Cannot detect any Linear Module!”)
  2. Machine model detection error (“Cannot detect Machine model!”)
  3. Linear module lost (“Linear Module Lost!”)

The thing that’s puzzling me is the lack of those additional log messages that would help narrow it down further. They are all logged using the same log function call. The detailed messages are logged in the StatusControl.cpp document, and the general one for all hotend heating errors is logged in the temperture.h file, in the setTargetHotend(temp) function.

It seems clear that the hotend temp was commanded to be set, then the hotend error was thrown. Then the touchscreen was used to start a job, and that caused the “cannot start” error.

The list could be shorter, but I think the conclusion is there’s only a few things to check.

  • Sensor is reading a reasonable value before setting the hotend temp.
  • The machine definitely knows it’s a 3D printer, and the toolhead options are present.
  • If it’s heating, it isn’t overshooting so as to trigger an error (haven’t looked at the specific requirement to trigger that error).
  • There’s no abrupt changes in temp, either up or down

I have emailed support, let see what they have to say.
Thanks guys I really appreciate it I might try and reset the firmware while I’m waiting.

It can’t be over heat or abrupt change, it says in the log the temps its reading and the time frame, it is only waiting 30seconds before throwing the can not heat error. So probably disconnected print head. Thanks for the explanation of errors.

Golly. You’re right. I didn’t look at the unused one. Now I really have to open it up and have a look.

Just thought I’d add a comment on the disconnected print head.
The hand controller is still reading the ambient head and bed temperatures.

Also I just tried the “M502” file and the controller can see the file on the usb.

The strangest thing just happened.
I thought I’d plug the SM into the computer just for the hell of it.
It connected to the PC and I could heat and load filament from the connect screen in Luban.
I’m now just trying to print something basic from the controller.

2 Likes

Well, just checked and no, the settings weren’t saved over WiFi. It did improve the print quality in the prints I did immediately after, but it looks like I lost the settings when I turned the printer off.

2 Likes

Sorry for the long delay real life gets in the way at times. So after all the connect problems I had been having with PC’s and Mac’s I decided to try out Octopi and it worked great. Thanks to halr9000 for the post above. I’m still try to get the full setting right but the calibration worked great.

2 Likes

so those of us who have the printer to far away from a PC to connect to it via USB, if you have an OTG cable (availible on Amazon) then you can download a free app called “3D Fox” and connect via USB->OTG to the SM and get full console access. this is how i currently do all of my calibration and console commands so i know it works and works well.

1 Like