"Bump" in Y-axis

I have the same issue and is in contact with support.
So far it seems my 2 Y-axis linear modules travel different lengths. When commanding 340mm with the touchscreen one module moves 0,9mm longer than the other. This leads to a bump when one decides to halt and wait for the other(when bed is bolted on).
Don’t know yet how this will be solved.

@General_Tux @danieln This is a good step forward in finding a solution, thanks for sharing.

I wonder if the solution will involve adjusting the eccentric nuts that tension the carriage against the rails…

Confirmed, at least in my case, the problem comes from different Y-module working speeds.

I have set up the following rudimentary way of measuring this difference:

And this is what happens after moving the Y-module 330mm in the -Y direction:

If moving it back to the first position, both marks match up again.

Now the tricky question, how we fix this?

2 Likes

That’s brilliant, nice test jig!

Really interesting find that it matches up when you go back. That sort of eliminates skipped steps as a result of a mechanical issue, because those would not be made up since these modules are open loop control.

Is this issue limited to the Y axes? I have so many questions, so many things that could be tried. Swap which Y splitter is being used? Try one module at a time directly to the controller with no splitter and see if they both go the same distance? Swap another module into there? Try swapping the Z and Y cables at the controller and see if the problem stays with the Y axes or does it move to the Z axes?

1 Like

Clever thinking!
Not sure: How much tolerance is there in the lead screws? It almost looks like one lead screw has a slight difference in its slope as compared to the other.
Potential quick fix: Remove the X-axis module and try if a combination of one of the Y-axis modules and the X-axis module yields consitent results. Then use the deviating module as X-axis module.
Still, I’d contact Snapmaker support, since in the end it’s a production error IMHO.

1 Like

I’ve solved the problem! At least for myself, hopefully there will be other lucky people.
After reading the Snapmik’s comment, when they’ve realised there’s a difference in the linear module speeds, I’ve tried the same and got the same result. And indeed it comes back to the same state when you go back along Y axis, so it’s a different steps/mm for the modules.

I’ve decided to check how other linear modules behave. I had to disassemble the printer completely.

And make a bunch of primitive tests. Put the modules side by side in pairs, connect both to Y axis, and try the same experiment. It’s almost like horse race, you can even bet on them!
That’s how it looks on the max Y (sort of 350mm on A350 I guess) after perfectly aligning the marks at the start.

In the end I found 3 modules with exactly the same speed. Two others are around 1 mm “shorter”, and nearly the same. Not sure if truely the same, but my experiment precision is not great.
Anyway, I can put two “shorter” once to Z axis (since it’s very long distance between them, I guess it can tolerate a slight difference, even if it exists). Three others would make X and Y.

Also I’ve noticed I had some issues during CNC, when calibrating the head perfectly on the left corner, there’s ~1mm gap on the right side with the same programmatic height. I guess that’s where my other “short” module used to be, so it should be fixed now too!

I haven’t tested the result yet. Moving home, so I had a good opportunity to disassemble the printer, will assemble back in 2 weeks to try. But I have a really good feeling!
Hope it helps somebody.

8 Likes

Yes, I can confirm that this solution works. I changed last weekend one of the Y-axis modules by the X-axis one and the “bump” has disappeared.

However, I believe that this issue is only another effect of a bigger problem: the non-uniformity of the lineal modules working speeds.

I have opened a new topic to discuss this in its full depth: Non-uniform lineal modules working speed

1 Like

I think that this issue might be caused by the speed difference between the Y axes. Could you please measure the travel length of the Y axes? I think that may be the cause of the failure. Here are the steps for your reference:

  • Dismantle the heated bed, platform from the Y axes so that we can see the movement of sliders.

  • Power off the machine, push the sliders to the foremost end of the linear modules and make sure they are in the same level. Place the laser work platform across the two sliders, making sure they are on the same level.

  • Here is a video for your reference:
    https://drive.google.com/file/d/19xjeb5s1dMRbnwk8myizW6YtPPk_VasJ/view?usp=sharing

  • Then power on the machine and click “Home” in the touchscreen. Please check if the sliders remain at the same level as the laser platform.

  • And then you can control the sliders via the touchscreen. Make the two sliders 200 mm lower and check if they remain at the same level as the laser work platform.

Could you please send me some images of the result so that we can confirm if the two sliders can move in sync?

1 Like

After reading all of the above, it seems clear to me that the issue is inconsistencies in the lead screw tolerances. Most cheap lead screws are not consistent and have a wider drift than an expensive screw. If it were steps missing or a driver speed difference, I do not believe the modules would return to alignment when sent back home.

tl;dr
It has to be mechanical in my opinion.

Hi Edwin, thanks for your answer.

The experiment you suggest has already done and published here in answer 38 of this same topic. Some of us conclude that the problem was caused by the speed difference between the Y axes. After changing one of the linear modules with the X-axis one, the problem has been solved.

You could also have a look to this other topic for further reference:

Regards

2 Likes

Just received my A350 2 day’s ago. Here is the short story, this product is not ready for the marked - and here is the long story.

1: Yes I also had a “bump” on the Y-axis. The one of the actuators trailed almost 1mm longer than the other, I measured all 5 actuators to one another, only 2 of the five travelled the same distance!

2: I was part for the early adopters with 1st gen Snapmaker, the actuators at that time, also had problems, but they were much more “thigh”. The axis with the 3D printer head almost wobble 1/2 mm when it changes direction, so also the internal sled is having troubles. Way to wobble when comparing with the old one.

3: No firmware was loaded into to the controller.

I will upload some small videos to show the details.

But all in all The Snapmaker Family is having serious QoS problems, and I hope that they don’t break their neck, it’s going to cost them a fortune to replace all these linear modules/actuators.

And then we all are fucked with a machine that newer will fulfil our wating time :

I will send all of my collected data to SnapMaker support, please everyone due this, we have to stop them from shipping more units out before they have fixed this, both for the client sake, but also for SnapMaker – We need them to survive.


I have requsted a Warranty Request, these modules are no good
Br Amdi Denmark

I wonder if it would be reasonably possible for us to replace the existing lead screws with higher quality ones?

1 Like

That’s what I’m thinking of doing. If someone has a linear module disassembled and would care to provide an accurate measurement of the total length of the screw, that would be great. I have an A350 but we should probably gather the dimensions for all three models of SM 2.0.

1 Like

Its very disappointing to see that there is so many of us… I really hope that Snapmaker will come up with a solid solution! And that they survive this crisis… its a fantastic product if it only would work like its supposed to!
At least Snapmaker support have replied to me and they will send me a replacement module. I hope the replacement will behave better! I only need to figure out which module i need to replace! :stuck_out_tongue:

Wow. There is a lot of people with this issue I see…

1 Like

It’s really hard to know how many or what %.

While any is too many, and there has definitely been a lot more than I’d want to see, the people who aren’t having problems aren’t posting.

-S

1 Like

Hello everybody

I’ve been having issues with the Y-axis modules but I’ve tracked it partly down to the carriage bearings being faulty.

But this could possibly be why the bearings have failed and would explain why I was having such bad wobble on the bed. Very interesting thead!!! and could be the cause of linear module failure with others.

~K

1 Like

Hi @MrEcho. I can’t recall if you got in touch with support? Did they acknowledge a defect and offer a replacement? That seems to have been the solution for the other lead-screw related issues here. I’d expect the premature bearings failure would also be a warranty replacement.

1 Like

Sorry guys, but I haven’t understood this part. Where is that inconsistency?

In my case the problem solved when changing one of the Y-axis modules for the X-axis one after checking that it moved at the same speed of the other Y-axis module.

in the lead screw inside the linear rail. the lead screw is what transforms the rotational force into a linear force. it appears that the thread pitch on the lead screws are not consistent from rail to rail. that is why you had to switch them around until you found 2 that where consistent with each other.

2 Likes