Bug: Luban 3.15.1 3D slice not showing all the layers


If “Z Hop When Retracted” is enabled and Skirt or Brim is used then only half the number of layers i shown for the sliced model.
All layers are in the generated gcode file they are just not shown as layers in the window. The complete number of layers is halved in window and the first half of the layers are shown in layer one. Layer 0 only shows the Skirt or the Brim not the model it self.
If you are using Raft of None then the number of layers is correct.
It is easy just to see enable or disable “Z Hop When Retracted” when using Skirt or Brim.

The time and how much filament will be used is the same and correct.


Hi Christian. I made tests with the steps you mentioned, enable the Z Hop Whne Retracted and add Brim, but I am not able to recreate the problem. Please share some screenshoots here.

I am having a similar problem. Slice number shown in Luban do not correspond with the slice numbers in the code file. Trying to place an M600 command in a very specific place in the file and am using trial and error at the moment.
I understand that if there’s a raft then the code starts with minus numbers and counts upwards to the actual model, also I think slice 1 on Luban corresponds to slice 0 in the code. This still doesn’t help me work out the numbering though. I’m going through PLA like water with my trial and error system. I think I’m putting the M600 command in the right place, that’s the last command before the slice I want the new colour in.