40W laser running out of boundary (lightburn)

Same Here #metoo I am working on a remote USB option that may be a good workaround.

Same problem here with the mentioned workflow (Lightburn → nc → File transfer via Luban).
But i figured out that some laser cutting worked, while others running out of bounds.
Comparing the working with not working projects i can see that the working projekts always use absolute coordinates (after G90 command) while the not working projects also position the laser first with absolute coordinates, then using gcode Command G91 (switching to relative coords) and uses relative coords further on.

I assume that Snapmaker Artisan firmware ignores the G91 command and interprets all coords as absolute regardless of G90/G91 commands. So this seems definitiv to be a bug in Snapmakers (at least Artisans) firmware.

There is also no workaround because the generated gcode from lightburn mixes absolute/relative positioning (fill always uses relative while line always uses absolute).

My fazit: pure Laser cutting should be working because there is only absolute positioning but other projects with Fill/Offset fill Modes don’t work due to ignore the G91 command

@darien: i think your solution works because your project only uses Line Mode

Regards Michael

@krash94 @drspringer @jedimasterjsa @darien @schleuss @Fabian997 @AtTwoAm @mchytracek

Good day to all. Our product team has identified this issue and it will be addressed in the next firmware version. In short term, we recommend using a Direct connection for Lightburn. Sorry for any inconvenience caused.


Thanks for the [news of a future] update.

thanks a lot - eagerly awaiting it!

updated both the printer and Luban and retried. Indeed, i have less problems with the release (i can laser Lightburn NC files) - i still have SOME problems with the offset, but need to do more research to give constructive feedback.

Also, notably, i was unable to download the firmware update on the printer via the touchscreen. It got stuck at the “Downloading XX MB” message, and never finished the download. Downloading FW manually and applying from USB stick worked.

I will follow up with more feedback once i have tested it more.

The new firmware V2.5.23 is available since today.
I have not tested yet but maybe someone else wants to do

I was finally able to try out the new firmware today on my A350 and it does indeed seem to have solved this problem! Now I just have to dial in all my other settings haha. Thank you for letting us know about the update @Zoe and pass on my regards to the dev team!

1 Like

Hi all.
I tried my 40W Laser first time today with same issue as reported here!
I have the latest Firmware on my Artisan (V2.5.23) and nothing changed.

I used LF to create some material Test patterns and all of them are going out of bounds.

Hi Sascha,
First: in Lightburn use the machine profile from here: Using Ray / Artisan / 2.0 with LightBurn | Snapmaker Wiki
Second: in Lightburn follow the instructions from Gil from here: Lightburn Gcode compatibility with Snapmaker Artisan 40W - Snapmaker - LightBurn Software Forum

These Steps worked for me. Running bounds on Artisan does not function properly but if you position the Laser in the bottom left corner (Lightburn Start from current Position, Job origin left bottom) all works as expected.

Regards Michael

1 Like