3D printing does not start in 4.2.2

I have installed new version 4.2.2 and now my 3D application does not start when I select 3D printing on de main page. What do I need to do to solve this problem?

I am on a Mac Workbook version 12.2.1 Monterey

Please give me something to start on. Can you provide screenshots of what is happening? (Crashing, Not Downloading, etc.)! Also some basic things make sure your on the mac version. If still doesnt work try getting directly from the github. GitHub - Snapmaker/Luban: An easy-to-use 3-in-1 software tailor-made for Snapmaker machines.

Hello Redcraft10,

Thank you for responding.
I am sure on the Mac version.

There is no screen picture to be made. What happens … is nothing.
So, when i start Luban the initial screen is shown allowing you to select either 3D printing, CNC or laser.
If I select 3D printing nothing happens. No error message, no nothing. I can also not select any other menu item.
I can select any other menu item before I select 3D printing.

I need to Force Quit Luban to exit this state.

I have already re-downloaded from GitHub yesterday. It did not change anything.
I have downloaded the previous version of Luban.That is still working. So I was able to start my 3D printing job after downloading the previous version.

Hope this clarifies the situation a bit.

Thank you again.


In the past when someone has had an issue like this on a mac they’ve solved it by completely removing all traces of Luban. That means a search including system and library folders and deleting all preference files, etc. Then re-installing Luban.
Haven’t seen anyone need to do this for a while, but it could be the case again.
Just remember to make note (screen grabs?) of any saved settings since this will erase them.


Thank you for the tip.
I have tried it. Removed everything of Luban from my MAC and installed version 4.2.2.

Behaviour did change but not enough. I now got stuk on loading a project for 3D printing. See screenshot.

It does not recover from this.
Also the application is not locked. When I go to Force Quit to allow to continue using my computer, the computer does not indicate that Luban is not responding.

So I go back to version 4.2.1.

Is there anybody who can help. 4.2.2 is still not working :frowning:

It appears 4.2.3 solved the problem.