3D print on top of a model already adhered to the bed

I have a snapmaker 2.0 A350, and am playing around with making some Christmas themed things. I was hoping there was a way to make a print where I could print a small cylinder with red PLA as a base, and then print some lettering on top of that in green. I was planning to load each model into Luban separately, print the red base first, change out the material, and then tell Luban to print the green lettering starting at +1mm in the z direction. My first question is would that work. And the second is how do I adjust the Z axis location in Luban? I get a Arrow that looks like I can drag it in that direction, but it always snaps back 0. If it matters, I’m using Fusion 360 for my 3D modeling.


This is a problem that has multiple solutions. Here’s 1 option for Luban:

  • Make the final model you want into a single model and slice as if it would be printed with a single filament non-stop
  • Find out the layer numbers where you want the filament to change in Luban.
  • Manually insert the gcode M600 before the layer where you want the change. This will pause and allow you to change the filament before continuing.

Another option would be to use Cura to slice your models with, and then use the plugin called PauseAtHeight to trigger something at the Z height you want


If you really want to do this with separate models there’s ways, but they get even more complicated and I would probably recommend against it.

Thanks. I found another way that seems to work alright. I created a body in Fusion 360 that was split to cause a small block to be printed up to the height I wanted, and then would move to print over top of the different colored base: Imgur: The magic of the Internet. I just made sure to tell Luban not to generate any support when slicing, and it printed out ok.

In the future you can also just modify the gcode by adding a G1 Z..., G92 Z... command to tell the machine to print at a different location

So I did try the M600 addition today without much success. I had a single model, added M600 after the top layer of the first color. That did cause the snapmaker to pause. It moved the print head to the bottom left, but gave no indication or ability to change the filament. I was expecting to see the filament run-out screen on the touchpad, but all I got was the typical screen it shows with the percent complete and the pause and stop buttons. I thought maybe I had to hit the pause button first, so I did, but that completely broke the print - had to kill power to the printer as the touchscreen would no longer respond to the buttons.

You should give feedback to support or the developers then, last I heard that feature worked. Haven’t tried it in awhile though.

You do have the latest firmware?
Just wanted to double check, because M600 wasn’t recognized until a couple versions ago. (Will technically it did recognize it and would pause, but there’s no way to resume)


Heh - I just realized to check that right after I posted. I’m not sure what version I have, but I think that’s the likely culprit. I don’t think I’ve updated since M600 became recognized. I’m in the middle of a print right now, but will check the firmware version once it’s finished.

Firmware version was, indeed, the issue. I updated to the latest, and M600 worked just fine. Thanks for the help.