SM2 Bed Leveling

I don‘t have this icons… just 4 (like i posted before).
Is there any option „expert mode“?
Beta-Tester?

I do only have 4 Icons, too.

Touchscreen Version 1.5.2.1 / Controller Version 1.6.0.0

I’m not suggesting that the bed heat up faster, merely that autocalibration wait for the bed to heat up prior to running. You’ll have to explain why the current PSU can’t do this.

Also, I’d love if my firmware had the same option @DroneOn has to disable auto-leveling prior to each print.

I only see 4 icons. I wonder if your TS slipped thru with some kind of debug mode turned on?
@parachvte?

1 Like

Yeah, same here.
Want this mode/option too!

There is a factory menu on mine as well but it is all in Chinese so I have no idea what it says

Dead Pixel test
CPU performance test
Wifi Signal strength test
Display brightness test
Touchscreen test
and Bluetooth test

Mine had the 6 icons, including Experimental since the I set it up without any changes being made to the settings that I can recall.

Thanks for the tip about turning off the quick calibration. Using it and turning off auto leveling calibration permitted me to set up the leveling manually and now no more minor gouging or too high off the bed for parts of the initial level to stick to correctly.

I hope they fix this and the ignoring M104, M140 codes (after the first). I welcome back being able to have the initial level level extruder and bed heat settings to be one and then drop 20C for rest of the printing to avoid as much stringing and nibs as possible.

I’m going to pile on with the leveling issues. I’ve run the calibration several times and am simply trying to print a large flat object, but I cannot get a good first layer, regardless of what I do. It is very clearly not getting an even first layer, with certain areas being flattened properly, too much, or not just barely touching the build plate. It’s making it very difficult to use.

Thanks for the translation. I don’t seem to need any of those options but my hope was that there may be a way to turn on the options I have for others that need them.

So I designed a holder for a dial indicator (which I’ll eventually post on Thingiverse) and scanned my bed and it’s all over the place. My question is when you’re in the movement screen, is the bed leveling system active? @parachvte ? I’ve been thinking about a little and it seems to me that the bed leveling compensation should only be in effect when you’re close to the bed and slowly be phased out as you move away from z=0. Otherwise your whole part is warped to match the shape of your bed. Anyone know about the guts of the marlin leveling code?

I finally had some more time to investigate. First off - I did get a machine where I can turn off fast calibration.

I spent some time placing small test models all over the print surface and ran a run boundary, and watched as the nozzle distance to the surface fluctuated wildly. Could this be a problem with the mat, or is the actual heated print surface underneath really THAT NOT FLAT, or is the calibration sensor that wildly inaccurate? I haven’t messed with the print module, adjusting the sensor and all that yet… maybe that’s what I have to do. :confused:

Update: I went in and manually calibrated the leveling, and ran the same test. It’s still all over the place. I would say there is a 0.1 mm difference between some high spots and some low spots, making a full calibration over the full board really ugly.
I still haven’t messed with whether this is the mat or the heated bed. …

@Tone It should be in effect otherwise higher layers will not match with lower layers.

@Tone @DroneOn @Raptor @onyx0909 @Jayberz For the guys mentioned about the “icons”, there is an way to turn on dev mode of TS, with 2 more apps “Factory” and “Experiment”.

But I don’t recommend you to turn it on since only very few options people would need (unless you have a bed leveling issue and want to disable to fast calibration before print), and contains options that are debug-only that will cause the TS to crash (you will have to reboot TS when it’s crashed).

Here is the routine to open dev mode: Go Settings -> About -> Tap the image on top for 5 times to activate dev mode (Tap once more to inactivate dev mode). The option to disable fast calibration sits inside “Experiment” app.

Next week we will have a firmware update, adding a quick fix for fast calibration and some debug functions. To let our early adopters to export logs, which could help us to precisely describe the issues we met, and the steps taken that lead to the problems.

Thank you all for the patience and your effects to make our product better :grimacing:

3 Likes

Thx.!
Actually i tried the laser, it works great!

I‘ll change again to 3d print and try out with complete manual calibration and without auto calibration before print on a glass surface.

I hope it’s a softwarebug only.

Maybe we can have a test on this. :slight_smile:

In reading about it in the Marlin documentation it does support the phasing out of the bed leveling warp. There is a “F” argument which describes the region height that the warp applies to. If the warp was great this region should probably be tall, but if it’s not that region could be short. It’s called the “Fade height", defaults to 10mm if no value is given. This is very smart. This only applies to “UBL” style bed leveling. I would hope that SM would use this and take advantage of larger matrix sizes (i.e. 5x5 perhaps).

2 Likes

I activated the developer menu, deactivated the auto calibration and actually i print on glas.

Works fine!
I hope we find the problem. But actually i prefer the ultrabase.

If the glass was stuck to a sheet of metal you could still use the existing sensor and magnetic base. The glass just couldn’t be too thick. I know our glass on our Lutzbot at work is only about 2mm thick. (And, ha ha, we have some plastic stuck to it! Something 3m makes (PEI) especially for 3D printing. BTW, that stuff works quite well compared to the glass which I thought worked fine.)

Here’s a link to some:

@Tone from what I can tell the SM2 is currently using bilinear and not UBL bed leveling.

1 Like

I recommend the ultrabase from Anycubic

For the SM2 at 310x310mm for about 30€.
Works really great! (Auto cali must be off!!!)


(Fixed provisionally)