PLA Stick to Side of Nozzle / Delayed Extrusion

I have been printing for a while now but I seem to always run into this issue, when the print head makes a move, sometimes but not all of the time, it seem to not extrude right away and, when it does, it has a tendency to stick to the side of the nozzle for a few millimeters and then it seems to come in contact with the bed and away we go.

This has caused several issues when printing lettering, it will do the first one just fine, then move to the next and stop extruding or it will be on the side of the nozzle, fall off leaving a blob, and then keep going.

I have leveled the bed in every way, shape and form I can think of and I have switched the nozzles as well. I have my extruder and my slicer both calibrated and I have a K factor set at 0.07. I was thinking to set it back to factory default and attempt the whole process again and see if I can get this little issue to go away, however, I would like to see if anyone else in the community has had the same odd issue.


Sounds like it could be filament related. Old filament? Have you tried drying it or trying new filament?

Could also be temperature related.

Is it possible the extruder gear is slipping? Do you notice any gouging on the filament?

I’m sure there’s other things as well.

If you want to try a factory reset, save a copy of the M503 output a) so you can go back to it if you want and b) so you have something to compare against.

I have not seen anything in the filament that would show a gouge, the small teeth marks on the side from where the gear is grabbing it. Temperature it could be, I am at 200C and things seem to flow well.

Filament is brand new out of the box and I have tried several others and they all appear to have the same issue, I am leaning towards a Liner Advance issue as it seem that the extrusion is delayed and, with my admitted limited understanding of the marlin code, that can be solved by K factor.

As well I agree on saving of the old config, always need a baseline.


Yea, linear advance would do what you’re experiencing. Follow the instructions here:

I’d recommend running the pattern generator a few times, first with 0.05 increments for a coarse adjust. Pick whichever looks the best and then rerun the pattern generator in 0.01 increments. If you suspect 0.07 may be close, but under, you could start at 0.07 and go up in 0.01 increments.

First, a sanity check: Linear advance that’s too low will do a line with underextrusion at the start, and a blob at the end. Linear adv that’s too high will do the reverse, blob at the start and thin at the end.

Make sure you’re seeing that on a test line, too much width at the start or end and the opposite on the other end.

If you’re only seeing under at the start and nothing abnormal at the end that is not linear advance.

I just went and ran the test a few times and changed the K factor, I am running my major test now to see if anything changes.
The more I look the more I am not sure what it might be, I am considering everything at this time, including sanding down the PEI sheet I am using, and putting a print guide in as maybe it is the stress/angle of the incoming filament that is causing some issues.

That’s a good thought - there should be as little tension in the filament as possible. That’s easy to test, supervise a print while making sure there’s free slack in the filament coming into the toolhead.

Other people have had issues because of that, particularly with the enclosure, the bushing and the filament path put too much tension in the filament. I used a teflon tube in a bushing and a guide on the tower to assist with that, others have relocated the filament inside the enclosure or above to reduce angles.

I am going to look at printing off a guide to try and stop any issues from that.

I do have the encloser so that MIGHT be an issue but I still am thinking that there is something else going on as I have never seen anyone else speak of the newly extruded filament attaching to the nozzle first. Almost like it want to go and hit the nozzle again.

At the bottom of my post here: Snapmaker 2.0 Initial Calibration Settings / Experiences, I linked 4 things I printed regarding that. Filament holder, roller bearings, guide, and ptfe bushing.


So I did print off the guide, works awesome and fixes the issue with the filament getting snagged. However the spool holder screw in parts are so sticky, I have been working them in for a better part of a day, and got it stuck once before finally getting it back together. How long did it take you to get that part worked in?

yes, that was a bit of a pain. I recall working it in a very small area at a time, but quickly, it will heat form the threads. Took me maybe 30m of hard work I think.

You could reprint with a slicer that allows you to cheat the outside dimension by a small amount to give some more clearance, you might have extrusion issues.

Well I have worked the thing to death but now it works very well!

Seems slowing down the first layer speed plus the addition of the guide and the filament holder has helped.

Onto the next issue, missing first layer after a long travel.