Luban 3.5.0 Zooming in on 3D model

I’m very new here and don’t even have my Snapmaker yet, but I wanted to play with the software. I’ve managed to load an STL model into the 3D print G-code generator screen but when I try and zoom in on the model to check it out the software only wants to zoom in to the center of the print area rather than to the center of model. Is there a way to change what your zooming in on?

-Chris

1 Like

hold down your right mouse button and move the mouse to move the image around, up and down. if you have a scroll wheel, you can zoom in/out

2 Likes

Thanks, that does the trick!

2 Likes

How do you zoom without a scroll wheel or a pinch-and-zoom touchscreen?

Using a Lenovo X1 running Debian to preview prints. Tried all key combos of Ctl, Alt, Shift with the arrows, PgUp/PgDn, +/-, and mouse-drag.

Rather surprised there are no zoom +/- buttons.

In the bottom right there are ‘+’ and ‘-’ icons.

On Mac it’s option to tilt.

-S

Ah, I see - those were offscreen, and I didn’t realize there was more to the app because of electron’s ill-advised “featureless white room” aesthetic.

I also found the Case Library and Settings down there too. Thanks!

1 Like

Looks like the “+” and “-” buttons are off screen for me as well. How do you see them, or get them to apear?

I had to move the window to get them onscreen. For me this was Alt + Right-Click + Drag, but I use a pretty nonstandard window manager that gives me a lot of control over window behavior.

Basically you need to resize the window, and I recall that it defaults to Maximized (which prevents resizing). So you have to un-maximize (minimize?) the window, then resize it using one of the bottom corners.