Lightburn GCode Inverts Light and Dark on Photos

Would you be interested in running this edited version and seeing what happens?
2 changes: 1) M03 P0 -> M5, and 2) G1 after an M5 -> G0 since it’s a non laser move (726.1 KB)

I sure can. Thank you…I will let you know what happens.

Just tested and it is printing inverted.

In the Snapmaker JS…there was no M106 P0 S255 but there is in the Luban gcode. Do you think that may have something to do with it?

M106 is fan speed. Not going to be that.

Which version of the firmware did you say you’re running? 1.9? Maybe try the latest version?

I finally brought it up to 1.10.1 yesterday hoping that would work but sadly no. I feel like we are close to figuring it out but that could also be wishful thinking.

Interested in trying a brand new unreleased firmware from their github? Firmware request: Tool Change Mode with enclosure lights left ON

That firmware is based on what’s currently on the Snapmaker dev site with 1 small tweak unrelated to what you’re doing here.

Sure. I will install it and try again.

Still experiencing the same issue.

Interesting. Well I’m fighting an issue elsewhere in the firmware where sometimes an OK response isn’t send when it should be, which breaks Lightburn - serial connection is dropped, killing the print in progress.

It seems like your issue could be comms related as well, like the thing is parsing everything 1 command delayed??

Don’t really have anything else to add right now, other than SN is buggy as hell and it’s really irritating.

There a bunch of other things that could be tried, but it’s just guessing now. :man_shrugging:

I agree that it is very irritating and I appreciate all of your assistance and suggestions. I have a support ticket open which is my last resort before I buy a cheaper laser engraver that will work with lightburn. Hopefully you’ll resolve your issue and if you want me to test any firmware updates…just let me know.

Thank you.

After I unbrick my controller tonight I’m going to spend some time running your code with a debugger and see if I can find anything. I need a break from my issues for my own sanity lmao.

In the meantime, I have had good luck with the Lightburn greyscale mode which does lines of varying power for images. It requires a special version of firmware I posted elsewhere: Laser Pause While Changing Power

I feel your pain with these issues.

I will update the firmware with your version and see if I can figure out greyscale in the meantime :slight_smile:

Has there been any movement on a resolve for this issue that I am also having?
Maybe Snapmaker and Lightburn could communicate and make nice-nice to solve the issue?

Hello…I posted this in another thread but here you go:

This is what my experience has been. We cannot use passthrough. I know that a lot of LB users use Imag-r or Da Big Gimpin’ plug in to pre process the image and when it is loaded into LB you are advised to use passthrough but don’t use those other products because SM does not seem to understand what to do if you use passthrough. In order to get out of the dithering inverted picture issue, I uninstalled LB including deleting the folder in programs and installed version 0.9.16. Newer versions may work as long as you never use passthrough. Before I uninstalled, I cleared out the LB preferences by going to File - Open Prefs folder. Once the folder is open, close out of LB and then delete everything in the folder. Once the folder is empty, then I uninstall. This has worked for me and everything has been good as long as I don’t use passthrough.


Thank you. I will give your process a try.

I tried your method and things are working correctly now!
Thank you!

1 Like

I though I had it working, but now it’s back to burning junk again. Tried the process over again with newest version of Lightburn and even reloaded firmware and still getting junk, never enabled pass-thru either.
This is beyond frustrating.

I have the same problem. So I did some tests and came to the following conclusion. The problem with the Snapmaker 2 is that lines are made way too fast compared to burning time of dots. I got halfway usable images when I reduced the speed and power significantly. But this means there is no advantage over the Snapmaker Original’s 200 mW laser. The same problem also with the line mode in Luban.

1 Like

Users can set the dwell time in the toolpath list.

Yes, I know how to set the dwell time in Dot Mode. And Dot Mode works fine. But not when set to Movement Mode Line (Normal Quality).

After consulting with our software engineer, he said that they do not have a plan to add the dwell time feature in Snapmaker Luban 3.16.

You guys can pull a request on our Github page: