Full Lightburn Control Guide

Everything looks correct. When I get home from work I’ll do up a test file to troubleshoot further. In the meantime, try the commands in the console in lightburn one at a time.

G0 Z23 F6000
G92 Z0
G0 Z300

It should home, change to machine coords, move down to your laser focus heigh, back to work, set Z origin, and then move back up. Put them in one at a time and watch the machine. Let me know if it does anything strange.

At the moment, I’m back to printing. But this behavior occurred to me after aborting a laser run, and restarting it. Seems that lightburn doesn’t send the initial gcode everytime. After restarting lightburn it worked again normally.

The above commands worked fine. No matter how many times I switch the system on and off and reboot Lightburn the laser head remains at the heiest point of the X axis whilst lasering my project,

I may add that in my Snapmaker setup I keep the heated bed attached to the table and I have the laser base plates stuck to a 1mm thick sheet of mild steel placed directly onto the heated bed. This is for easy swapping for printing or lasering. Until lately I have used Luban very successfully for lasering. However this adds about 4.5 mm to the height of the bed so I assume my laser height should be 29mm plus this 4.5,

While I don’t know your laser focus height, which is listed on the home screen of the touchscreen. You saying 29 here makes me think that’s it. If you did the calibration with your setup, your laser height should be correct, as it should be measuring to the surface you had touched down on. However, for safety, I’m going to add the 4.5 to 29 and make you a new header.

M106 P0 S255
G0 Z33.5 F6000
G92 Z0
G0 Z250
G0 X2 Y0 F6000
G92 X0 Y0
M3 S0

Again, this assumes your offset is the same as mine as well. I’ve also attached a laser file to test. All this does is a 50mm square at the lower left origin @ 1% power (so the laser comes on, but low power). In lightburn just click run gcode to load the file and run it.

EDIT: I DID NOT put in a material height, so it should be running “at zero”

TestSquare.nc (450 Bytes)

Sorry for the dealy in replying.

I made the adjustments as per instructions but still the head remains at the highest point.
I dont know if the version of :Lightburn matters but I’m using 1.2.04


Your lightburn version is fine, it’s the same as mine. Could you take a picture of the about machine screen in your snapmaker? Also, could you generate a small project, such as a tiny circle or something, then click save gcode and upload it so I can review it and see if I get the same results?

Hers the Gcode and an image of the ‘About machine’


Circle.nc (3.0 KB)

Preliminary look, everything seems in order. I did note, however, you might have relative Z moves only ticked. There’s no material height movement set in the gcode. So after it runs the header, it just stays up at the top. Even if you forgot to set a material height, it SHOULD do a G0 Z0 before main movements. Double-check your lightburn settings. I can’t run the gcode right now to test, as I’m at work, but this is what I noticed just glancing over it.

EDIT: Running your gcode, it acted as expected. Homed, came down to set the laser height, moved to 0,0. Then the head remained at the top, because there was no Z movement afterwards (meaning either Z disabled, or relative only in Lightburn).

Will this work running files created in Lightburn and transferred to the Snapmaker? or do I have to run it with my computer connected?

1 Like

You can, but omit these lines:

G53 ; Changes to Machine Coords.
G0 Z23 F6000 ; IMPORTANT, the Z value here is your LASER HEIGHT on the touchscreen.
G54 ; Changes back to Work Coords
G92 Z0 ; This sets Z Work Origin to 0, making your laser height as 0.
G0 Z300 ; Moves the toolhead back up out of the way.

from the header. Since you’ll be inputting the thickness on the snapmaker. Should run fine. :slight_smile:

So when I run it (off the USB or connected to Luban), the laser goes to max height and starts running from there.

All but Test2 went to max elevation and then ran the laser. Test2 went too low and pushed the canvas out of the way.

Test2.nc (2.7 MB)
Test6.nc (2.7 MB)
Tets5.nc (2.7 MB)
Test4.nc (2.7 MB)
Test3.nc (2.7 MB)

Oh, whoops, also remove the G28 in the header, it’s a homing command. Luban and via touchscreen sets the Z height, then runs the program. No need for the G28 if the machine itself is setting Z (also it was just a safety line anyway incase you forgot to home after booting. Connecting via Luban forces home anyway)

Do I need to input the material thickness in Lightburn still?

No, if you use Luban/USB exclusively, you can just leave ‘relative Z moves only’ ticked (for multi-pass cutitng). You’ll be inputting the material height via the touchscreen or Luban.

So then do these settings look correct?

Outside of the words Header and Footer, yeah looks good to me.

Big oof lol. I’ll run a new test now.

These are the header and footers I run with my A350 with the 1.6W when configured as Marlin using the firmware at the beginning of this guide. I have my machine set for absolute coordinates and set my Z height manually for each burn.

So I got the laser to run, by using my old Lightburn configuration and manually setting the work origin. The laser is still running like it did before I updated it with the custom firmware, it doesn’t appear to have changed the inline power mode. It’s possible I misunderstood the purpose of the firmware, but I thought that this would enable the inline power, is that right?