CNC program stop-starting at each line

Hi all,

I’m trying to cut some shapes out of acrylic using fusion 360
generating the code and postprocessing to my SM A250 has been fine

the problem I’m having is the machine seems to read one line of code at a time
pausing at each point before moving onto the next line and moving again
causing the acrylic to melt onto the tool or generally poor finished parts

can someone help me smooth the tool path, and have the tool/machine run continuously through the code, please?

Thank you

(SM2.0 Firmware V1.10.1)

Sure. I’d love to check it.

Sure
Thank you
find enclosed fusion project and the output files used

working with 3mm acrylic,
engraving with snapmakers ball nose, and cutting out the template using a 4mm two flute end mill
(I broke the snapmaker flat end mill)CutFob-01.cnc (187.0 KB) EngraveFob-02.cnc (22.1 KB) FobTemplate01 v7.step (1.1 MB)

Unfortunately I don’t see any real problems in those toolpaths. Are you executing these from Luban or the Touchscreen? If it’s from Luban, could you try running from the touchscreen? You don’t need to do a real cut, just set the work origin somewhere safe and run it without a tool, see if it still pauses.

If the problem ends up being a Luban problem, all I can say is don’t use Luban to send the code unfortunately. Maybe there’s a bug report to be filed there.

This is not related to your question but in Cut, line 16: G0 X-37.917 Y3.014 Z14.000. No feedrate is specified, which can have unpredictable behavior. Typically this isn’t a problem since the default feedrate is a reasonable speed, but with back to back files being executed the first G0 will take the last used speed which sometimes can be quite slow. The same thing happens in Engrave. If you’re not having a problem, it’s fine, but something to be aware of.

Also, that’s a great design, I love it.

1 Like

I’ve been running them from a memory stick using the touch screen.
Actually spent some time tinkering with the settings in fusion; to improve my feeds/speeds, selected geometry etc.
I may have solved (or at least improved) my original problem by increasing the tolerance in the smoothing setting.
the tool still slows right down for tight corners though. It may just be my feed/speed settings…

good spot on line 16, It is good practice to make sure the speed parameters are set properly at the start
I think because the line calls G0, the default rapid speed for the machine is used?
But I’ll keep an eye out for it

Thank you. My partner drew it up using Cricut software, and then I traced it using a Decal in fusion sketch tools and some crudely placed spline curves
simple yet affective :slight_smile:


1 Like

That turned out great! Nice job!

Also, Cricut can export SVGs, which can be imported in F360! Might save you some time for more complicated projects: https://knowledge.autodesk.com/support/fusion-360/learn-explore/caas/sfdcarticles/sfdcarticles/How-to-import-SVG-files-in-Fusion-360.html

I just looked it up in the firmware, and the default rapid speed is 1500mm/min. I think that’s quite reasonable.

1 Like