CNC GCode-starting out above the work piece?

Not sure if this is normal or not, but I created a 2 pass CNC job in Fusion, and I can see the bit trying to carve through thin air on the second pass. In fusion, I created a setup, and did a 3d adaptive clear on the model using a 3.175mm bit. Then I went and did a 3d pocket using the 1.5mm bit to clean up. I noticed that the bit was starting what looked like a clear pass (increasing radial cuts) a few mm above the board. I confirmed that the work piece is basically level. When I did the bit change I left the x/y of the work origin the same, and just reset the Z back to the original work piece face. Is there something else you need to do for a multi-pass CNC run to link the two operations together in the same setup, or is that behaviour completely expected?

Does it looks like it’s spiraling down into the work piece?
Some of the clearing passes use helical paths to start the carving.
So they’ll start well above the workpiece and kind of hover in circles down into it.
You can change some of the settings to reduce the amount above the workpiece it will do this.
If it’s not that, explain in more detail what it’s doing. Like if it’s just carving air for a long time or carving nothing where clearing pass has already been.

So the spiralling down I get, and it’s doing some of that, but there were other points where I could see it going over an area that it’d already cleared. All I did was:
-3d adaptive clear with a 3.175mm bit. I left the heights as-is (clearance 10mm, retract 5mm from top, top 0mm from stock top, bottom 0mm from model bottom.
-Added 3d pocket to the setup with the smaller bit. Heights are all the same as the first pass
-Stock to Leave was cleared on both passes.

It might have just been taking a very liberal runup to the workpiece like you said, but it definitely seemed to be going over spaces that it’d already cut. I’ll have to try another model and see what happens.

Not bad for a first (real) attempt though. I had this on an old hard drive as a vector, so I extruded it out to a few different heights in fusion. Just used a bit of scrap plywood I had around to see how it worked (answer was not very well). Reasonable detail on the letters though, except for the interior of the A. The spaces where I really noticed it duplicating effort were in the top corners (outside the circle) and at the start of the pass (when it seemed to be re-facing the workpiece).

Do you have rest machining turned on in the 2nd path?
That’s how you tell it to ignore what’s already been done.
You can also select boundaries so that the path is contained within a certain area.
Like tell it to ignore everything outside of the inner circle.

Nope…that looks like it was it. Just toggled that on in the options and I got a much shorter second pass. Thanks! I’ll give this a shot on my next test.

1 Like