Changes to Laser options in 4.0.1

Hi Snapmaker team,
I have 2 questions about changes to Laser options in the new version of Luban:

  1. Why did you switch from dots per mm to fill interval?
    I understand the two are interchangeable, so is there any advantage to this change?

  2. Why was the option for vertical vs. horizontal toolpath removed?
    And more importantly, what is the standard currently?
    Perhaps this option doesn’t matter for most users, but still, I don’t see any reason why it should be removed?! So why not let the users select in which direction they want their laser to work, perhaps depending on the wood grain orientation there can indeed be a better or worse option…

  1. This one is strange. I can enter up to 6000 which can’t be right.

  2. I’m not seeing this missing. At least no differently than Luban 3. In vector you can’t change direction. In B&W and grayscale, if you choose line for movement mode then you can select "line direction. If you select “dot” it disappears, but then it doesn’t matter.

They haven’t fixed the padlock to resize png. It won’t unlock still.
Screen Shot 2021-08-23 at 4.02.01 PM

(I’m using the mac version of luban 4.0.1)

1 Like

Still, even for dot mode, I don’t see why Luban shouldn’t offer an option for the dots to be made along vertical or horizontal or diagonal patterns.

And indeed, I noticed that issue with resizing as well, but I forgot to mention it above.

Was multipass removed in 4? I cant seem to find it now.

It’s now “number of passes”:

Why does it matter? It wouldn’t change the result. It’s creating a dot with a momentary burst. With line the laser stays powered on while moving.


1 Like

I thought it should be that easy but it just doesnt show up for me. Is there aditional settings I can open up?

I agree, it wouldn’t change the result on the workpiece.
But it would change how the axes are moving.
And perhaps I - as a user - have a preference for doing the “quicker moves” along each “line of dots” with X and the “gradual moves” between each line with Y. Or vice versa.
I see absolutely no reason why I or anyone else as a user should no longer have this option.

The laser function doesn’t seem to have been properly updated under 4.0.1.
I just wanted to start a job at 65% power.
And I generated the laser code as such using 4.0.1.
Strangely enough, after transferring the file to the machine, it showed up as 100% power in the preview.
I thought this might be a bug and started the job, but the machine then indeed started operating at 100% power…

Please address this issue with another Luban update!
And please don’t release such unfinished and improperly tested versions in the future…
Until this issue and also the constraints I mentioned above are addressed, I’ll stick with Luban 3.15.2.
And if this remains a longer term issue, I have no problem to switch to Lightburn…

hi, edwin is not working there anymore. you can try @staff but they probably wont notice.

regarding light burn, i think most users graduate past luban anyhow so that might be a good avenue for you to look at.

1 Like

If the I set the method to “Fill”, The field for number of passes disappears. From the last few tests I have done it the machine has run 2 passes. I only want to run one pass, but in the future I may want to run more than 2. I was able to adjust the number of passes prior to Luban 4. Will this be fixed?


1 Like

Indeed, I’ve somehow carried on with Luban as I never needed any “special” laser functions.

But the least that I’d expect is for the laser power to be correct as per my settings in the toolpath.
I can’t understand how nobody noticed that the laser power doesn’t get properly exported, but instead that it’s “stuck” at 100%.
And I doubt this is only an issue for me; seems to be a general error.


They probably broke it on the 4.0 or 4.01 update, maybe they will fix it someday


Is there a conversion factor going from Density to Fill Interval? I tried opening some of the older saves I had in the .snaplzr format and they don’t open with the toolpaths saved! If my Density was set at 4 before the update, what would be the Fill Interval now?

The “conversion factor” is:
Fill = 1 / Density

So if you had Density 4 dots/mm before, your Fill will now be 0.25 mm.
That’s why you see the “standard” Fill in Luban as 0.14 mm, which basically corresponds to 7 dots/mm.

I still don’t understand these changes, and I’m still using 3.15.2.
Hopefully Snapmaker will realize the changes don’t make sense and will bring back the old setup.

Thanks, that’s helpful! It doesn’t bother me that they changed it, but you’d think that older version files would convert instead of just blanking it. :confused:

1 Like

The strange thing is that you can enter a value of up to 6000 now. I’m assuming that’s just a case of shoddy programming and testing as seems to be the norm for SM.
So what’s the actual max that creates a difference in the path/gcode?