Z-Axis Extension not working

i have installed the z- axis extension for making bigger projects, i started a larger print and it seemed to be working well until it stopped ascending and just kept printing on the same level, when i stopped and pulled the print off I measured it, the Z-axis stopped moving at 125mm, its like the controller doesn’t even acknowledge that its installed. i cant get anything to print over 125mm without messing up, Yes i have tried switching ports, and the 3D software is configured correctly.

1 Like

I don’t have the extension, but I think I found something in the forums.

Did you upgrade the firmware to 2.11 and tell the controller that the extension is installed?

According to the firmware upgrade notes:

Added support to Z-Axis Extension Module. When you attach the Z-Axis Extension Module to your printer, upgrade the firmware to [version 2.11]. Reconnect Snapmakerjs to the printer. Enter “M1025 M1” in the console and press “Enter”. When the software replies “ok”, your printer is upgraded successfully.
When you want to use the original linear module, enter “M1025 M0” in the console and press “Enter”. When the software replies “ok”, your printer can only print items as tall as 125 mm.
Also, you need to upgrade your software to the latest version and change the settings of the machine to generate G-codes for taller models.

The article has links to the new firmware and software.

3 Likes

You have to perform the above command from the console to tell the firmware you have a longer slide on it. Otherwise it will just stop rising up…

i have that installed seems to still not want to work, i may have to try re-downloading it.

edit: anything i do to the snapmaker i am doing through the provided flash-drive, i have a gaming computer that i edit everything on, and i have the snapmaker in a shop.

I’m not sure that will work. How did you send the M1025 M1 command to the snapmaker?

You have to hook up a computer to the USB port on the snapmaker and you have to connect it thru snapmakerJS and then send commands from the console over USB cable to the snapmaker to change the code. Different than running a g-code program.

Check this… Boot up your snapmaker and then on the handheld controller and go to Setting -> About and report back what the build volume numbers are. If they are all 125mm then you have not updated the unit to the longer z-axis. If one of the numbers is not 125 then you have upgraded it and you need to tell snapmakerJS you have a larger volume.

If the above is correct then Go to SnapmakerJS and under setting (Lower left corner gears), go to machine settings and see what it’s saying the z height is in the software. If it’s still 125mm then that is the largest it will print as the program on your USB key you plug in will be incorrect as the software is limiting it’s height.

There is a custom setting in the machine settings that you can adjust the z height to a taller number. You should really take your computer in, hook up the USB and go thru the process.

1 Like

You are guilty of the same oversight as me…

http://forum.snapmaker.com/t/downloads-and-updates-for-firmware/1467/11

You use the snapmaker.js software. You connect a USB cable from your computer to your snapmaker, and start up snapmaker.js. Press the “open” button (I think its called open), which connects you directly to the snapmaker.

You will see a black window on the upper left that looks like a dos box. Type in the M1025 M1 command, and it should be done. While you are at it, you should probably do a M1005 – this will allow you to confirm what firmware revision you are on.

Just a quick reminder to all: before typing “M1025 M1” in the console make sure that Snapmaker.js really sees your printer. Looks like it says “Connected to COMn” even if there’s something wrong with the connection.

I’ve spent a pair of hours trying to send the command and checking everything before I recalled that I connected the printer to the wrong computer where CH340 driver was not installed :slight_smile:

1 Like

Thanks for this thread, exactly the same issue I faced.

As an extra note, I found that if you create a gcode for the taller print. Start the print, then stop (after the initial heating-up, but before printing), you can then verify the settings by using the Jog-Mode (over USB) and just keep increasing the ‘+Z’ axis. It will either top-out, or stop ~1/2way).

added note: , make sure you set M1, the first time I set M0 (which is the command to return to original length, face-palm)

just had a similar problem. When I goto “About” in “Settings” on the actual Snapmaker little screen, it confirms in error the 125mm x 125mm x 125mm(Z Axis Extension Installed) Here are my confirmation pics

So much filament wasted, so much time lol. Just want this to work right. And I had installed the correct windows driver when I got it setup originally

Now that I’ve learned more, there’s nothing special about GCode or the USB connection. The SnapmakerJS USB connection just lets you send GCode directly to the Snapmaker, without explicitly making a file. And GCode is just a text file.

There’s no reason you can’t open up Notepad, and type

M1025 M1

then save it as a file named “TallZAxis.gcode”. Just make sure that windows isn’t going to change the file extention to .gcode.txt. Copy that file to your USB drive, and “print” it. It doesn’t have any actual print commands, so it should be pretty fast. If you plan to switch between the two, you can do the same with the M0 code and save it to “ShortZAxis.gcode”.

You won’t get the “ok” feedback, but you should be able to verify it worked in Settings > About as @enlightenonq suggested.

1 Like

Well, I have a related problem: My Snapmaker knows that it has a 221 Z axis, but Snapmakerjs won’t let me slice anything over 125. I’m sure this is just some setting somewhere, but I cannot find it. If you know, please help me out!!! Thanks.

Please refer to this article:

1 Like

OK I’m answering my own question here. I had already tried everything in the answer below but the SOFTWARE would not let me slice anything over 125. I finally found the place to make the change in Snapmakerjs. The little gears in the bottom left led me to machine settings where at last I was able to tell the software that it could print up to 221. Just leaving this note for anyone else having this problem!

I have offered the FAQ for Z-axis extension. Did it not work?

Ok, so I found a workaround for this issue.

Open SM Luban, using the cogs bottom left, change to “Custom” and set the Z axis to 221.

Now load your print file, make setting changes as you need, generate Gcode and load.

Now turn your original Sanpmaker on and open the communication port, choose Original and printer and away you go. It sees the print size and allows you to continue to full height.

Hope this helps

2 Likes

I am having the same issue since installing “Base-2.9” version firmware as Omwoodshop above. am unable to change the build volume … I am suspecting that Base-2.9 does not support the 221 mm Z Extension, if that is the case then can you recommend a version that has this above V-2.11?

P.S. I have tried in JS and can change my Z axis length in custom settings, but check Snapmaker display and after sending the M1025 M1 command it will not recognize it on the SM Display, still z-axis remains at 125. in Luban I am unable to get the dropdown menu to select custom and extend the axis for the software and M1025 M1 command yields no results. one of the posts mentions a work around but not quite sure I wanna hang my hat on that in the event it does not work, I will just go back to the Firmware version that was working until somebody can tell me what I am doing wrong … I think this is most likely the case.

I just discovered the error in my train of thought!!! It’s V-2.11. Not V-2.1.1 ok back in goes The version that recognizes the extended Z-axis! WOW it works again!! :nerd_face: so embarrassing!! Amazing what a good night sleep can do!

Thanks Edwin!