Wrong Temperature gcodes in CURA


#1

Hi, I know this may go to the CURA forums but as I’m having the issue with the snapmaker and there are some other users here using Cura I may be able to understand the issue.

I had used the Cura settings recommended here

Problem is with the printing not starting due to a bad nozzle temperature setting, the printer does not recognize the temp gcode and is thinking that the goal temperature is zero.

This is part of the header of a VALID gcode file generated by snapmaker software:
;Generated with Cura_SteamEngine 2.7.0
;Start GCode begin
M140 S60
M109 S210
M190 S60
G28 ;Home

This is part of the header of an INVALID gcode file generated by Cura software
;Generated with Cura_SteamEngine 3.2.1
M190 S60
M104 S210
M109 S210
M82 ;absolute extrusion mode
G28 ;Home

If I replace those gcodes generated by cura with the gcodes generated by snapmaker software the issue is solved and the printer prints correctly.

Anyone knows where to change in cura the gcodes used to make it compatible with snapmaker or if this is due to snapmaker not following gcode standars?

This post is to get insights of what is happening, I have no problem with replacing the headers to be able to use the cura software.


#2

I’m having the same question:joy:


#3

Hi @luismesas

Doug the newbie here. I am on the road to test Cura and found these windows to enter new settings and will try shortly. I setup a printer named Snpamker and will alter settings for ir.

Doug
Update, I forgot a reference that may help you https://manual.snapmaker.com/3d_printing/faq/snapmaker-profile-for-cura-and-simplify3d.html


#4

He did it, and me too, but the print temp is still not recognized (shown as 0℃).
Replace that several lines of code will solve the problem.


#5

@doug, I did that, those headers are OK, but before those, the gcode file contains instructions for nozzle and bed temperatures. If you see the codes I shared, Cura uses different gcodes for nozzle temp than snapmaker software.

I was wondering if there is any place on Cura where I can replace what codes are being used so I can use it directly without the need to replace those lines in the gcode file


#6

Hi @luismesas

Alas I am a Klutz in this area. I suggest asking @rojaljelly for suggestions. (BTW he will get this message)

Have a great week.

Doug


#7

Short answer: Just wait. Once the bed reaches temperature and stabilizes the nozzle will come up to temperature.

Cura does things just a touch differently. Since often the bed will take longer to heat up, and you don’t want your print nozzle at temperature cooking your filament while the print bed heats up. The GCODES used cause the system to wait for the bed to come to temperature first. You can always modify the Extruder Start Gcode, if you prefer not to wait.

M109: Wait for Hotend Temperature
M190: Wait for Bed Temperature
M140: Set Bed Temperature

Reference: http://marlinfw.org/meta/gcode/


#8

I use Cura quite successfully. It brings up the print bed temperature first and then then the nozzle temperature and away we go.

Doug


#9

But there is no command to set the bed temp, so M190 waits forever (there is no call to command M140):

;Generated with Cura_SteamEngine 3.2.1
M190 S50
M104 S200
M109 S200


#10

Hi all,
so do we paste the settings from the Snapmaker profile for Cura to the printer settings tab or the extruder tab?


#11

@Vask
very good question! Since Cura splited the settings in two tabs, where shall we enter the start and end G-Code?

Any answer on that?


#12

I have mine in the Printer tab and it works like a charm.


#13

Hey Vask - Just put them here like normal. It’s cool that Cura is adding more options, though it’s reaching a point where they might need a “basic” setting for their machine, not just gcode generator. :rofl:

https://manual.snapmaker.com/3d_printing/faq/snapmaker-profile-for-cura-and-simplify3d.html

@croder is right on this, Cura settings wait to warm up the nozzle until after the heatbed has reached temps at least on Cura 4.0.0. @luismesas Maybe someone fat fingered the M140 and put M104. 4.0.0 seems to work. It now looks like this:
;Generated with Cura_SteamEngine 4.0.0
M140 S60
M105
M190 S60
M104 S215
M105