What Problem is this?

@Somnium

I have talked with our application engineer and here are the results:

  • Which version of Luban you are using?
  • Firmware version
  • How long do you use the filament? Did you dry it to avoid the moisture? You can try a new spool of filament.
  • As for the slider, you can shake it manually.
  • The retraction distance is too small, and the default value is 5mm in Luban V3.15.1.

  • Printing temperature of the model? The proper temperatures of different filament vary due to different manufactures.

Please share the files with me, including STL file, G-code file. We will test the G-code file and then generate a new G-code for you.
image

Edwin

Firmware is the latest and i used cura to slice it. The default value may be 5mm but i saw no one here in the forum or elsewhere using more than 2mm retract with a direct extruder.
The filament was not old and was in a filament box with 10% humidity all the time and it happend only by this piece that bad. I printed all shown pictures at 203 C° it is labeled from 195-215 C°.
What are you saying to the other two pictures in this case are two different roles from the same brand and it misses some parts of the layer near the changing point?

This right here is really strange. 5 mm retraction? Everybody who actually gets things to print decently uses less than 1 mm after lots of trial and error, but this is of course outside of luban at that point.

@brent113 any comment this this line from Edwin specifically???

Now, i am going to rant a bit, and its not even really intended to attack anybody or snapmaker or anything… it is just what I am feeling going through all this over time.

I think when this machine was designed, and all factory settings applied, they had a concept of how 3d printing worked, but it was outdated and i think the firmware is not doing things properly as a result of it.

This is the same story about the linear advance, it comes from the factory way out of tune, because luban is set up in such a way that it doesnt matter, but when you go to use a real slicer things arent right anymore. we are all trying to make things proper per tested well accepted best practices, but the machine itself isnt designed to work in a best practice format. so its like all these things everyone has been working towards is just shifting the problems someplace else, because there is something not right in the firmware.

in other words, luban slices things differently than other slicers do, to accomodate the firmware in the machine, and any substansial changes to make something better in an effort to improve the performance of the machine are just undoing everything they shipped in an effort to get luban to work a certain way.

just my opinion of course… Snapmaker is missing the bigger picture by focusing its efforts on changing the machine for luban’s sake instead of changing luban & the firmware for the sake of best practices.

1 Like

In my opinion that retraction suggestion sounds like a blind shot in the dark with no basis in how 3D printers work. Retraction that is too low results in blobs being deposited which is clearly unrelated to this issue. Retraction that is too high could possibly result in under-extrusion in some conditions. Suggesting to increase retraction on a direct drive extruder to 8x the current value to fix under-extrusion is a hail mary of a suggestion, especially since the issue is transient in nature and doesn’t occur near the bottom.

More generally speaking, it’s really convenient for Snapmaker they are able to hide behind Luban when anything doesn’t work. It prevents any real understanding being required.

Issue: solved.

2 Likes

That is a very elegant way to say what I was trying to portray thank you lol

I‘am with brent and moose the first two pitcures are with uncalibrated esteps (they got reset do default value) and the last picture is with calibrated esteps and the issue i still there and since i have used a different and new role of filament for the last one it seems that the filament is not the cause of this problem. I now run on file again with z hop disabled to see if its gets better.
And thanks for the offer to send me a new gcode or something but i rather would like to have a solution for this problem in general and to say i should use luban for slicing is not a good way bc its restricting users are forced to use luban wich is also not good. This printer costed way too much to be limited to one software it should be able to get along with all of them.

So your stored settings in the firmware got reset on an upgrade. Would you mind setting your linear advance to K0.07 for a test. Super easy to do, can do it temporarily if you want just before one print: On wifi or usb, or in the start of a gcode: M900 K0.07, and until the machine is power cycled that will be a temporarily override. If you want to save, M500.

My thought on why it’s linear advance related is you mentioned it’s at a layer change, which would be the start and end of lines, not really the middle. I have seen issues like that especially at faster print speeds, though I don’t know your exact speed.

Linear advance is likely only part of the issue, if it is in part at all; I’m not expecting perfection here, maybe a slight improvement.

2 Likes

I set the linear advanced setting in the extruder gcode in cura i saw one doing it and thougt it worked but i should do it like you say to be sure!
The print speed for the outer wall is at 40mm/s

If the start of the gcode file generated has an M900 near the top then it’s in effect.

You could also try playing with that. A linear advance that’s too low will result in underextrusion at the start of a line. The default is .22, you could also try running it at that. If it’s wrong then you’ll notice blobbing at the start.

The ‘proper’ thing to do would be determine the best setting using the pattern generator described here: https://teachingtechyt.github.io/calibration.html#linadv

Linear advance is tied to your machine and also the filament you’re using since it is sensitive to the ‘springiness’ of the filament. It manipulates the extruder motor to make the filament appear like it’s incompressible by applying extra pressure at the start of a line segment, but wrong settings make things worse.

1 Like

I have tried to say this few posts ago, force retraction between layers should be off, especially if your extruder is not calibrated well :wink:

1 Like

Thanks for this i will try to tune this :pray:t3:

Yes in the last pic it was turned off

linear advance should be like a built in walked through calibration routine, it makes such a big difference

1 Like

@Snapmaker-Support heres a file where it happended again if u want to check it Uploading: Helmet.v2(75%).gcode.zip…

Still happening? Is it along same axis? Or is it multiple directions?

Yes but this time with the spare snapmaker filament i had but i dont think its moist or the quality of the filament bc it happens only on the join/seam or the start and end of a layer where it gos on to the next layer.


On the bottom left you can see it by the visor and above the visor in the middle

I would say its multiple directions

Is it the same hotend like in your photos before?

Which slicer do you use?
What did you (try) to get rid of this issue?

I think 0.1 looks the best

No i took the a clean one with new nozzle
I use cura
And now i made the K factor test. I think its something with this setting bc it appears only on the seam between layers nowhere else the rest of the surface is so smooth. Its very unlikely that the nozzle only gehts clonged in a certain area would it?

Try it with 0.04 - 0.12 again to get the best results!

I guess your issue comes from the Slicer. Unfortunately I am no cura user and don’t know the settings that well.
Surely there is a setting about what to do at layer change like let the extruder run out before layer change.
Have a look at this, the first picture describes your problem well:
https://www.google.com/url?sa=t&source=web&rct=j&url=https://community.ultimaker.com/topic/24144-under-extrusion-after-every-layer-change/&ved=2ahUKEwi65aDsmJrxAhUZtaQKHeu5BoYQFjAOegQIHBAC&usg=AOvVaw2n6DJbCZK0HOfs7HuV6R9l&cshid=1623779228969

1 Like