Unable to update firmware

I just put together my SN2.0 from the original Kickstarter. The help for firmware updating I have found does not seem to apply. I don’t have a Settings/Update Firmware menu item, and it won’t see the bin file on my flash drive root folder. What do I do?

The settings update category is only possible if you are connected over wifi.

You should be able to tap the bin file in your root folder of your files.
For information, you have to switch to your usb drive by swiping on the touchscreen instead of screen memory.

It has my wifi network listed as connected. But there is no Update available. I don’t see a way to swipping to USB. There are 2 buttons at the bottom of the screen. If I select USB it says file is empty.

Edit: I tried a different USB stick, with nothing else on it. That worked. It may be the first one was formatted to NTFS. With the current firmware the wifi update option was there to.

Old SM with early firmware had to be updated via USB only. Wifi updating was introduced in a later update.