Troubleshooting


#102

This might or might not be related. Few days ago I turned on my Snapmaker and it would not warm up or reset the print head to home position first. It just just started printing. My first initial though was firmware issue. Several turn on’s and off’s later, it was still happening. Like you I also print directly from my USB key drive.

Turns out my USB key drive was corrupted. It had read errors and now I can’t even format it. So check your USB key. I’m surprised it failed this fast (only had this printer not even a month). As soon as I switched to a different USB key drive, the Snapmaker was running as usual.

Hope this is your case too, and nothing more serious with the Snapmaker.


#103

My printer locks up even without a memory key in it. I have a request submitted for a new controller. I ran chkdsk on my memory key and it was fine.


#104

@quarky42 Sorry to hear that. That’s quite unfortunate. I was hoping it was a simple fix like mine. Good luck and keep us posted.


#105

After send “PRINT”, heating bed is hot but dgree is not when you put your hands on it but The temperature of the computer screen and screen does not change. The wire also clicked and I think it was connected to normal.

Help me!!!


#106

Thanks. I still haven’t heard anything from Snapmaker. Considering how short their warranty is, this delay in getting a replacement control module is painfully slow. I hope they decide to extend the warranty period for the early adopters or at the VERY least I hope they provide discounted parts replacement for us in the future. We shouldn’t have to pay out the nose to replace faulty hardware. I have made 8 prints before my Snapmaker started failing repeatedly.


#107

Something that might help people troubleshooting filament problems. If the filament is properly loaded all the way, it takes ~85mm of filament. Getting the filament to enter the heated end can be tricky. It’s pretty easy to think the filament is loaded all the way when it isn’t.


#108

You beat me - I made 4 before it failed. 20% of the warranty period has passed with no response from Snapmaker.


#109

Problem with Nozzle Heating

I was wondering if anyone else is having the same problem I am with my Snapmaker

It has been working fine, and I’ve been able to successfully print a number of objects, but I now seem to have having an issue with the Snapmaker resetting itself.

This happens both printing directly from the USB stick and with it connected to the PC.

I’ve done some diagnostics and it seems to be that the nozzle stops heating which causes the Snapmaker to reset.

If I restart and goto the Change Filament option, I can see that the temperature of the nozzle isn’t increasing.

I’ve taken the right hand side off of the 3D Printing Module (as if you were going to swap the nozzle) and if I wiggle the red or white wires, whilst watching it on the Change Filament screen, the nozzle suddenly starts heating again.

I can only assume it’s a problem with one of the wires/connectors or a dry joint?

It’s frustrating because sometimes it prints fine, and sometimes it resets.

The Snapmaker has been brilliant so far as well!


#110

Yes, I have this exact problem. It’s either that it isn’t heating or it isn’t detecting that it is heating.

I have contact support regarding this but 18 days after doing so I have yet to receive a reply saying that it will be replaced by a warranty or any hopeful information. That’s 20% of the warranty period for anyone who is counting.


#111

I had exact same issue. They sent me new heating element and temp thermistor but haven’t had a chance to install. I have been working flawlessly working with the right panel off the print head and bending the wires out so they are not bent at the head . Will post if all my issues go away once I install the new parts. I noticed from photos above, some have the element wires wrapped around the motor on the right (which mine was) and some on the left. I suspect the sharp bend when they assemble is the culprit…


#112

Hi Rainie

Does the Snapmaker have a overheat function, I got mine yesterday and assembled it and then switched it on, leveled the heating bed all good. Today i went to load the software and filament wire, so i switched it on and everything came on, while i was waiting for the head to heat up i downloaded the software and searched for a project to start printing, during this time the touch screen has gone blank and wont come back on, I have reassembled everything and switched it of and on, all the fans run but the touch screen remains blank and even when i try to connect my computer to the printer it cannot connect, am i missing something, and yes i have RTFM.

Kind Regards
Bruce Gibb


#113

Sounds like your controller failed. Did you update the firmware? I did, but my controller failed anyway after 8 prints. Now when I turn the unit on with or without the USB memory key it freeze up after a few minutes of doing nothing. If I start a print job, it gets 10 to 70 layers in and freezes / reboots and freezes. I have tried contacting Snapmaker and have tried posting here but have not heard from them in more than 10 days. They responded to one email this morning and answered 1 question out of 4 or 5…they left the other questions blank. There is a form on their website you can request a replacement controller from, but good luck with that. You likely won’t hear from them for a long time. I’m pissed.


#114

Thanks Quarky42

This doesn’t sound good, at least you got to use your printer, mines currently a paperweight that makes fan noises, will try the upgrade and see what happens, also I am going to repost this in its proper place on the forum, its taking me longer to work this site out than it did to assemble the printer.


#115

hi! i got some issues with first 4 rounds of printing. it gets kind of messy around smaller detail and sharp turns. It also suddenly loses its grip to the heating bed after 6 layers. Should i increase the temperature on the heated bed or is it malfunctioning. I have calibrated 4 times and the calibration looks good so i do not think that is the issue.


#117

Hi Quarky42

Haven’t got a response from anyone yet, have found the firmware update, but its a .bin file any suggestions on app to open it have tried a few but no joy also do you need to unzip it to update or can you use it in a zipped state and one last question should the LED light be on when you switch it on or does it only come on when you insert the flash drive?


#118

Hi @bruce @Rainie

Have you followed the instructions that came with the firmware upgrade? repeated below for you.

Please follow this tutorial to upgrade the firmware: https://youtu.be/GCxzZwxJ_mU

Or, follow these steps to upgrade the firmware:

  1. Copy the Update.Bin file to the provided USB Disk.
  2. Power off the printer and insert the USB Disk into the USB port.
  3. Power on the printer. If the LED changes as below, the upgrade is successful.
    • The blue LED blinks slowly for about 5 seconds.
    • The LED is then off for about 2 seconds.
    • The LED starts to blink quickly.
  4. The upgrade process is completed.

If the LED doesn’t change as described, please follow these steps to troubleshoot:

  1. Make sure the file system of the USB Disk is FAT32.
  2. Make sure you copy the correct .Bin file (Update.Bin).
  3. Make sure the USB Disk is properly inserted into the USB port. If you are not sure, remove the USB Disk and insert it into the USB port again. The printer MUST be powered off when you remove and insert the USB Disk.
  4. Make sure the .Bin file is put in the root directory of the USB Disk. The controller cannot recognize the .Bin file if it is put in a folder.

Doug


#119

What are you printing? Maybe it needs a brim or raft.

What material are you using? Maybe it needs different material heat and heated bed settings.

What movement and extrude movement speeds are you using? Maybe it needs to move a little slower?

What surface is your printer sitting on? If it wobbles that will affect your print quality. You may need a solid surface to put it on.

Other things like layer height and whether or not the filament has absorbed moisture will affect print quality too.

Would need to know a lot more in order to try and help you troubleshoot. When my printer was working the quality of prints was great.


#121

Please follow these steps to troubleshoot:

Print another model and see if this happens again.
If it happens again, please check the LED on the control when the touch screen freezes. How does the LED flash?


#122

Does this happen the first time you use the printer or after you use the printer for a while?


#123

I have answered these questions already.

For the third or fourth time:

It blinks blue at the same rate that it does after I turn it on. I have failed more than enough prints.

Also I’ve said that I have printed 8 models successfully, one of them being pretty good size with no problems. The 9th model failed after 70 layers. The tenth model failed after 10 layers. The unit freezes if I turn it on with or without the USB key in. It freezes even if just let it sit for a while. The screen stops responding. If I am printing the screen looks like it reboots and freezes at the boot screen. If I am not printing it just freezes on what ever screen I leave up.

I’ve sent pictures. I’ve sent this info several different ways.