Troubleshooting


#82

My problem rare than others problems: controller freezes when I try start filament replacement option and on calibration option. On display I cant reach “change filament” screen (manual page 26) and calibration screen with 1…4 dots (manual page 23).
I need new firmware with debug Info or maybe controller replacement or something like this.
I bought product from site, not Kickstarter and want to receive product support as normal customer.


#83

Hi @vabavia

Did you email support@snapmaker.com with details of your problem?

Doug


#84

Hi, @doug
Yes, sent email 18 days ago. And posted problem there too. And fulfilled form on warranty request. No answer on any channel


#85

Use @Rainie and @whimsycwd to pass on your concerns. I am sure they will see this now. Hopefully you get resolution soon.

Doug
BTW, I am just a normal user, not a Snapmaker employee.


#86

same here, not snapmaker employee…

(i have not even made anything with my (just received) snapmaker yet)…

have a bit of metal trades / software experience tho…

except doug ain’t noway “normal”… :wink:

william…


#87

ok, looks like you sneaked past me coming from the land of france…

you seem to have done due diligence requesting assistance, and the ball was dropped…

the nozzle rising would seem to be a software or configuration issue, so i’d not go past that…

the bed leveling does not need to be as precise as you are trying to achieve…
( i could be wrong, but many others’ machines work well with less leveling precision… )

as i have yet to do actual builds, i’ll now shut up and defer to software support…

william…


#88

it’s almost that, I’m from Belgium, next door. And my english is not perfect, it’s true :slight_smile:

thank you for trying to help me William


#89

Hi @jerome,

Just to share my experience on this problem. I don’t know if that could be of any help. I am a complete noob for 3D printing.

I received my SnapMaker just before Christmas :smiley:. At first was a bit disappointed as I could not get the print to stick to the bed at least using the SnapMaker3D software. I tried Cura 3.1 and I had a bit more success. Cura heat the bed at 60°C for PLA. That help a lot.

For the calibration it was not too clear how to adjust it (not tight, very tight?). Then I found this post:


In the update on Dec 30, there’s a test pattern to validate the calibration. It is one layer thick.

I loaded the Test.stl file in the Snapmaker3D software, duplicated the “Normal Quality” print setting and increase the bed temperature to 60°C. I then experimented with different adjustment during the calibration. I found that in my case I had to press the head fairly hard in the print bed to get a relatively uniform pattern.

When I found that adjustment and the 60°C bed temperature, I had fairly good print success. Adding a “Brim” help for some model.

@Raines was really helpful to me. I think that the SnapMaker team are a bit overloaded at this time. Shipping 1000 machine a month is certainly demanding.

I am from Québec, so my english is not perfect either.


#90

i b from mississippi, so my english not b perfect either… :wink:

but i tries…

william…


#91

…and @william.o.yates is a Professor at the local University.

Doug


#92

The bed leveling is the most uncomfortable Thing with the product - and this was on of their arguments in the campaign…
Of course it’s far away from the automatic bed leveling in my Ultimaker 3 but I do still Play with my Little Snapmaker.

I’m working with PET-Filament (90% as siple to print as with PLA but many advantages) so you can’t simply convert to PLA but here are the main things I did to achive better results with 1st layer adhesion:

  • tighten the screws of the heated bed (all with the same force and not too tight)
  • cleaning the bed surface
  • preheating the nozzle to about 150-170°C if possible (I’m using the Simplify3Dmachine control pad) for better results (Filament gets soft on the tip of the nozzle)
  • Z-axis calibration (lower the axis until you start Feeling the nozzle Scratching over the paper by movin the paper back and forth)
    All 4 Points should deliver the same resistance to the paper
  • When using Snapmaker Software you cant do much but inceasing the numer of lines for the skirt/brim to prime the nozzle for a propper flow of the plastic
  • When using Simplify3D I set the layer height of the first layer to 120% because at Standard the nozzle is to low and doesn’t let the molten polastic flow out from the tip.
    Also I extrude about 5-10 mm @ 1mm/s just when the axes are homing so it extrudes some plastic before the print starts.
    Do not use more/faster because then there is too Little material in the Extruder
  • Also you can try to increase the Z-axis Offset in the Software (not on the touch Display) in steps of 0,02 mm until the result is getting better
  • Optionally you can use PrintaFix - it is superb!!!
  • Sometines if nothing else helps I use 150% Extrusion/flow rate for the first layer until the plastic Comes out.

I hope this will help you a Little bit but it isn’t a big fun struggling with this Major Problem…
Also I strongly recomend the Simplify3D slicer Software (not for free) because it provides so many aqdvantages (different infill pattern - also customizeable, supreme Support structures which require no Tools to remove them, Software controll pad when printing via USB cable and many more) - it is worth the Money if you want to make 3D printing your new Hobby. Cura is also better than the Snapmaker sotware but not as good as Simplify3D.


#93

CLOG!!!

I tried posting this under Uncategorized, but I couldn’t start a new topic. I will try to post it here as a help to others and reminder to continually check the nozzle area for filiment.

First, let me say that I am in no way unhappy with my snapmaker, but I may have rendered the 3D print module useless. I noticed about 2 days ago when trying to do a larger print (11cm x 9cm x 5-6cm high), print delaminated from the base and filiment had collected around the nozzle. I figured it was just because the part was too big, so I decided to try something else, which seemed to print fine. Tried another big part and it delaminated. Thanks to the forum, I realized that I hadn’t calibrated in a while, found point 1 to be a bit high, got it calibrated and thought all would be well. Did a smaller print OK, but then left it overnight to do a larger one (6cm by 10cm by 2cm high).

This morning I wok to the heating bed dislodged from the base, the raft and first mm or two of the print suspended from the print head, and another mass of filiment around the print head. I decided to act like I was changing filiment (heating the nozzle) so I could removed the ball of filiment (worked before). But this time it did not. I eventually removed the printer module, used pliers to removed the mass of filiment, which is when I saw all the filiment that has collected inside my printer.

I decided I had to remove this cured filiment, so I carfeully removed the side panels and the fan next to the print head (by the way, thanks, these were easy to remove). However, I quickly realized that this material was cured in place. I tired plugging the print head in to heat it like I was changing the filiment, but the controls never got off the snapmaker logo screen (even when plugging the fan back in, more on this in a minute). I know I could not print as is, so I pryed off the filiment as best and carefully as I could. I then reassembled the unit, plugged it in and…nothing.

The screen shows the software for a second, then goes right back to the logo screen. It would appear that something happened to the print head. I did connect the laser engraver head, and the software progressed to the control screen, so that seems to be working fine.

I do have to say that I accept that I should have done a better job checking the nozzle when I had the first clog, but It did appear to only be a clog and was easily removed by heating the nozzle (plus you don’t want to really stick your head under the nozzle just after heating, and I was excited to get printing again). I don’t recall checking the area around the nozzle as part of the snapmaker recommendations. I think this is something that folks should do on a regular basis. Maybe they’ll send me a new 3D print head from pointing this out and making other aware so they don’t clog theirs (hint - hint).

In general, I have been very happy with the unit and was really enjoying the printing. Now I will have to move on to laser engraving until either I can order a new printer head or one arrives to replace this one.

Thanks, and happy printing!

Below are some photos to show the clog and my removal…


“BALL” OF FILIMENT (AFTER REMOVING RAFT)


FILIMENT INSIDE PRINTER MODULE


INSIDE PRINTER MODULE AFTER FAN REMOVED


SIDE VIEW OF MATERIAL INSIDE PRINTER MODULE


AFTER REMOVAL FROM FAN SIDE


MATERIAL INSIDE PRINTER MODULE (OTHER SIDE)


AFTER REMOVAL OF CURED FILIMENT (OTHER SIDE)


MATERIAL PULLED OFF/OUT OF PRINTER MODULE


#94

I too had a similar issue but to a smaller extent.
(Ironically I have a messed up prusa i3mk2 with the same issue as well) I just seem to have a knack of clogging up my 3D printers.

However, snapmaker is already cleaned and good to go(details below) while my prusa still needs to be worked on. No fault of theirs, i just love the snapmaker so much more that I didn’t take the time to fix the prusa.

So here’s how I fixed my clog… (Safety warning… do this at your own risk). I notice you have done most of this, but for one (Risky) step. I will list all my steps in any case for anyone else that reads this post

Step 1. Switch off the machine and unplug the power cord
Step 2. remove the side panel of the module, as if you were trying to replace the nozzle (check official documentation on how to do this step). DO NOT remove anything other than the cover (especially the fan)… we are not trying to replace anything yet.
Step 3. connect and power up the printer
Step 4. go to controls > change filament, on the menu. This will start heating the nozzle module (I increased my temp to 250, but would suggest not doing so till you are a little comfortable with the next steps)
Step 5. After a few minutes, the temp was high enough and the plastic started to melt. careully using decent tweezers (or other appropriate tools), start scraping off / removing the melted material. make sure to take this off your tool right away before it resolidifies.
Step 6. Remove small amounts at a time and keep repeating as more material melts.
Step 7. Once it is all clean, go to home menu (te stop the change filament process.)
Step 8. Let the machine cool down (shown on the screen)
Step 9. Switch off the machine
Step 10. Fix the cover back, and hopefully, you are good to go

You seem to have opened the cover and removed everything you could force out. try reconnecting your fan and removing the rest of the material after melting it with the change filament option.

PS: I have to thank Prusa support guys who gave me the idea of trying to melt off the clog in the first place.

Sorry… I reread your post and realized you did try to heat it… but hopefully this post will help people who ignore your post and get into this clog situation to start with


#95

I tried that, but it wasn’t really working this time. I probably should’ve tried longer. I may try again using my computer to control the printer this time instead of the touchscreen, which doesn’t seem to like my 3D Printer Module anymore. I’m hoping I can get it working or order a new one, I’ve been really happy with this printer.

Thanks for the advice and the help!

John


#96

Update…I tried using the computer (which was just connected to the snapmaker with the laser engraver installed) and no luck. It would not connect and the Sanpmaker program eventually froze when I tried to quit.


#97

I had the same problem, it seem after calibrating at the start of the run the filament wouldn’t stick or became unstuck. I found that it was important to calibrate with the print head and bed fter they had been heated

Also with PLA I found that increasing the 1st layer depth to .2mm and increasing the 1st layer bed 60 C and filament 210C temp as well as slowing down the the extrusion to 10 and travel 20 and using a skirt seems to work every time. It also seems that it forgets the calibration on power cycle… But once calibrated it works for multiple prints

Having great fun now 3d printing


#98

I tried to post my own topic under the Software/Firmware section, but the forum refused to let me create a thread there. When running a large (70 to 75mb) 0.05mm layer resolution print job from the kingston USB stick, I have had the snapmaker lock up on me twice. I have tried two different slicers (Snapmaker3D which is based on Cura, and I have tried Cura itself). I have had several small prints at different qualities ranging from 0.05mm to 0.3mm work great. I have had 1 large 0.1mm layer print work great at 9.8 hours of print time.

So far this print job has failed twice. The first time it froze at about 70 lines in and the second time it froze even earlier (about half that or less) This is what the screen shows when it freezes up:

I am running the latest December 2016 Firmware, running gcode file from USB Key. Using a Windows 10 x64 Laptop running the latest version of Snapmaker3D (0.06mm layer thickness since 0.05mm wouldn’t render) and Cura 3.2.0 (0.05mm layer thickness)

Edit: Now it freezes up just trying to calibrate or jog axis. If I boot up with or without the memory key inserted, it freezes a short while later in the middle of basic controls. I have submitted a request for a new control unit.


#99

Another “Bug report”…
Changing filament on snapmaker is always a big issue for me. Most of the times, the filament does not go all the way through. It feeds through the push button, but does not exude when printing. I’ve noticed, that the print only works when I push the filament enough where it starts oozing out during the change filament stp.
However, today even that isnt workig. I am unable to get the filament to ooze out while loading, also the button seems to go in only half way.
Any suggestions?
I’m feel there is a clog somewhere in the nozzle/feeder? How do I unclog it? what makes the filament load properly sometimes while it just stops short most of the times?

Thanks


#100

I have a similar - When “changing filament” (I am having a go with the laser at the moment) it would not heat. I had snapmakerjs’ console window open.

Error: Heating failed, system stopped! Heater_ID: 0
Error: printer halted. Kill() called

My diagnostics suggests it is no longer heating, or is no longer detecting it is heating.

Unfortunately, support@snapmaker.com seem unresponsive. I appreciate they must be busy with fulfilling rewards at the moment but this has already cost them one sale (a colleague was interested but I have suggested he wait due to the communication issues). It will cost them more.


#101

Feeding the filament through can be quite tricky. Yes, you need to feed it all the way through until it oozes out and change colour (if you’re using a different colour).

The good news is, it is usually not a clog. From the image below, you can see the filament has to go through the top feed tube, get grabbed by the gear (the button controls wether to engage or disengage the gear), then proceed to the heating element tube.

What’s happening if you can’t feed it through most of the time it is not finding that heating element tube. This is especially true when the filament is very curved (like at the end of the spool). You want to make the filament end as straight as possible when feeding it in. You can do this by carefully bending the end of the filament in the opposite direction as its natural curve. This usually works for me and I hope this helps for you too.


Also having trouble with inserting new filament, how to replace nozzle?