Troubleshooting


#42

Operating System: Windows 10 - 64 bit

OS Release Level: Latest Release (GD32 Base 1.2)
Snapmaker 1.6.2

Machine Configuration:
3D Print

Describe the problem you encountered:
Machine rebooted about 5% into first print.
Stayed on progress bar screen

Rebooted.
Started a print, machine just reboots before starting print.
Rebooting does not fix.

Machine was received yesterday, unboxed and setup this AM.
This started with the first print.


#43

If you unplug the usb cable going from the snapmaker to the computer and print using the provided sd card does the snapmaker still reboot on you?


#44

I wasn’t using usb, as I have had issues with that before with other printers. Also to avoid any sleep/os issues. I was printing straight from the provided USB.


#45

Dang, sorry you are having bad luck! Does the issue happen with multiple print files? It may be worth trying another file and possibly one prepared by another slicer. Sorry if you have already tried that.

I am also curious if you have issues when you use another module. Would you be able to try the laser engraving module?

Depending on all of that, I wonder if it would be worth flashing new firmware. I am on my mobile or I would search for the thread. I can’t remember if it had been officially shared or if it was on an as needed basis. I bet @Rainie will have a solution.


#46

I only have the 3D Print module. No laser or CNC.

It happens with multiple files. I’ve tried 4 different ones.
All were sliced with the Snapmaker software though.

I can try another slicer later.


#47

I forgot that some people only got the 3d printing module :sweat_smile:; it was a stretch to test with another module anyway. I am not sure what you have had experience with, but cura might be the most accessible to test with. Below are the machine settings for Cura that Noah had shared a while back.

image

If the printer still freezes up with a print file prepared from another slicer, it might be time to try printing via the usb cable. I guess there is a chance there is an issue with the reader or the sd card?

My snapmaker was freezing up when I was trying to change filament the other day and after a few reboots the issue persisted. Ultimately I got it to start working after I turned it off, unplugged the power adapter from the unit and from the wall. I then unplugged and plugged each of the ends for all of the cables and left the unit unplugged from power for a good 5 minutes. I then plugged the power back in and turned the unit back on. After that it was back to printing. After going through that I think the cable going to my print module was loose but it took reseating it and leaving the unit off for a while before it fully recognized that it was plugged in properly. It may be worth giving that a shot…

After that my opinion would be to try to flash latest firmware or re-flash if you are already on the latest.

It looks like the firmware is posed on the downloads page of the snapmaker site under “Additional Files for the Software”. The instructions are included in the zip file.
https://snapmaker.com/download

Oh one more strange question… You wouldn’t happen to have the snapmaker plugged into a surge protector or a UPS would you? Whether you do or don’t should really matter, but under these circumstances I usually plug strait into the wall and possibly move to another outlet. I know it seems like a pointless exercise but I have seen some things… I had a server once that would shut down randomly… turns out it didn’t like the sine wave the UPS was putting out… idk way over my head (http://www.apc.com/salestools/RMUZ-7DTKRC/RMUZ-7DTKRC_R1_EN.pdf)<-- Don’t bother reading that, just wanted to attempt to prove that I’m not crazy. Anyway, I know that was way off topic, but like I said, may be worth plugging straight into an outlet or moving to another outlet if you have easy access and you haven’t tried it already if only just for kicks.

Hopefully one of these steps helps you out and I haven’t wasted your time. Just trying to offer some suggestions until the snapmaker team is available to help you out.


#48

@cjyohe, @jstncrft GIven that Cura 15.04.6 is a free download and can be easily configured to work with the SnapMaker 3D printer it can be used to crosscheck the G Code files generated by Snapmaker3D. A couple of the areas you can check is for the settings for the Heated Bed temperature (try printing with this toggled off and on for trouble shooting), try varying your extruder temperatures (there are 3 extruder temperature settings in Snapmaker3D that can be modified in the custom menu).
If you are interested in Cura 15.04 the website is https://ultimaker.com/en/resources/16579-installation.

Your issue may also be related to Windows 10 and its USB drivers. Using the USB cable you should be able to attach your computer to the SnapMaker and control the movement of the print head. If you are using Cura 15.04 and have a model loaded you should be able to move the print head, control/monitor the temperature of extruder/bed temperature. If you have issues moving the printer head problem could be your USB driver. The solution is to download/install CH34X_Driver_V3.4_Windows.zip driver from the Files/Download section of SanpMaker.com website.

If that does not work try opening the G Code files that your slice is generating and opening it in a text editor you can actually read through it using the G Code definitions that are written up in the G-Code Wikipedia article (https://en.wikipedia.org/wiki/G-code). Actually a better reference for Marlin 3D based G Code is http://marlinfw.org/docs/gcode/M104.html

Generally a system reboot occurs when an incorrectly formed instruction is received by the system. So the trick is to isolate the offending the instruction.

Question: Did you create the models you are attempting to print or did you download them?

If you want to test with a couple of small models that work on the SnapMaker, I have a Guitar Pick that will print and runs quickly unlike the carabineers, tugboats, and whistle that some use as test prints for their 3D printers. The Guitar Pick will print in about 5 minutes and you can easily modify the perimeters such as Infill percentage, bed temperature, extruder temperature, etc.


#49

I have the same issue. When it stops, does the light on the controller blink red and blue. I think it is related to the heat element loosing connection. When it happens, I do a power off/on reset and try a filament change, which the temp does not move and will error out with the same results (Snapmaker Screen and lock up)
. Also, if you blow on the 3d module, do you get a lot of filament bits flying out. If so, let me know and I will point you in a area to check.


#50

When you do the bed leveling calibration, and save it then go back in to the calibration again. I would think the set points should stay where you set them in the last calibration that was completed 30 seconds prior. When i re-enter the calibration screen i usually have to adjust the setting and save it again. It is like that every time i enter the calibration. I have gone through the quick start guide and fallowed the leveling portion over and over again with the same results. The kicker is the first two days i had the printer it worked flawlessly for six or so prints. Then day three I fire it up and none of the prints will stick to the print bed. So i re-calibrated with the same outcome. Then tried messing with print speed, feed speed, adding tape to the print bed, and many other things. That is when I noticed that every time i go into the calibration the set points are different after saving them. You can tell that things are not right when you try to print and one section of the print sticks then when it gets to the other side of the bed it just balls up on the print nozzle. Any ideas on the situation would be greatly appreciated.

Oh and I am using snapmaker 3d software with all 3 default print profiles and custom when I tried messing with stuff after the problem started.


#51

Just received printer. First I updated firmware to latest (GD32Base-1.2). Then Tried to calibrate, but option “Calibrate” missing, I found “Z Offset” on its place. When I tried this option printer placed tip on left down and stuck on “Homing…”. No other actions in 10 minutes was performed. I powered it off/on and tried some time with same result. Please, help me perform calibration.


#52

I’m having the same issue here. No matter if I do the calibration and then save, when I come back in the calibration (1 minute later), everything must be restarted.


#53

Having this issue also. Running Win 8.1 64 bit, tried with Cura, tried with the snapmaker software, tried over USB cable and by a USB drive. I was about 85% through my first print when it locked up, I was initially printing via the snapmaker software and over USB cable. So I tried the USB stick at that point, nothing, tried using cura, nothing. It just locks up and power cycles then sticks in snapmaker booting screen. Tried disconnecting all cables, including power adapter from wall and from the printer, tried running re-calibrations, updating firmware (not sure if that was truly successful or not, and no way to confirm exactly what version firmware the snapmaker is actually running, does not tell you on the info screen what version is installed). So far, nothing, still stuck with the gremlins. The nozzle temp does not change in the change filament setting like it did prior to the issues. The bed will get about 75% up to temp when i try to load a file to print before the printer reboots and sticks on the holding screen.


#54

I think the bend in the heat cable is to tight and either breaking or disconnecting when bent around the fan before reattaching the cover. When the heat cable does not heat up, it seems after aprox 30 sec the system goes into lock mode with Snapmake screen. I have same issue. I had to remove the left cover of the 3d Module and putt the heat cable out straight to get working. This also happens if the Temp sensor in the heat block is not fully inserted .


#55

Hi @splintercell02 @steven.ferland

Thank you for your feedback!
The printer will remember the calibration after you tap Save and before you go to the Calibration section again. Next time you tap Calibration, the printer will erase its memory of the position of point 2-4 and only remember the position of point 1. Therefore, if you tap Calibration again right after you save the last calibration without starting a print, the nozzle will go to the last position of point 1, but you need to calibrate point 2-4 again.

If the printer can’t remember the position of point 1, please send a video showing this problem. I will provide a solution accordingly.

Look forward to your reply. Thank you!

Best regards,
Rainie


#56

Hi Vabavia,

If your screen shows “Z Offset” instead of “Calibration”, you don’t need to upgrade the firmware. The upgrade is mainly for bug fixing for some of the machines with the “Calibration” function. You can use “Z Offset” without upgrading the firmware.

About the problem that the touch screen stuck on “Homing…”, please follow these steps to troubleshoot:

  1. On the Touch Screen, go to Controls > Jog Mode.
  2. Select Move 10 mm and then tap X-, X+, Y-, Y+, Z-, Z+. Can the 3D Printing Module move according to your operations? If it fails to move when you tap a certain button, which button is it?

Thank you for your information. If possible, please send us a video when you follow the above steps. Look forward to your reply.

Best regards,
Rainie


#57

Hi,

Thank you for your feedback. Please follow these steps to troubleshoot:

  1. Please check the LED on the controller when the printer locks up. Is the color red or blue?
  2. If the LED on the controller flashes red and blue, the thermistor is not inside the heated block. You can check if the thermistor comes out of the heated block. If it does, pull the thermistor back so that it stays in the middle of the heated block and try again.
    image

If the above steps can’t solve the problem, please shoot a video of how you operate and how the printer performs after the operations.

Look forward to your reply. Thank you!

Best regards,
Rainie


#58

I am using 3d printing module. I have encountered a problem with the touch screen. After attempting to update the firmware on my microSD model, I noticed that when the screen goes into its screen saver mode, all black screen, that it does not recover from it. Upon disconnecting the screen and plugging it back in, the Snapmaker logo appears with a loading animation but it does not change from there. I shall also add that the printer still appears to be printing fine. The firmware update did not function, however, Rainie has addressed that issue in letting me know that my model does not require the update.


#59

I seem to have lost the ability to jog + / - the Z axes, I have tried unplugging all cable and unplugging the power cord. reconnected everything. Still can’t jog the z axes. Also when trying to print the nozzle never moves down Please advise.


#60

Hi Rainie,

In jug mode all axes moving fine, I tested laser engraving and all printed as I need. In laser engraving mode I move axes from mac and save start position in software.
With 3D module installed printer stuck on homing leave touchscreen freeze and led blink blue.

When I start “Z Offset” with 3D printer tool and heated bed installed, head moving to bottom most left position, going down until “click” sound, then few mm up, then down and freeze at this position.
All this time screen says: "Homing…"
Nothing happens then, touch screen not responding, head not moving.


#61

When you set you Z Offset all axes are homing(Position 0/0/0) and remain in this position.
The clicking sounds comes from the Limit Switches positioned under the smal silver rail on each axis - one on each side.
You have to wait until homing is finished - then you should see a new page on the Display with Points 1-4, save, back and home (as far as I’m remembering).