Troubleshooting for Laser engraving


#21

Try BW Mode(This one suit the image you use) & Vector Mode. :slight_smile: have fun!~


#22

Hi! I’m struggling to get a greyscale image to engrave. I’ve had good results with B&W images, so I know the laser works well. The issue is that when I load a gcode (either directly from the software or from the microsd), all I get is a black box. Check out the video below for an example:

Being an optimist, I tried engraving the image and got, predictably, a black box. What am I doing wrong?


#23

Sorry for the late response.
It’s expected behavior. After you loaded your gcode, the visualizer is the preview of the gcode path. This is how the gcode looks. Go ahead and print it out.


#24

Hi Jeremy,

Could you please share the result of the engraving as well?
Please lower the power to 80% or even lower and try again.

Best regards,
Rainie


#25

I could use some tips with the laser. I had success the first few days using SnapmakerJS but now it doesn’t burn paper or wood at all.

  • I’m using version 2.2.2.
  • I have the Windows drivers installed.
  • The light comes on when I press focus, I position it to be the smallest dot.
  • I tried B/W and Greyscale images of various sizes.
  • Tried many combinations of Dwell times, work speeds, Quality.
  • Tried all kinds of Power levels and clicked Set after each change. The ToolHead Power value changes.
  • I’ve tried exporting the file and using the gcode from a USB stick and the onboard screen to print.
  • I’ve tried turning off the laser and back on again.

Still it just shows the blue laser dot while moving around but it’s not burning anything. It’s like it’s stuck at low power even though the read-outs say it’s using more power.

:frowning:


#26

I just can’t get gray-scale to work at all. I import different images, run g-code. and all I get is a black blob. Per reading the forum other people was told just to run it. I let it print a few hours and all I have is a black blob. What am I doing wrong? I have downloaded the newest software. Any other Ideas?


#27

@mreese120: Try a different/simpler image and increase the brightness in SnapmakerJS. This should help :).

I also had good results when switching the Algorithm. Try Atkinson.


#28

Does anyone around here know how to laser engrave without a computer attached?

I’ve used SnapmakerJS 2.2.2 to generate the gcode for laser engraving and stored it as logo.nc on an USB stick. But the Snapmaker does not show the file. Do I need another extension for the file?


#29

Hi I have Problems with the Scaling of the Vector svg import. I make my drawings in mm and tried different Softwares, but when uploaded to Snapmaker i have always a wrong scale by 2.56. it must be a mm to inch Problem. Is there a possibility to adjust the scaling in the Snapmaker import directly and not over the Pictrure Size?


#30

Are you using Illustrator for creating your vectors? See this: https://www.youtube.com/watch?v=eT5jh13v_v8


#31

Hey thanks for the fast reply. I am using Inkscape. The difference is always a Factor of 2.56, so its in my Opinion not a matter of Points, then of mm and inch conversion. I can Scale it up manually by this Factor, but i am searching for a more elengant and consistent Way to import svg in the right Scale.


#32

You did right - when you are connected via serial, what options do you see? do you see focus and power settings?

If the controller doesn’t detect the laser module being attached, it won’t load laser files.

David


#33

I have similar experience.
How do you set work speed rate or dwell time in the software.
I even edited g-codes created by SnapmakerJ 2.2.2 and and changed F value from f288 to F20 still it did not laser engrave on pain paper, wood, acrylic.


#34

Thanks for your feedback David.

Detecting the modules works perfectly fine. It shows the correct options on the attached controller and the laser switches on when I switch to jog mode. Also, I’ve never had any issues when the computer is attached.

I’m quite sure it’s a firmware bug. Printing/carving from USB stick works perfectly fine but switching to the laser module it does not show any files.


#35

I just started my first run, with the laser. Tried a greyscale image on wood. Now the engraving is started, and oh surprise 288mm/min it will take 23 hours
Two questions;

  • is it possible, to get a time calculation before starting (ok, I would be able somehow, to calculate it by my own, but I am sure it possible to do it the software))
  • second question G-Code is just a text file with simple move commands. Would it be possible to add a feature to store actual position in the file, turn off the snapmaker, the computer and go to bed. Go on with engraving on the next day - starting with the stored position in the g-code file?

#36

Did you ever get an answer for this? I am having the same problem now. Thank you.


#37

I am trying to use the Laser attachment for the first time. I went through the handbook and setup guides. In the software, I don’t see a Laser Section to the left, just a 3D Printer section where the Laser should be. Has anyone had this issue and how do I fix it?

Thank you,
Michael

2018-02-10_1842


#38

Hi @MHalvey05

Have you shutdown the snapmaker and snapmakerjs application an restarted them? You should see the laser panel n the left-hand side of the Snapmakerjs application. I too am a newbie and I can tell you that it works well. I started practicing with B&W etches then ventured onto grey-scale.

image

Doug


#39

Hi @doug,

Thank you for responding. I have powered down and unplugged the machine and restarted the software. Opening it back up I am still seeing the 3D Printer image instead of the Laser. I took it one step further and uninstalled and reinstalled the 2.2.2 software.

Do you have any other ideas? Thank you again for taking the time to help.

-Michael


#40

@MHalvey05 @Noah

This newbie is scratching head. Have you uploaded an image and generated and loaded its gcode?

I included the knowledgeable Noah from Snapmaker on this message.

Doug