Troubleshooting for Laser engraving

That is a good idea!
I think is an easy-to-design add-on for the laser engraver and CNC carver. Would you like to have a try? :grin:

to be really accurate, the grid would need to be etched into the surface.

But as an add-on, this can be printed on sticker paper.



Direct, unbroken grids have been known to cause human induced errors.
(the 1 in 5 as shown is not enough to prevent human alignment errors…)

Grids which have a “broken” field have major/minor indexing, which assist us “humans” to NOT get lost in the “sea of unbroken lines”…

ANY form of field line-breaks will do.
(ie: 1, 2, 3, …; A, a, b, c, …; I, 1, 2, 3, …, II, 1, 2, 3, …)

OR, even some form of graduated scaling will allow enough change to be perceived and prevent “loss of alignment”…


1 Like

I made a number of successful laser engravings but now when I connect Snampmaker the console code that loads when connected contains numerous question marks and there is no functionality to the laser…any ideas on how to correct? Ive removed and re-downloaded the snapmakerjs software and the driver for Mac-OS

Solved my own problem, my baud rate was off…Sorry I’m a nube! Back to engraving

1 Like

Since the baudrate is fixed. We hide it from you in newest release. Snapmakerjs 2.1.1

Over the last day I have been attempting to get the laser engraving module on 011/200 SnapMaker Limited Edition working using Snapmakerjs-2.1.1-win-x64.exe. I am using an HP ENVY x360 Convertible (Intel Core i7-5500U CPU @ 2.40 GHZ 8 GB RAM 64 bit Windows 10 Home OS Build 16299.125). While Snapmakerjs reports that it is connecting to the SnapMaker through COMM 6 when the USB cable is plugged in you can not control the X, Y, or Z position of the laser engraving head. After the G Code is generated and loaded from the workspace menu of SnapmakerJS and sent to the Snapmaker the Snapmaker does not engrave.

I can save the G Code to a SD and execute it from the SD. However the LCD menu on the SnapMaker only provides the ability to load files, start execution, pause engraving, resume engraving, or stopping engraving. There is no way to position the laser head (X, Y, Z) to position it over the work piece and focus the laser. I have been doing this manually with the power off and roughly guessing where the head should be based upon my experience with my other laser engravers. I have attached a picture of the LCD menu. It would be nice if the Laser Engraver also included the Axis Jog menu from the 3D Printer so that the user could position the laser engraver head prior to starting the engraving when engraving from the SD card.

How come when I use snapmakerjs, my software keeps telling me that i’m connected to a 3D printer, even thought my machine is clearly setup for laser engraving?

1 Like

Try 2.1.1, If you your machine is UDisk-version(Non-beata), then need to use this version. We fix a status detect problem for new motherboard in this release.

Also, Could please type `M105’ In the Console. Then give me the screenshort to help to find the problem.

  1. Please make sure you choose 10mm step distance. then try jogging around.
  2. Please type G0 X10 in the Console
  3. Please give screenshot of the software help me find the problem. Please including Connection and Console widget.

Thanks for your report.


As I mentioned in my earlier posted, while Snapmakerjs-2.1.1-win-x64 reports that it is connected to the Snapmaker Laser Engraver on COM 6, it will not move the X, Y, or Z axis. This is not completely surprising as Snapmaker3D_1.6.2_win64 reports it times out when it attempts to connect by USB cable. I have tested the USB port and cable to make sure it works by connecting to a USB storage array and my CR-10 3D Printer. Using an SD I have exported the G Code and, after manual positioning the X, Y, Z axis, the laser engraver did a great job. The issue is it was all using Kentucky windage.

Here are screen grabs of attempting to connect to the Laser Engraver and jog the laser head (without success).

Laser Console capture2Laser Console capture20171222_105519_resized20171222_104352_resized20171222_104040_resized

Hi, jokeefe

From your screenshot, we can know that
Software didn’t connect to 3d printer successfully. Normally it will print out other setting infos.

You already rule out the problem for USB port and cable. Which is great.

Try follow steps, let me know the results

  1. Reinstall the driver
  2. Make sure software connected to the added port when the cable plug into computer(the other end connect to started Snapmaker).
  3. If you have other computers, Mac/other Win. Give a try. lol.(optional)

If you still can’t solve your problem. Let’s arrange a Skype call to find the problem.


I have been having grief with grayscale printing. Any thoughts on how to setup a print that does not show up as black blob?


1 Like


It’s expected behavior. After you loaded your gcode, the visualizer is the preview of the gcode path. This is how the gcode looks. Go ahead and print it out.

1 Like

David I was able to download and install this afternoon and it seems to have resolved the USB connection issue that I have been seeing. I am now able to maneuver the X, Y and Z accesses of the laser engraver using the Snapmakerjs-2.1.1 GUI. When CH34X_Driver_V3.4 install I am now able to change between COM 3 and COM 6 in the Port menu.

The SnapMaker is actually on COM 3 and I am currently able to control the engrave from my laptop. One addition to the Snapmakerjs-2.1.1 GUI that would be nice would the capability to turn on the laser for focusing, establishing the work origin, and/or checking the perimeter of the work to make sure the engraving will fit on the work piece. Other laser engravers such as the Full Spectrum H Series 20x12 Laser and the Darkly Labs Emblaser provide this capability and it has kept me from destroying many work pieces/wasting a lot of time in running an engraving run that is not properly focused/aligned.

David after I finished my previous post this evening I was playing with the SnapmakerJS GUI and found the Laser menu in the lower left portion of the communication screen. I had not previously expanded this menu and as I discovered in the attached picture this menu provides the ability to turn on the laser for focusing and adjusting the laser power for engraving.


Now I just have to experiment to find the right settings for the material/work/image I am working with.

1 Like

David Attached is a picture of a line drawing of a woodland duck that I was able engrave using Snapmakerjs-2.2.2-win-x64.exe (I upgraded from Snapmakerjs-2.1.1-win-x64.exe this evening). After a bit of experimenting I found that the engraving head should be about 1 1/4 inch (31.75 mm) above the popular block when the power was set at 80% and the Jog Speed was 300. I have also attached a copy of the G Code file that I generated while working on this engraving.
20780709_20780708_ducks (263.9 KB)

WoodlandDuckImage Woodland Duck Engraving

1 Like

Try BW Mode(This one suit the image you use) & Vector Mode. :slight_smile: have fun!~

Hi! I’m struggling to get a greyscale image to engrave. I’ve had good results with B&W images, so I know the laser works well. The issue is that when I load a gcode (either directly from the software or from the microsd), all I get is a black box. Check out the video below for an example:

Being an optimist, I tried engraving the image and got, predictably, a black box. What am I doing wrong?