Troubleshooting for Laser engraving


#92

I have no problems with v2.4.4-updated.1:

B/W-mode:
Preview:


Of course you can select the anchor you want/need!

Workspace (shows the visualized gcode - perfect radius of 35 mm):

Vector-mode:

Preview:

Workspace (only the paths will be engeaved/cut - perfect radius of 35 mm)):

I can’t see any problem…

When you update your software please reset the workspace too to be sure:

If your problem isn’r resolved please provide some explaining screenshots.


#93

Welp, I went to fetch 2.4.4 from the forum and it appears to work as you said. One would think the stable version would always be the best one. Though Win10’s defender and Panda antivirus both found a virus in the installer…

Thanks!


#95

In the new Snapmakerjs 2.4.6, in both the laser and cnc modules, the gcode is generated at 131% of the size I set. So to get an engrave of 120mm wide I need to set the size to 95mm. Is this something I am doing wrong or just a quirk of the software? I saved the svg file out of Inkscape at 120mm size, when I first import it, it is 125mm in snapmakerjs. I can work with that, it is the enlarging the gcode to 131% that took a bit to figure out.


#96

I don’t know what you are doing.
Did you set the size in the preview?



#97

Yes, I set the size as you are high lighting. Then when I generate the gcode, it resizes to 131% of that size in the workspace to send to the snapmaker It does the same thing in either the laser preview or the cnc preview.work%20space|690x388

.


#98

Hi, I’m having an issue with the work and jog speed. I upload the image I want engraved and the work and jog speed say ‘0’. I’ve reset to default settings and still no luck, I’m also using the latest software but this issue started with the one before. Anyone else had this issue? I’ll upload pictures of what my screen shows.


#99

For the life of me I cannot figure out why some files work fine on here and other do not. Can someone please tell my why this PNG file is not working? This should not be this difficult. This is on version 2.4.4. I can load the file in, preview, generate the GCODE and when the workspace screen opens I get a black box with a bunch of lines when when I start the print that is exactly what it prints. I black box.


#100

Remove the transparent layer of png file will do the work.


#101

Hey Jeff did you ever figure out the grayscale image problem. I recently got a laser engraver and am having the black box appear whenever I try to engrave a grayscale picture.


#102

There is no transparent layer (that I can tell) it is a single layer image and if I make the background white then I end up with “spots” on the background in the image.


#103

There is a transparent layer (alpha channel shown as greyed checkerboard) as shown in gimp:
xmas

The spots may be from your computer pausing while the laser is operating or you might have been able to clean up the image with the Black and White slider.

Here’s the image with the white removed and cropped:

You shouldn’t have to remove the transparency - I laser engrave PNG’s with transparency all the time. You probably just need to adjust your Black&White slider setting. I typically have mine set at ~165. But if for whatever reason that you do have problems, just open the png with something like MS Paint and save it as a jpeg. Here’s the above PNG engraved onto a card:


#104

I’m having a really tough time doing anything in greyscale. Would anyone be willing to try and run this as a test for me. The intent is to start at 100% power (Make Black) and decrease in 4% increments until we have a 4% black square(almost white) at a given speed so I can gather data as to what works well on various materials. It is meant to be a 115mm square with 25 filled squares of decreasing black level. Thanks in advance for any assistance.
25%20grays


#105

I just recently received my snapmaker and am having trouble getting the snapmaker to generate the gcode. When I first open Snapmakerjs and connect to the port, it shows as being connected. I continue to modify the image and hit generate g code and nothing happens. It will allow me to then click load to workspace but it doesn’t load anything into the command box. I may be missing something but am totally lost.


#106

Try smaller files, currently we have some trouble with big images (memory usage), or you can click View -> Toggle Developer Tool to see if there is any error log in console tab.


#107

I seem to be having issues with laser focusing. I recently purchased the Snapmaker as well as the 1600mW laser. When I set the power with the focus button in the newest version of Snapmakerjs, the laser does not turn on. It originally worked but has now stopped at random. I’ve only used it about 5 or 6 times for very small engravings, so I’m not at all sure what the problem could be. If I set the work power and start engraving the laser then turns on and works no problem. I use about 3% power (which I’ve been doing from the start) for focus. Even if I set it higher it never turns on. Any ideas would be helpful.


#108

@LouisT
You can use the command M3 P<percentage> (M3 P3 for 3%, M3 P10 for 10%) on the console to test out what power works for you, it’s equivalent to press the focus button. You can set the power either use work power or focus, the difference is the “Save” button only turns on the laser for milliseconds and then save the power for the next machine start.


#109

No matter what I do, I can’t get the laser to display for focusing. When I hit run it turns on but I have no way of knowing if it will even work.

EDIT: I figured it out, I had door detection on which I guess isn’t working right. When I turned it off I was able to turn the laser on with low power. I’m not sure why door detection isn’t working, I only just got this setup a couple weeks ago.


#110

I’m trying out the Laser Module and for the life of me can’t figure out a) where to set the work origin and b) how to set it properly. In the attached photo the text is centered properly in the upper the left quadrant of Snapmakerjs…


#111

in Workspace tab, there is an Axes widget where you can set work origin, turn the laser on at a lower power (0.5% for 1600mW laser) so you can see a little dot focusing on plywood. and then you can jog the head to a proper position, click set work origin. When you are engraving objects that need to be centered, you can set center of plywood as work origin and put your object (text) centered at (0, 0).


#112

In other words, measure precisely the center of the plywood and mark it(?) and set that as the work origin?