Troubleshooting for CNC Carving


#21

Stay tuned. We will release feature that allow you draw simple svg in Inkscrape or other software and then import it into Snapmakerjs to do simple cnc cutting. @jpoppinmoneyunit @selbonia


#22

Прошу сообщить о создании обновления для работы с SVG.
СПАСИБО. БПН


#23

Any update on using InkScape??


#24

I ended up mounting another motor…


Make sure you delete your M3 command in your gcode so your Snapmaker DC Motor doesn’t go nuts!
Here are a few pics of the finished pocket.


#25

image
Am I supposed to see a diffeent workspace button for CNC carving? The FAQ states if I don’t see it i should click, " Please click Settings -> Workspace -> Restore Defaults and try again." But I’ve tried that and I never see 4 items (like in this image attached), just 3 and the middle one I assume is only for laser?


#26

@stevilg
The CNC and Laser Engraving share the same workspace for operating the machine, load G-code and run G-code, etc.


#27

I am having trouble using the CNC to create a pcb board. The gcode is generated in Eagle (8.7.0) using the pcb-gcode plugin (3.6.2.4) and when i upload it to snapmakerjs (2.3.1) it appears to be correct, the run boundary is the correct size but when the gcode is run its a approx a 10th of the correct size. Im running MacOS Sierra 10.12.6.

Attached is the gcode.

Thanks for the help

PlantPCB.top.drill.tap.gcode (9.8 KB)


#28

Is this still working out well for you? How is the runout of the collet in relation to where it mounts to the motor? What is the motor shaft diameter?

Can you provide links to the motor you used? Is the mount 3D-printed and, if so, do you have the file(s) posted anywhere?

I’m trying to use square end mills to carve circuit board traces and can’t keep the bits from breaking. I suspect it’s due to runout. I’ve gone down to 75mm/min speed thus far.


#29

I used the original motor shipped with the unit. I was able to get a pulse out which was proportional to the speed. I am just having problems getting a closed loop speed control to work. I understand that they now offer a variable speed system with the new units. Do you know if this is true?


#30

@gdoland18 I was actually addressing two people in that one post. I know you’re using the original module; @ThinkMakeRepeat is using an aftermarket motor.

Anyway, I’d still like to know the Snapmaker module motor’s shaft diameter. The collets you bought will fit two different shaft diameters, it appears.


#31

Hello ThinkMakeRepeat, the spindles and collects I purchased were from Amazon also. The spindles had two bores; one 2.35mm and one 3.17mm. I do not remember which I used. The collect was a snug fit without much run-out but was mounted with a set screw (not the best). The set included 10 collects of various sizes. The supplier was Yakamoz and the Amazon part number is 60270186405. Hope this helps.


#32

The reason I wanted the shaft diameter is that I was also looking at this collet, which is for a 3.175mm shaft only:

I went ahead and ordered both, since the total came out to less than $15.


#33

The motor shaft is .125” which equals 3.175mm. Should work. The only tricky thing to using this chuck is being able to hold the shaft still while tightening it. You may have to drill a hole in the housing so you can stick an Allen wrench into the set screw used to hold it on the shaft to hold it while tightening the chuck.


#34

I’ve uploaded G-code to snapmakerjs from Fusion and it is doing something strange that i cannot seem to fix. It is just a pocket and it behaves normally in Fusion but this is what it does in snapmaker.

All it does is carve circles everywhere. I could use some help.


#35


#36

Double-check that you have installed the Fusion 360 plugin for the Snapmaker. Have you tried to print directly from Fusion 360?


#37

In the new Snapmakerjs 2.4.6, in both the laser and cnc modules, the gcode is generated at 131% of the size I set. So to get an engrave of 120mm wide I need to set the size to 95mm. Is this something I am doing wrong or just a quirk of the software? I saved the svg file out of Inkscape at 120mm size, when I first import it, it is 125mm in snapmakerjs. I can work with that, it is the enlarging the gcode to 131% that took a bit to figure out.


#38

Did you figure this out? Cause I am having the same issue and am unable to get the CNC carver to work…?


#39

I don’t have the little CNC icon on the left hand side, and if I generate a G-code it does not recognize the contours and depth (no Z axis) and just carves a blob and not a image…


#40

You’re using an older version (2.2.2) of the software. Update - just make sure you update the firmware also to match if necessary.