Snapmakerjs v2.5.1 Beta Testing


#1

This is the beta version of Snapmakerjs v2.5.1, we’ve made some big changes on Laser G-code Generator. Please check it out and any feedback is appreciated!

Changelog

Changelog:

  • Added multiple-model feature for Laser G-code Generator
    • Click engrave mode button to upload image
    • Select model to modify its parameters
    • Auto Preview: Once parameters are changed, model preview is applied immediately on canvas (there are still some bugs on SVG models)
  • Added keyboard bindings (delete button and backspace button) to delete models
  • Added keyboard bindings (up and down arrow) to change the preview layer of the 3D model
  • Bugfixes:
    • Fixed the bug that is unable to generate G-code on Snapmakerjs v2.5.0
    • Fixed issues when you upload different G-code/images/models with the same name
    • Fixed the bug that G-code is generated incorrectly for PNG files with transparent layer
    • Fixed the bug that changes on wall thickness, top thickness, bottom thickness do not take effect after generating G-code

Downloads

Windows 64bit:

macOS:

Linux 64-bit:


Bug Reports and Feedback for Snapmakerjs V2.5.X
#2

#3

How about still adding the possibility to adjust support printing speed? It’s too noisy at current unadjustable speed for example for night printing.


#4

Tried the beta 5 and the top / bottom seems to be ok.

The wall thickness is still wonky. I think the variable for calculating is the layer thickness instead of the nozzle diameter, because changing the layer height changes the wall count (eg. 0,2mm layer with 1mm wall gives you 5 walls and with 0,1mm layer height it gives you 10 walls)


Bug Reports and Feedback for Snapmakerjs V2.5.X
#5

Use custom 3D printing configuration, you can modify the printing speed. (We have had this feature since v2.4.0 I guess)
But even you can modify the speed, the noisy problem may not be solved. A box with sound insulation cotton is what you need :frowning:


#6

Yes we use wall count = wall thickness / layer height to calculate the wall count. As you see in the preview, setting wall thickness to 2 with layer height is 0.2, you will have 10 walls: 1 outer wall and 9 inner walls (see the red line and green lines).

In my scenarios, the new wall thickness works fine. If you still have problems please upload your model :wink:


#7

The issue I found is with the laser module.
When importing a SVG the vector is offset and I can’t it in the right place making it harder to engraving/cut. The vector doesn’t stay inside of the frame, also it scale it to 125 x 125 by default if it can, instead of just leaving it with imported size. It’s not always that we want to scale it. The imported SVG has the right size already.
With the offset issue, if I try to run the boundaries, it goes outside of the boundaries which is blocked by the axis motor.

With 2.5.0 there is no issue.

on the picture I’d expect the gear to be inside of the frame not on the bottom right with parts outside of the frame.


#8

Hi All

I would like to see the ability to change the scale on the X, Y and Z values like other slicer applications can.

Doug


#9

Yes, but the wall thickness does depend on the nozzle diameter and not on the layer height.

So I tested it and 1mm wall with 0,2mm layer is 5 walls (2mm wall thickness in reality) and with 0,1mm it’s 10 walls (4mm wall thickness in reality).

I even printed it and measured the wall thickness, as expected it was 2mm for the 0,2mm layer and 4mm for the 0,1mm layer model.


#10

I know your issue now. Currently we don’t add any restrictions to wall line width based on nozzle diameter, which causes the problem. The smaller layer height is, the more obvious the diff will be. Errr…I’ll try to fix it in the next few versions.


#11

Could you provide your SVG file (Or a simplified version) for us to test? It’s an SVG parse problem we can solve, the boundary is what it suppose to be, but the preview is what the G-code locates.


#12

Try this one.
drawing-2
I’ve gone back to previous version as this was causing me too much headache… :slight_smile: