Snapmakerjs starts briefly and then crashes immediately

Does anybody know the problem that Snapmakerjs starts briefly and then crashes immediately? I have already tested all versions from 2.3 to the latest version 2.7.1. In the 32 and 64 bit versions. With and without installed Snapmaker driver and the current Java version. With and without connected Snapmaker. Also without virus scanner and firewall. Every time the same problem.
System: Win10pro | Snapmaker Original

1 Like

Have you installed the Windows drive, CH340 Driver for Windows from their downloads page? Also have you installed the latest firmware?

Good luck.


1 Like

Thank you for your answer Doug. Yes, I have installed both in the current version.

I start SnapmakerJS as administrator. SnapmakerJS opens and closes again after 2 seconds.

I’ve had the same issue since day 1 of snapmakerv1 and still no solution. I even have the same problem loading snapmaker luban, so it’s obviously a similar issue. have you tried it on another pc? I managed to get it working on my laptop but never my main pc. even on a full format reinstall of windows and snapmaker. I’m assuming then that it must be a driver issue? who knows, I’m no programmer.


It is the same with me. It’s not running on the main pc. On the notebook it runs. It’s probably really a driver problem.
I installed “VirtualBox” from Oracle with “Ubuntu 64 Bit” on my main pc (windows 10 pro) and shared a folder for data exchange. With this I can work relatively trouble-free on my main PC.
With the USB stick I then copy the data to the Snapmaker. Maybe I can get it to work via USB.
SnapmakerJS v2.6.1 (2.6.1 works without problems)

1 Like

If the issue persists on your main pc but not your laptop, it could be a driver issue. Or you can try to do a clean uninstall for the software and reinstall it again. by clean uninstall I mean clean the registry leftover for the software. But please know it is very risky to mess with the registry. I recommend to back up your pc before you take this route.

1 Like

I use an uninstall cleaner every time, so there’s no registry entries remaining or abandoned files/folders. I think I managed to get it to run for about 2 weeks at one point without changing anything and then after an extended hiatus it stopped working again.

Have you loaded the Windows driver and latest firmware from the Snapmaker downloads page?