Snapmakerjs "line type" un-ticking removes nothing


#1

Hi there just curious if anyone else has come across this and knows how to fix it.

When i load a 3D model and generate G-code to see supports etc even though by default “travel” is un-ticked it shows these travel lines still and if i un-tick any of the others it still shows them too.
I can have all line types un-ticked and all lines are still showing.

I originally tested with Snapmakerjs v2.5.4 and un-ticking would shrink but not remove the lines and so I downloaded Snapmakerjs v2.5.5 to see if it was fixed in this version but alas its not as far as i can tell.

Any help is appreciated


#2

So no-one else has this issue? Can someone please tell me if their’s is working with 2.5.5 if that the case so i can try and work out what is happening.

Here is a link to some images showing what i meant as well: Picture examples

Thanks in advance


#3

You have to use the scroll bar to select another layer to make the change take effect.

BR, Michael


#4

Thanks, could you please explain a little more what you mean and if your lines go away completely as if i un-tick it and move the scroll bar a little it may pixilate the un-selected colors a little (not see through or anything), the lines still do not get removed so it makes it hard to see an individual layer.
Maybe its the version i’m using, what version are you using?
Thanks again


#5

Wonder if tagging @parachvte might help shed some light on this issue.
Hi Chen Zheyong if there is any help you could point to on this it would be greatly appreciated .


#6


#7

thanks @rojaljelly hmm so it must be something at my end but i cant for the life of me work out what as it is setup with default options,
I downloaded the same boat : https://www.thingiverse.com/thing:763622 to see it that one worked for me like yours did.but it didn’t, i have been un-ticking and moving the slide scaleand for the example shown and if un-tick the Outer-wall and Inner wall and slide the scale it goes from this (Not transport is always unticked and shows up also)

to this

Thanks for confirm it should normally work now i have to work out why it doesnt for me , im using Windows 10 x64 build 1903 Uninstalled and reinstalled snapmakerJS , Java version 1.8.0_201 and i updated to 1.8.0_221 (this was just in case it had any relevance).
I even Tried install the 32 bit version but that didn’t even give me a 3Dprint option
Bit Stumped as to where to look next