Snapmaker resetting mid-print


#1

Hi,

Anyone else having problems with their Snapmaker just “re-booting” mid-print? Seems like a controller or power supply issue to me.

The last 5 prints my printer has re-booted and I finally was there and saw it happen. One flash of the white boot screen and that’s all she wrote.

I’ve tried updating the firmware, re-slicing my file, checking connections, and printing from the SD card instead of octoprint with no luck.

Jake


#2

Hey, may you upload a gcode and a .stl file where the machine got stuck. (not too big pls :slight_smile: )
I could check it out for you, but it seems more likely a defective controller…

Chris


#3

Sure, this is the most recent one it reset on.

TransformerCover.stl (1.2 MB)

Here is a dropbox link to the gcode. Too big to upload here I guess.

Jake


#4

I’m still having this issue with the Snapmaker rebooting mid print. Any one else here having it?

It seems like it only happens when I come somewhat near the max build volume even though I’ve made sure I’m within the limit. Once I separated the file and printed something smaller, it worked fine. Or it just didn’t have enough time to goof up. I’m thinking the control board is over heating causing the reboot?

The latest one rebooted and then the Z fell smashing my prints. Can’t rely on this machine currently.


#5

Hi jpoppinmoneyunit.

Which firmware version did you use in Snapmaker motherboard?

When Snapmaker rebooted,is there any error message output or empty progressbar on the screen?(such as mintemp error or something)

Already download the gcode file,will be reproduce this week.I will put my result when it is done.Anyway, more information for the machine status will be thankful.

Alan.


#6

Hi Alan,

I’m using the most recent firmware version 2.4.

I’ve only been there to see it happen once and there were no errors before flashing the white boot screen. Progress bar resets to zero percent.

A few more details, it does it on the SD card as well as on octoprint. Maybe I can paste the log from octoprint or something next time it happens if that would be helpful? It seems like once it happens on one print then it’ll happen fairly quickly on the next.

Hope this helps.

Jake


#7

Hi Jake

I had tested the TransformerCover.gcode.Here’s the result(with Firmware V2.4)

It seems like something is forcing controller to reboot.I’m not sure where the problem actually is,but I think it may caused by the hardware.

Hope this can helps you.

Regards
Alan


#8

Dang. Yea I could never get that one to print. Thank you for trying it. Do you work for Snapmaker?

I’ve had a ticket in for quite some time with no answer. I’m really starting to think the controller is possibly overheating.

Jake


#9

Hi Jake

Yeah I am one of the Snapmaker staff,I had feedback this issue to my colleague before.Will follow this issue for a while.

Regards
Alan


#10

Cool, thank you for the continued support!


#11

Hi Alan.

I finally got around to trying the troubleshooting guide on the website and after five failed prints I finally got one to work when printing with the touchscreen unplugged.

It’s been a long time since I’ve submitted a warranty request and I still haven’t heard from anyone. Can you please look into it?

Thanks,

Jake


#12

Hi Jake.My apologies for the late response.

Could you please provide your email address which submitted warranty request to me? I have sent you a messsage via forum. Sorry for the inconvenience.

Best regards
Alan


#13

Hi @Alan,

It’s been a while since i’ve had this problem but now it’s back. After installing the Z extension and upgrading the firmware it resets randomly again.

I don’t know if this is related but it seems to only do it on larger prints.

Any suggestions? I have already grounded all of the axis…


#14

Hi jpoppinmoneyunit
Sorry for the late reply, did the issue still causing?

Did your machine reset when you tried to print a larger model every time, or just randomly reset no matter printing or idle? Any infomation for the issue will be thankful.

Best regards
Alan


#15

Hi Alan,

As far as I can tell it’s only during printing. It seems like it only does it on larger prints but maybe it works for smaller ones because they’re quicker and it doesn’t have time to reset?

I just noticed that the cord that plugs into the power brick slips out pretty easy. If there is a weak connection would that do it?

A little history, when I first got the printer it would reset often. And then for some reason it started working for about 9 months. Now it is happening again. Something intermittent it seems.


#16

Also, can you send me the serial number for my printer if I give you my kickstarter back number?

The technical request page asks for a ton of information that I don’t think people generally save like the serial number if it’s on the white box. I threw that in the recycling ages ago…


#17

I’m seeing the same thing on my one. Mid way through it seems to stop and the head sinks in to the print.


#18

Yep. That’s what happens to me.


#19

Is yours frequent? Every time? Is there any patterns you can see causing it?

It would be great to get more people on this forum speaking up about it because right now I have an expensive paper weight.