SNAPMAKER 3D software not loading properly on PC

The great news is I received my Snapmaker last week and built it in less than 30 minutes with the help of a 3 and 6 year old. Awesome!

The not so good news is I downloaded the the Snapmaker3D software version 1.7.5, installed it and then opened it on my computer. It opens however I can not see any of the menus in the software window. I know it’s there but it’s invisible in the background. I’m running Windows 10 and my computer has plenty of memory.

I’ve uninstalled the program and reinstalled 6 times. The definition of insanity is doing something over and over again and expecting different results.

Has anyone else encountered this issue?




Amazing, I can run the Snapmaker3D application on my Windows 10 Pro and Home versioned PC’s with no problems. What screen resolution are you running?


Hi Doug, I’m currently at the highest setting, 1366x768.

1 Like

Hi Borinkito

That should work OK. Have you sent an email to ?

I have included @Rainie in this message so that it gets into the pipeline. Be patient I know that they are busy.

Maybe some other users might have some suggestions.

BTW, I am just a newbie, located in Australia and having fun learning about this art from… lots to learn.


1 Like

Thanks Doug. I am being patient. I have waited a while and spent a lot on this machine. I can wait a little while longer. If I have to use a different 3D printing software, I’m ok with that.

Thanks for reaching out all the way from Australia! I’m in the USA. I’m looking forward to testing this thing out with my kids. They are more excited than I am.

Do you use another software, such as SLICR?



Hi @Borinkito,

Thank you for reaching out to us!
This is a tricky problem. 2 of our users ran into this problem too, but we can’t reproduce it in our office, so we may not be able to solve this problem quickly.
The temporary workaround is to use another computer if you have one. If you don’t have another computer, you can use Cura or Simplify3D as the slicer. Settings for Cura and Simplify3D are collected at

If you have other questions, please feel free to contact us! Thank you!

Best regards,


Thank you @Rainie

Your support is wonderful and appreciated.


1 Like

Hi @Borinkito (@Rainie )

i forgot to ask a few questions earlier. Are the drivers for your video card up to date?

Are you running the 32 or 64 bit version of Snapmaker3D and does that match your operating system type?


Hi @Rainie,

Thanks for the quick response. I am using my daughters OLD laptop but so far it seems to be working fine on there. I updated my graphics card and quadruple checked the operating system I’m running, 64 bit. So all is well on both those fronts. It’s frustrating that it doesn’t work on my computer but I’m glad at least now I’m able to use the software program.

I am having problems getting the filament to stick to the bed, I’ll follow up in the appropriate forum section for that though.




Hi @doug,

I’m running 64 bit version of Snapmaker for my PC. I quadruple checked and made sure it was the right version. Thanks for suggesting I update my graphic card. I did that so now I have an updated graphics card. However it didn’t solve the issue I’m having.

Luckily my dad gifted my daughter an old laptop they aren’t using and thankfully the software works fine on there. But still it’s frustrating. Nonetheless, I’m at least trying to print. Now I’m having issues getting the PLA to stick to the bed when printing… :o)


Hi @Borinkito

Thanks for the response, much appreciated. I am stumped by your black window problem.

As fro your print adhesion problem.

I am a newbie to all of this. As a suggestion try using RAFT as the adhesion setting, I found this to help a great deal in getting your prints to work. It lays down a little mat before printing you project on top of it. On completion you can peel this raft off easily from the bottom of the project.

Here is an example of one that if printed and you can clearly see the raft under the project IMG_0808b

I hope this helps


1 Like

In regard to the blank screen upon snapmakerjs program start, I get that every once in a while. I just close it and start it again and it’s good. Im using W10 on a Lenovo W530 laptop.


So I supported the kickstater for the new Snapmaker a350 and was wanting to try out the slicer and I downloaded the Snapmakerjs 2.5.5. When I launch it there is no 3d print option just the jog, laser, and CNC options. is this avaible for me and if so how do I unlock it or download the new extension.

1 Like

If you click on the 3d box - G code generator file - an upload an stl file, you can set the printing options, and then you can generate the G code and either save it to a file or send it to the printer if connected. I use Cura to slice and generate G code and Octopi to control the printer so I may be rusty on Snapmakerjs

We are having the same problem with the snapmaker program loading up with a black screen every single time tried closing it tried reinstalling it but to no avail we still get black screen. My partner is so pissed off he’s thinking about throwing it away. We managed to print a couple of things when we viewed the program in browser but that is all. We can’t generate gcode for laser or cnc and now printer head is stuffed

I downloaded and installed the newest software as I need to upgrade my firmware for the new longer post for the original snapmaker but the program will not open. It shows running in the task manager but nothing ever show up on the screen. I ran it as administrator and uninstalled and reinstalled and even uninstalled and tried the newest beta version and get the same thing with that as well. It will not load onto the screen and only shows that it is running in the task manager.
Windows 10 Pro edition

I’ve got the same Problem.
Snapmaker 2.7.1: Snapmakerjs starts briefly and then crashes immediately
Original post
Snapmaker: 2.4.0: Snapmakerjs starts with black window
When i start “Toogle Developer Tool” i see the following message