SM2 Bed Leveling

My bed is not flat so a larger set of data points may help the underlying issue.

There is more than one problem here, 1) the beds are not flat and a larger number of check points would fix or greatly help that. 2) Some people are seeing the z height jump around and not be consistent.

1 Like

And 3) sometimes it didn’t work correctly (auto cali before printing) - for me one of the critical points!

adjustable calibration

  • before print on/off (if an initial calibration is done
  • with heated bed on/off
  • 3x3, 5x5, 7x7, maybe more options (for small prints in the middle i can choose what i have to calibrate), best solution, software checks the size and location of print and choose the best routine (nr of points and location)

Maybe with a menu at sm and/or luban, additional with m-codes.

Is no one else able to disable the quick calibration that runs before the print starts like I am able to do?

How do you go about disabling the quick calibration DroneOn? I’ve been having the same autolevel issue error (hot end digging into the bed because the sensor isn’t responding). I disabled the auto bed level function and did a manual level, but it still tries to quick calibrate before the print. I don’t see a setting on the touchscreen to disable it and I haven’t found a place in the Snapmaker Luban software that allows you to edit the actual code to manually remove that autolevel line.

I’m going to try a print using my Simplify3D software this evening and see if I can get a decent print using that and a manual bed level, but it would be nice to do it all from within Luban.

This is on the firmware rev as I received it in the box. Controller v1.6.0.0 and touchscreen v1.5.2.1
2 Likes

Thanks! I don’t remember seeing that on my settings page but I’ll check again when I get home tonight.

I don‘t have this icons… just 4 (like i posted before).
Is there any option „expert mode“?
Beta-Tester?

I do only have 4 Icons, too.

Touchscreen Version 1.5.2.1 / Controller Version 1.6.0.0

I’m not suggesting that the bed heat up faster, merely that autocalibration wait for the bed to heat up prior to running. You’ll have to explain why the current PSU can’t do this.

Also, I’d love if my firmware had the same option @DroneOn has to disable auto-leveling prior to each print.

I only see 4 icons. I wonder if your TS slipped thru with some kind of debug mode turned on?
@parachvte?

1 Like

Yeah, same here.
Want this mode/option too!

There is a factory menu on mine as well but it is all in Chinese so I have no idea what it says

Dead Pixel test
CPU performance test
Wifi Signal strength test
Display brightness test
Touchscreen test
and Bluetooth test

Mine had the 6 icons, including Experimental since the I set it up without any changes being made to the settings that I can recall.

Thanks for the tip about turning off the quick calibration. Using it and turning off auto leveling calibration permitted me to set up the leveling manually and now no more minor gouging or too high off the bed for parts of the initial level to stick to correctly.

I hope they fix this and the ignoring M104, M140 codes (after the first). I welcome back being able to have the initial level level extruder and bed heat settings to be one and then drop 20C for rest of the printing to avoid as much stringing and nibs as possible.

I’m going to pile on with the leveling issues. I’ve run the calibration several times and am simply trying to print a large flat object, but I cannot get a good first layer, regardless of what I do. It is very clearly not getting an even first layer, with certain areas being flattened properly, too much, or not just barely touching the build plate. It’s making it very difficult to use.

Thanks for the translation. I don’t seem to need any of those options but my hope was that there may be a way to turn on the options I have for others that need them.

So I designed a holder for a dial indicator (which I’ll eventually post on Thingiverse) and scanned my bed and it’s all over the place. My question is when you’re in the movement screen, is the bed leveling system active? @parachvte ? I’ve been thinking about a little and it seems to me that the bed leveling compensation should only be in effect when you’re close to the bed and slowly be phased out as you move away from z=0. Otherwise your whole part is warped to match the shape of your bed. Anyone know about the guts of the marlin leveling code?

I finally had some more time to investigate. First off - I did get a machine where I can turn off fast calibration.

I spent some time placing small test models all over the print surface and ran a run boundary, and watched as the nozzle distance to the surface fluctuated wildly. Could this be a problem with the mat, or is the actual heated print surface underneath really THAT NOT FLAT, or is the calibration sensor that wildly inaccurate? I haven’t messed with the print module, adjusting the sensor and all that yet… maybe that’s what I have to do. :confused:

Update: I went in and manually calibrated the leveling, and ran the same test. It’s still all over the place. I would say there is a 0.1 mm difference between some high spots and some low spots, making a full calibration over the full board really ugly.
I still haven’t messed with whether this is the mat or the heated bed. …

@Tone It should be in effect otherwise higher layers will not match with lower layers.

@Tone @DroneOn @Raptor @onyx0909 @Jayberz For the guys mentioned about the “icons”, there is an way to turn on dev mode of TS, with 2 more apps “Factory” and “Experiment”.

But I don’t recommend you to turn it on since only very few options people would need (unless you have a bed leveling issue and want to disable to fast calibration before print), and contains options that are debug-only that will cause the TS to crash (you will have to reboot TS when it’s crashed).

Here is the routine to open dev mode: Go Settings -> About -> Tap the image on top for 5 times to activate dev mode (Tap once more to inactivate dev mode). The option to disable fast calibration sits inside “Experiment” app.

Next week we will have a firmware update, adding a quick fix for fast calibration and some debug functions. To let our early adopters to export logs, which could help us to precisely describe the issues we met, and the steps taken that lead to the problems.

Thank you all for the patience and your effects to make our product better :grimacing:

3 Likes