Printing issue - Z axis stoped moving properly


#1

I decided to do a slightly larger print. I think I finally got all the settings dialed in for success. And then failure struck.

For some reason it not only stopped moving up on the z axis. It actually lowered for some reason - and the heated tip fused into the piece (and im pretty sure bent the tip) not a great way to start. On the plus side none of the servos burned out and I was able to jog in all directions after removing the printing module.

Now i have to figure out how to change the tip. Wasn’t expecting to have to on my third print.

Any ideas what caused this problem?


Custom Print settings?
#2

Have you figured out the reason for this or has Snapmaker support helped? I’m having a similar issue where my Z axis is working fine and then stops moving and it’s tearing up my prints. I’m using Cura to create the g code. I can have the same print work perfectly fine and complete, but then the second time I print it may not work. It’s very odd.


#3

I have meet the similar case yesterday and today. There are total 4 times. with 2 different models.

3 of 4 times are stop at certain Z-height. but X/Y still moving. The nozzle keep scratch on the material, when issue happen, I stop the print, and tried to use controls to moving the Z height, not works. Power off and power on again, then Z-height control is working again.

The last failure is also interesting, Z-height ever stop for certain time, but recovered to moving again.

I made some trouble shoot, change the Y/Z, still have failure. later I modified model file a little bit, it works for 2 print. Seems Snapmaker have issue to hand some corner case.


#4

I reached out to support and they had me change my z drive from port 5 to 4. Once I did this, everything worked properly. Apparently there is an issue where port 5 gets shorted out.

From Support:
“We think it’s the static electricity generated between the modules that damaged the port 5. This happens more often in winter than in summer because of the dry weather.”


#5

Thanks for share! After update model, printing is stable. I will keep monitor.

If ESD damage theport, it shall not work at all.but it recover after power on & off.


#6

I got the issue again, After 4~5 good print, issue occurred again. now I change Z- drive port from 5 to 4. See weather it helps.


#7

I had the same thing happen: Did some good prints and then tried a larger one and the z-axis stopped working while the x, y, and material feed & nozzle heat continued. Made a rather flat mess. When this happened and I stopped the print, the Jog mode would not move the z-axis. After power cycle, everything worked fine. After some troubleshooting, I found the root cause is the g-code generated by Snapmaker3D. The g-code moved the head down into the material and the controller took the servo motor feedback as a failure and would stop all further movement on the z-axis (until power cycle). I manually edited the g-code, making the z-axis value always increase and the print works great. This is a bug in Snapmaker3D that needs to be fixed. How do I log a bug report?


#8

Post it in this subcategory : https://forum.snapmaker.com/c/software-and-firmware/snapmaker3d-for-3d-printing
There are some bug reports there specific to certain versions. Be sure to mention what version of software your using.


#9

Have had this exact same problem start happening for me. I have only completed 2 successful prints, and the last 4 prints I have tried start, and at some point between 15-65% complete stop responding on the z-axis completely, resulting in the extruder digging into the print and just printing on the same z-level messing up the entire print, if it does not cause it to completely detach from the bed.

Once this has happened, if I go to the axis control and try to move it on the z-axis, nothing happens. It does not respond to any + or - commands, and the other two axis also respond very slowly. with a 10 or so second delay, as if the entire machine is lagged down.

As soon as I power it off and back on again, I can go back to the axis controls and all of them respond immediately.

My Z-axis is already connected to port 5. I have just moved it from 5 to 4 to try again and see if anything gets better.


#10

Just here to add that the malfunction noted here has been happening to me as well. The good news seems to be that it is a problem with the controller unit. Has anybody seen anything resembling a response from snapmaker?


#11

It’s a known issue, they simply recommend switching the connection to the other Z-axis port.


#12

I now have the same problem on the alternative port. Have they acknowledged that the control unit has a design flaw and needs to be replaced?


#13

How do you change the Z port from 4 to 5 or vice versa? Is there a setting somewhere?


#14

I started experiencing this yesterday. I’m in South Africa and have a lot of static this time of the year.
Is there any recommendation to reduce the static?
Is my port 5 now permanently damaged? Can I move it back to port 5 in a month or two?
@Rainie
Regards
Waldo


Z axis after printing issue
#15

I’m having the same problem.
After restarting it works fine again so it does not seems to be a short circuit. Only happened in higher projects, usually above 8 cm.
I’ll try switching the port 5 to 4.