Printer nozzle will not clear print bed -- printer cannot be used


The entire cone of the nozzle is below the top edge of the bed. I did another print (w. a raft) of a cube and it repeated again the banging against the bed.

I checked the screws and all are tight. I did remove the print module to fix a filament problem but it is installed per the instructions with one empty hole in the plate above the screw and one empty below the bottom screw. But this is moot as the printer after installing the print module printed once fine.

Attached is a picture of the print head as it was stoped. I just turned off the power to the printer. Thanks for the help.

Jose Rodriguez


I would like to add that the problem started with the printing of an object where the first layer would not stick to the base (like the nozzle was too high). It did this several times so I recalibrated the printer, saving the values. Then the nozzle badly scratched the plastic layer in the top of the (this was last Sun.). I posted an email for help on this but got no reply.

This Sat morning, I more or less removed the damage plastic in the bed and tried to print a sample object (a cube) with a raft (as the plastic on top of the bed has a a big hole). But now the nozzle will not clear the bed when it starts printing. It has done this twice.

Jose Rodriguez


i’ve had it where after a really bad failed print, i installed a new head and heat block and dug into the plate badly. With the unintentional physical contact like that, especially with the damage to the plate, I would probably take it apart and put it back together. This should be done regularly anyway. but i would try essentially re-seating everything.

  • Unscrew build plate and reinstall
  • Unscrew 3d module and reinstall
  • Verify that the nozzle is fully screwed into the heat block
  • Reset calibration settings (not just re-calibrate, reset to defaults them first).

Other than that, I would defer to Support.


I think I’m going to use some blue Loctite on the screws when I assemble mine.


So I had problems with my Z Axis, tech support had me change the port of the cable from port 5 to port 4. They had stated that there is a known issue where port 5 shorts out. Give this a go and see if it fixes your issues.


I tried it. Made no difference. When a print starts, there is this low humming sound that appears to come from the Z axis module. The nozzle does not raise and when it moves, it hits the bed.

By the way, using the small LCD controller, I can raise and lower the print module so at least that way, the Z axis module is OK.



I’m wondering if there’s a loose screw in the Z-Axis module from what I’ve read in this forum. It might not be catching close to the bottom of the track, thus causing the printer module from raising. Eventually it catches and the printer module raises. It’s worth a check to eliminate another possible cause.

Another possible solution is to use a different slicer, i.e. Cura or Simplify3d, and use the start script that’s been shared in this forum.

Good luck!


As the three transport modules are all identical, try switching the Z with the X. This should tell you if the Transport module is defective.


Just had a similar problem. After connecting the enclosure switch, the nozzle startet scratching the bed as soon, as I closed the door.
Disconnected the enclosure switch and the positions are OK again.


Hi !
I’ve got the same problem !


My nozzle is now doing the same thing… I changed the sticker on the bed, and ever since, it bangs in to the top left corner just prior to printing. That corner is starting to get banged up after 3 prints… I’ve homed it, reset it, levelled it, check that everything is tight… I cannot find what accounts for this.

I know I have the thumb screws on as tight as they can go… it is the same bed… nothing has changed. What is going on?

I appreciate any advice here…



Did you check if you choose the correct mounting holes??


Yes. It won’t really fit using any of the other holes… I know the thumb screws are tight… but I’m just going to pull it apart and put it back together I guess, and hope for the best…


Any update on this issue? I just re-installed and callibrated my 3D module today and to my horror, the nozzle scratched the stickers on the plate…I changed it , recalibrate and scratched again.


I have just encountered this issue after updating the Firmware to v2.8.
Unable to find a solution, my work around at the moment (using Cura) is to add a ‘G1 Z1.5’ into the ‘Start G-Code’ under machine settings.
This raises the Z axis 1.5mm after homing, before starting the actual print.

Hope this helps someone!


Well, I found out what was wrong for me. I was a relatively early backer, and got in on the first non-beta shipments. The bed that shipped with mine had rubber “O” rings underneath, around the thumb-screw holes. It looks like they bailed on this design, using metal nuts instead. Probably for this very reason.

One of my O-rings became dislodged, and would not settle neatly back into the channel that they have to help hold the O-ring in place, since it isn’t properly aligned

(and there really isn’t a good way to cram it back in and have it stay there without some sort of glue), the bed was raised on that corner. That corner happened to be the top (front) left corner. Since it was higher, the nozzle banged into it every time it started. After installing the new model (with the hex nuts instead of o-rings), it is working normally again.

Getting a new bed might be the solution that is needed here…


OK… so much for that hypothesis… It is STILL hitting the 3D printing bed – even with the new bed replacement.

The thumbscrews are on as tight as humanly possible… there is no debris wedged in there… I didn’t change anything within the snapmaker itself (i.e. no customizations) and it has never suffered any maltreatment… Why is it doing this all of a sudden?

Maybe I’m barking up the wrong tree here… I just printed something, slicing it in the snapmakerjs application… instead of Simplify 3D (which I’ve been using)… and it did not bump. Something must have changed in the last update… maybe their new fff is bad… I don’t know… but there is probably some bad gcode in the slice that is causing it… If you are having this problem, can you indicate what you are slicing your prints in? S3D, maybe?

You can bet I’ll be reaching out to them on this…


@moonglum Sorry for the problem you ran into.
Please fill in the warranty request, and attach a video or several pictures of problem and describe the problem in details.
We will transfer several questions to you from our engineer later and instruct you to locate the problem.
Once the problem is located, we will provide a solution to you accordingly.
The more detailed your description is, the fewer questions we will have.


Hi Steve!

Thank you!! I was beginning to think that none of the snapmaker team looked at the forums any more…

I did find the issue. The problem seems to have been an incompatibility between the last couple firmware updates and simplify 3D. As indicated in my last post, I did reach out to them. The fff needed updating… we went round-and-round for a bit there, but finally they nailed it. It also clears the bed with the latest snapmakerjs… so all is good there too. There must have been some pretty substantial changes in the last firmware update (or maybe update before last, actually).

I’m back in business.

Thanks again for keeping an eye out for us.



@moonglum Glad to know that you problem was solved. Actually we will follow the forum and try to reply when anyone facing the problem. Seems many users would like to post the problem in facebook group and less users take a visit to forum now.