Mac OS High Sierra


#21

I did, twice now just to make sure. I have rebooted the Mac but still it doesn’t see the 3D printer.
I just looked at github but I don’t see any extra information which is helpful.
On my older macbook, it was working witht the CH34X 1.3 driver, which was automatically copied to this newer imac (I have migrated my whole account).

Also, I read on the forum that more people are having issues with High Sierra in combination with the Snapmaker.


#22

I tried all the suggestions but I was unable to get my mac to see recognize snapmaker while cabled. I came across the instructions below that relate to the driver. After following the steps I was able to connect to my snapmaker. I hope this helps

  • Unplug any CH34* devices.
  • Unload the old drivers if running:
  • sudo kextunload /Library/Extensions/usbserial.kext
  • sudo kextunload /System/Library/Extensions/usb.kext
  • Remove the old driver by issuing one of the following commands (depending on your installation):
  • sudo rm -rf /System/Library/Extensions/usb.kext
  • sudo rm -rf /Library/Extensions/usbserial.kext
  • Double-click on the CH34x_Install_V1.3.pkg file and install (no need to reboot)
  • Instead of rebooting, you can force quit Installer after it completes.
  • Load the new driver:
  • sudo kextload /Library/Extensions/usbserial.kext

The newest drivers are listed here


#23

I did all the things you did when I first upgraded to Mojave.

After a bunch of install and uninstalls, it works finally. The final result is: just uninstall the driver and reboot.


#24

Is this problem solved for Snapmaker 2? For Catalina?

It seems irresponsible to promote snapmaker 2 if it isn’t.