Mac OS High Sierra


#1

Anyone else having issues installing the drivers for Mac OS High Sierra? I’ve tried several times now and am unable to get SnapmakerJS to recognize the laser engraving module.


#2

I ran into the same issue, so I installed the additional driver, and now my MacBook Pro freezes when trying to log in. I’m having serious concerns about what exactly those drivers did.


#3

Hi @spkeelin One thing I want confirm, is it just laser module? Can it recognize 3D Printer Module & CNC Module. If it can’t. Please make sure to connected to the right port. /dev/cu.wchusbserial1410

Bests,
David


#4

Hi, @elpelon We use CH340 chip which is used by a number of Arduino compatible boards to provide USB connectivity, We get driver from the official website.

According to your description, I do some google, Did find some relative infos.
Check this out.

https://sparks.gogo.co.nz/ch340.html

Could you try

Let me know if it solve your problem.

Bests,
David


#5

Snapmakerjs did not display the laser module so I downloaded and installed the CH340 driver for OS Sierra and now my computer won’t even start. God knows what to do! - any thoughts anyone?
(writing this va my ipad)


#6

Followed all the above and more to try and uninstall the CH34X driver.
Now re-installing the OS !
Let’s see if at least that gets me back to the start


#7

All fixed - it took me two goes
Went to safe mode when rebooting - learned something new there - used the disc utilities first aid but that didn’t reveal anything.
Installed the latest OS - failed first time
Second time I sat and nursemaided it at every step-] - about 40 minutes and fantastic my Mac was back.
Then starting up snapmakerjs - guess what the laser console was there too.
Lovely

Got myself a clip art image of a greyhound and 4 minutes later my first laser etching

Lovely.


#8

After installing I cant find it in the list of devices "After the installation is completed, you will find serial device in the device list(/dev/tty.wchusbserial*), and you can access it with serial tools.
If you can’t find the serial port , you can follow the steps below:

  1. Open terminal and type ‘ls /dev/tty*’ and then you will see devices like tty.wchusbserial;
  2. Open ‘System Report’->Hardware->USB, the right side is “USB Device Tree” there will
    be device named “Vendor-Specific Device” and check if the Current is normal."

Ive installed it about 10 times now and it doesnt show up


#9

1.3 still did not install or show up


#10

Same issues for me. I’ve tried multiple installs of the driver following the instructions above and in the read file on an iMac and a new iMac Pro both with the latest updates of High Sierra installed, and nothing - it won’t even recognize the portable USB drive. To say I am frustrated beyond belief is an understatement, especially when I see others unresolved for the same issue dating back to February.


#11

Most of the fault lies with Apple. In High Sierra, they made significant changes to USB support and have not published any documentation about the changes. This issue is not limited to the Snapmaker. Part of the fault does lie with Snapmaker for not using one of the two most common USB chips (Silicon Labs and FTDI), which seem to work just fine in High Sierra.


#12

Thanks and good to know. But how do I change my printer from an expensive and not very good looking paperweight to do what it is supposed to do in the meantime?


#13

Use the USB key. The first several prints on my Snapmaker we’re done by exporting G-code to the USB key from Snapmaker3D, plugging the USB key into the printer, and then using the touchscreen to start the print.


#14

Not even recognizing the key - tried that too. First instance I’ve had in almost 10 yrs of Apple use that a USB item wasn’t recognized.


#15

The computer isn’t recognizing the key, or the printer isn’t?


#16

Computer isn’t – Export is greyed out and when I go into look at the USB tree – everything else is there but the usb key - and given there aren’t any files on the key to begin with (if someone from marketing is listening, how about a couple of small files for just this purpose?), I can’t tell if the printer is reading it.


#17

You need to press the Preview button in Snapmaker3D to get the export button to enable.

As for the USB key, try a different thumb drive. It just needs to be formatted FAT32. I used an HP thumb drive when I accidentally dropped the supplied one behind a bookcase.


#18

OK - that did the trick. At least I can print this way while waiting for a direct connect fix. Appreciate it :smile:


#19

@ Snapmaker Team: I recently bought a new iMac. I have the same issue: It doesn’t see the printer connected to the USB port. also, The Firmware update seems not to be working but that’s a different topic.

Will there be a new driver soon for mac OS High Sierra?


#20

@aphex_84
Did you install the CH34X 1.4 Driver from our download page?
We don’t develop the driver ourselves. You can checkout the github link, follow the installation instructions and troubleshooting to check if the driver works for you.