Laser won't burn if gcode is generated when computer is Not connected to Snapmaker


#1

Ok ,I’ve found a problem I don’t like ! In my opinion I should be able to generate a gcode for my laser on my computer, then export to my usb drive , then take and insert usb drive into my Smapemaker and then laser etch my file ! BUT when I do this my laser won’t burn ! The only way I get it to work is by connecting the laser to the computer while generating the gcode and leaving the laser powered up, disconnect the usb cable , and export gcode to usb drive, then insert usb drive and run file. what ever you do DO NOT POWER OFF THE LASER ! or the laser won’t burn ! Snapmakerjs is NOT incorporating th laser commands into the gcode for the print !
The real question here IS “Why Does Snapmaker3D incorporate power settings for the printhead in the start code for printing” and “Snapmakerjs DOES NOT incorporate power for the laser in the start code for the laser !” Rainie Zou can you help on this ?


#2

Hi!!

Same issues here. The Laser stays off when i push the button play in G-code. Help us Snapmaker team :wink:


#3

I have the same issue. I don’t want to be tethered to the laser engraver when my comfy (“work”) couch is in the other room. So I googled the g-code commands open the g-cdoe *.nc file in notepad++ and make the following changes…
replace all “M03” lines with “M03 S6000” (turn laser on at 50%)
replace all “M05” lines with “M05 S0” (turn laser off)

I noticed some of my nc files have just M3 / M5 instead of M03 / M05 and am not sure if that because they were made with an older version.

For the M03 line the S bit is the laser power between S0 (off) and S12000 (on at 100%) so depending on the material / image adjust accordingly.

Yeah I haven’t plugged in my snapmaker to my computer and Snapmaker JS doesn’t even show the Laser section in the Laser G-Code generator or the workspace so I have to use jog mode and set origin on the snapmaker. *note to the Snapmaker team: It’d be really awsome if there was an auto center laser origin on build plate option! (Like how the 3D module knows where the edges are.)

Hope this helps those who refuse to plug in their snapmakers! :wink:


#4

Please download the latest version 2.4.6 of Snapmakerjs.
The feature is new:
grafik


#5

Yup. that’s what I was looking for! Took me a while to actually read the download page and see that I have to go to the form to get the latest version. Fixed another issue I was having so double win!

Thanks rojaljelly!


#6

with firmware GD32Base-2.11 I just figured out :
(edit) for the 1.6 W Module !

  • M03 S120 -> 48% power on touchscreen
  • M03 S61 -> 22% power on touchscreen
  • M03 S30 -> 6% power on touchscreen

so S12000 for max power is bull**it S6000 will burn also with full power.
I miss the Documentation for those details, where is the Link to real information, according to the firmware?