Gcode not generating right

Hey, so I’m trying to replace a light switch cover, and snapmaker appears to be oblivious to how to read the model.

What I want to print:

How the program writes the code:

I have no idea what to do, same result from .stl and .obj source.

I assume you’re using SnapmakerJS? Which version?

Did you design this object yourself? If so, how thick are the parts that aren’t printing? Pieces that are too thin to print won’t be rendered. That’s kind of what it looks like to me. Parts have to be at least as thick as the layer in the Z axis (depends on your print quality), and 0.4mm in any X/Y axis (assuming you haven’t installed a smaller nozzle). Snapmaker will allow you print layers as thin as 0.05mm (using custom quality) if the layer height is the problem.

If that doesn’t help, once you’ve generated the G-code, there is a vertical slider on the right side. The number above the slider is the number of layers required to print the object. That should match the (height of object / layer height). Drag the slider all the way down to 1, and see what it’s doing. If don’t click on anything after you drag the slider, you can use up and down arrows to move the layer up and down by 1. If you did, you can make the arrow keys control the slider again just by clicking on the slider handle.

I like to render the travel path by checking the box in front of “Travel”. That will tell you where the head is moving when it’s not printing.

Talk a look at the layers as it builds up to the problem. If that doesn’t give you an idea about what’s going on, try rotating the part 90º around the Z axis. I’ve fixed some rendering problems in Snapmaker3D that way.

You could also try re-generating the g-code at a different resolution. I’ve seen a generation fail, only to work on a different resolution, then work on the original resolution again. I haven’t been able to figure out why it sometimes fails.

If all else fails, upload or link the .stl or .obj file, and I’ll see if I can figure it out.

1 Like

I don’t think thickness of the parts is the problem here. I believe the problem lays with the CAD program being used to generate the STL file.

I’ve seen this problem when the model is not properly consolidated before exporting.
Unfortunately @JReiman doesn’t mention the origin of the STL file.

I have a new PC and a new install, I’m using Snapmakerjs 2.6.1.

Thinnest part horizontally is 5mm. I’ve fiddled with various settings, including layer height, but that strange lid still appears. I noticed that rotating it to it’s side fixes this issue!

@BriHar, I use Sketchup. But I also imported and exported this through blender, with exactly same results. exported .obj too, obviously.

I also tried Cura, which drew it exactly the same, and 3Dprinteros completely filled everything.

I’ve uploaded a slightly revised version, I removed an unnecessary line from one side, was “splitting” past the left side hole. cover.stl (24.5 KB)

1 Like

When I use your cover.stl, I got some weirdness. Even before rendering the G-Code, it’s very strange. It looks like every surface is extremely thin. Sides, tops, and bottoms disappear depending on how I rotate the mode.

Here’s a picture of what I see before rendering: 27%20PM
If I rotate the piece clockwise or counterclockwise, the four outer walls do show up. If I look down at the part from above, it looks similar to the picture. If I look up at the part from below, there is a sold layer on the bottom.

When I render the G-Code, I get something better than what you show, but it still has some floating pieces.

As hard as I try to zoom in on the walls pre-render, they disappear when I get too close. So I think there might be a wall thickness issue here.

How in the world do I even adjust a 3D models wall thickness? The insides are supposed to be solid! This has never happened with any of my models before.

Try using the solid inspector plugin for Sketchup and use it to fix problems with the model before exporting.

Yes. It looks like you have some issues with the STL. Probably duplicate points, intersecting planes, reversed normals… that kind of thing. That can throw a slicer for a loop.

I don’t know what software you are running, maybe BriHar’s advice will work for you. If you want to try something else, you can download freecad, and use the mesh work bench to check the stl. It does a really good job of looking for non-solid anomalies, and a good job of fixing them, so you won’t need to do any mesh editing (unless the stl is really bad, if that is the case, a re-design is probably in order). As the name implies, FreeCad is free (as in freedom), so you can download with impunity.

Good luck.

1 Like