G-Code generate button isn't selectable


#1

Hello @Jade or other admins,

I’m trying to print this file in SnapMakerjs 2.5 but the Generate G-Code button isn’t selectable. I’m scaling the file to 1200 percent and rotating the Z axis 45 degrees to print diagonally across the bed (see screenshot).

I_Love_You.stl (488.2 KB)

It’s a 2 part build and the first file I printed (1200% scaling) worked just fine, this one: I_Love_You_Base.stl (1.8 KB)

Any help would be greatly appreciated.

Thanks!


#2

@Borinkito

You should reset the workspace after each update of the Snapmakerjs-Software.

Just tested it - worked for me (I don’t use the Snapmaker software for 3D-printing so I didn’t saw the problem earlier)


#3

In SnapmakerJS 2.5.0 there is a known bug. If any part of the print falls outside the print area the gernerate G-code button becoms unavailable, but is supposed to become available again when all parts are back within the print area, but it does not, it stays greyed out/unavailable.

So if you have any bit outside the print area when opening, scaling, rotating etc. you won’t be able to generate G-code.

I went back to version 2.4.6 because of this issue. A fix should be out soon (stated to be in 2 weeks, that was 14 days ago!), check Parachvte’s post in this thread (post 17, currently second last post).


#5

There is everything inside the print area in this case…

For this model you can rotate the object before resizing to avoid the error.
Another workaround is to do the resizing/rotating until everything fits in the build area. Then you can export the model(s) - close and resart the app and you can start generating the code with version 2.5.0

Currently there is no beta test in progess so at least another week before we get the new version.