CNC, error when cutting disjoint polygons


I’m trying to cut the following model, but the result is wrong.

Snapmaker 2 A350
Machine firmware v1.10.0_20200723
Snapmaker Luban v3.7.0 (
Fusion 360 v2.0.8809

Can’t tell from that.
Post the fusion and g-code/cnc.

Have you tried using camotics or to see what it’s doing?


Here’s the g-code.
I run it in and it looks good.
I suppose it is a machine error of some kind.

1.cnc (470.3 KB)

1 Like

Looks fine in Luban.

You’ve had success with other cnc from fusion?

Maybe try exporting g-code from fusion again. Quit Luban and import to Luban again?

Or try from a usb?

I’ve had some weird things show up and go away when I’ve redone them.


1 Like

I think I would start it directly from the USB. I couldn’t try anything yet, because I’ve got no machine. But I think @jepho had some problems when trying to laser engrave files he created without Luban but was lasering with Luban.

Is that one sliced model or two? I mean, when you loaded the model, did you load one model or two models? I’ve noticed what I think is an issue when printing two models.

And still being a novice, that could be me missing some detail.