Cannot upload custom image to SnapmakerJS

Hi!
When i upload a custom image to SnapamkerJs, image not appear to workplace, default image is not change!

Hi,

I’ve the same error using snapmakerjs! I can’t upload any image. JPG, PNG, BMP … nothing will displayed in
the working area. Only the default image is displayed. I’ve tried 2.3.1 and 2.3.0 … and 32 and 64 bit…

Win 10 64Bit

Thanks!
Stevie

Hi,
I have exactly the same problem with a configuration under Linux 64 (opensuse tumbleweed). My solution to work around this malfunction is to drop my png, svg . images directly into the “Snapmakerjs/resources/app/web/images/_cache/” folder.
From the cache images are loaded into the Snapmakerjs interface. I think this is a small concern of writing permission management in the appropriate directory. The snapmaker team should be able to fix this at the next update.
Thank you

I haven’t encountered this problem. What version of Snapmakerjs are you using?

I’m not sure if anyone has received a response as to why this is happening but I have the same thing happening on my end. I’ve been able to save the response before it disappeared in which it displayed “A problem caused the server to stop working correctly. Check out the server status and try again.”

The console area in Snapmakerjs 2.3.2 developer tools indicates the following:

LaserParameters.jsx:113 Uncaught (in promise) TypeError: Cannot read property ‘width’ of null
at LaserParameters.jsx:113
at

along with:

websocket.js:111 WebSocket connection to ‘ws://127.0.0.1:64407/socket.io/?token=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpZCI6IiIsIm5hbWUiOiIiLCJpYXQiOjE1Mjc4NjM4NTIsImV4cCI6MTUzMDQ1NTg1Mn0.YKNewntcSN3Z3_bzzbw1jMNAjFJ6vw5atTHlPU54qOg&EIO=3&transport=websocket&sid=jPDdm9cjWJGMva75AAAA’ failed: Invalid frame header

any help in this matter would be greatly appreciated.

Forgot to add, I’m running Win10 64bit version 1803 build 17134.48.

@KZXten Thanks for your feedback!

The error “TypeError: Cannot read property ‘width’ of null” occurs when we fail to parse the SVG image (which has .svg extension but not standard SVG file or not even a SVG file). You can try generating SVG file using other softwares (e.g. https://www.vectorizer.io/) to see if that works.

If you have problems with other formats of image please let me know.

Zheyong

@parachvte Any progress on getting fills fixed?

The problem here, especially as a new person using this utility, is that when I use the upload button it automatically is looking for a .png; .jpg; .jpeg; or .bmp file for the laser which led me to believe it could read those files then convert them to what was needed before using the laser.

It does, at least for PNGs. I’ve successfully laser engraved one.

Even when I try to pull one in I get the same error unfortunately. BTW, that’s using their standard .png files in the install folder even.

@TheBum Not fixing the fills very soon, but we are working on other big changes on the software we will release next week.

@KZXten that’s weird. Can you give more details about your operations?
From your previous post I can infer:

  1. OS: Win10 64bit
  2. Snapmakerjs version: 2.3.2
  3. Mode: Laser B&W or Greyscale?
  4. Using our default picture named “snap-logo-square-256x256.png”?

It that right?

OS Name: Microsoft Windows 10 Home
OS Version: 10.0.17134 N/A Build 17134
Snapmakerjs version 2.3.2
Mode: B&W & Greyscale tried
the default pictures used were those in the install directory Snapmakerjs\resources\app\web\images

I’ve tried various images in the directory with BW & Greyscale, I’ve also tried the images contained in that directory for the vector in which the program crashes, rosetta for example; which may be the 3D carve image but an SVG none the less.

LaserParameters.jsx:113 Uncaught (in promise) TypeError: Cannot read property ‘width’ of null
at LaserParameters.jsx:113
at

As my 3d Print Module is gameover and I’m still awaiting a solution from the technical support

I wanted to play with laser module. But now I can’t upload an other picture… :frowning:

I’ve updated with the last application version but impossible to laser engrave

what is this new problem ? and how I can resolve it ?

please help me

@Rainie !!! I’m damned or what ?

I’ve tried to rename _cache directory then launch the application : result a message as the web page was not found !!!
Is it simply a web interface SnapmakerJS ?

Ok in Fact you’ve got a javascript error in your Electron application using React

in webpack:///C:/projects/snapjs/~/superagent/lib/client.js at line 802

xhr.send(typeof data !== ‘undefined’ ? data : null);

exactly an error 500 (Internal Server Error) on http://127.0.0.1:51101/api/image

Error: cannot POST /api/image (500) at l.toError (http://127.0.0.1:5110Preformatted text1/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1162518) at l.r._setStatusProperties (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:2026579) at new l (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1159737) at c.<anonymous> (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1160248) at c.r.emit (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:755375) at XMLHttpRequest.t.onreadystatechange (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1165288)
    method
    :
    "POST"
    status
    :
    500
    url
    :
    "/api/image"
    message
    :
    "cannot POST /api/image (500)"
    stack
    :
    "Error: cannot POST /api/image (500)↵    at l.toError (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1162518)↵    at l.r._setStatusProperties (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:2026579)↵    at new l (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1159737)↵    at c.<anonymous> (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1160248)↵    at c.r.emit (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:755375)↵    at XMLHttpRequest.t.onreadystatechange (http://127.0.0.1:51101/c83b2e9f/vendor.2612a8bd1ef388fefa04.js?_=1526551448038:1:1165288)"




1 Like

may be a wrong dest setted here in webpack:///./api/index.js line 37
David Chen ?

allright in fact here https://snapmaker.com/download
the links are :

SO I’ve juste tried to change 2.3.2 to 2.4.0 and it work I can download it
https://s3-us-west-2.amazonaws.com/.../Snapmakerjs-2.4.0

I hop 2.4.0 is the last release and will resolve my problem

And I’ve just seen update here :

hum now with 2.4.0 version When I try to upload I’ve got this message “Failed to parse image file”

1 Like

I also get this same error with any image file, including the samples with 2.4.4 on Windows 10-64 latest w/24GB RAM. Are there any known causes of this behavior that I can work around?