Calibration in snapmakerjs

Is it possible to calibrate the printer using the software?

I got some trouble with my touchscreen it’s initializing forever (Heating uncontrolably)

I still can connect my computer and send commands by software. However I do not know how to calibrate the 3D printer using the software.

Hey @dskerr , if you have followed the last post of your other topic

and you want to adjust or calibrate your machine anyways you could send the snapmaker marlin commands over the terminal. maybe look at this, https://marlinfw.org/docs/gcode

COMMAND: M503 shows you actual calibration settings:
Send: N78 M503*26
Recv: echo:Steps per unit:
Recv: echo: M92 X400.00 Y400.00 Z400.00 E92.60
Recv: echo:Maximum feedrates (mm/s):
Recv: echo: M203 X300.00 Y300.00 Z5.00 E25.00
Recv: echo:Maximum Acceleration (mm/s2):
Recv: echo: M201 X1000 Y1000 Z100 E10000 X_CNC100 Y_CNC100 Z_CNC100 E_CNC100 X_LASER3600 Y_LASER3600 Z_LASER3600
Recv: echo:Accelerations: P=printing, R=retract and T=travel
Recv: echo: M204 P1000.00 R1000.00 T1000.00
Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
Recv: echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
Recv: echo:Home offset (mm):
Recv: echo: M206 X-4.50 Y-5.50 Z-5.40
Recv: Mesh bed leveling:
Recv: echo: M420 S1 X2 Y2
Recv: echo: M421 X5.00 Y5.00 Z0.25 //this lines are the Z offsets per position
Recv: echo: M421 X120.00 Y5.00 Z-0.50 // there are four positions on the bed where it is calibrated
Recv: echo: M421 X5.00 Y120.00 Z0.00 // these are my current offsets
Recv: echo: M421 X120.00 Y120.00 Z-0.55
Recv: echo:Z2 Endstop adjustment (mm):
Recv: echo: M666 Z0.00
Recv: echo:PID settings:
Recv: echo: M301 P22.20 I30.00 D18.00 C100.00 L20
Recv: echo:Filament settings: Disabled
Recv: echo: M200 D3.00
Recv: echo: M200 D0
Recv: ok

If you want to calibrate your bed:

G28 : home axis
M420 S1 : set mesh adjustment (calibrate bed height) active
G29 S0 : shows you the actual bed mesh

i have figured out, it is complicated :sweat_smile:
my printer doesn´t go to the right points of messurement.
my way works like this:
ATTENTION give the Z some height at every positon NOT to collidate with the bed!

i give you no warranty or something else, if you destroy something, i am guilt-free

go to your position, i.e. X5 Y5 Z1
now, turn your Z down till the paper works for you (like normal calibration) like
Z0.9
Z0.8
etc.

X5 Y5 Z0.5 : calibrate this position to Z0.5:
G29 S3 X1 Y1 Z0.5
X120 Y5 Z0.6 : calibrate this position to Z0.6:
G29 S3 X2 Y1 Z0.6
X5 Y120 Z0.7 : calibrate this position to Z0.7:
G29 S3 X1 Y2 Z0.7
X120 Y120 Z0.8 : calibrate this position to Z0.8:
G29 S3 X2 Y2 Z0.8

here are the points of interest:

Recv: Mesh bed leveling:
Recv: echo: M420 S1 X2 Y2
Recv: echo: 1: M421 X5.00 Y5.00 Z0.25
Recv: echo: 2: M421 X120.00 Y5.00 Z-0.50
Recv: echo: 4: M421 X5.00 Y120.00 Z0.00
Recv: echo: 3: M421 X120.00 Y120.00 Z-0.55

Recv: Measured points:
Recv: 1:0.25000 2:-0.50000
Recv: 4:0.00000 3:-0.55000
Recv: ok

X5.00 Y5.00 : 1 (0.25) : left forward : X1 Y1
X120.00 Y5.00 : 2 (-0.5) : right forward : X2 Y1
X120.00 Y120.00: 3 (-0.55): right backward: X2 Y2
X5.00 Y120.00 : 4 (0.00) : left backward : X1 Y2

now you have to save your settings:
M500 : save to eeprom

check your calibration settings:
M503 or G29 S0

FINISH

feel free to contact me,
greets Chris

Thanks @xchrisd.

Do you know what will happen if I disconnect the computer in the middle of a print? In case I need to take my notebook elsewhere

@dskerr this will stop the print, the print could not be continued and is lost.
the computer sends the next Gcode line if the printer gives the OK, I am there

Ok, So I tried to calibrate the printer with terminal for the first time. It is being a complete nightmare :sweat_smile:

Moving the module around with G0 was ok, but the grid seems off. It seems that the printer is getting home position from the place the module was when turned on and it does not move before it (below 0).

G29 S3 gives me an error “X out of range” - it seems I have to set X1 Y1, X1 Y2, X2 Y1, X2 Y2, but not the actual position eg: X10, Y10, Z0.3. M421 also gives a similar range error.

Also, many movements resulted in the nozzle carving in the heating plate :man_facepalming:

Any ideas.

Hey, you have to home first
G28
Now set calibration active M420 S1
Then move to your position X5 Y5 Z0.5
Lower the head till your paper works
Z0.4
Z0.3

Now you could calibrate the position with
G29 S3 X1 Y1 Z0.3
The same with the others, move there manually then calibrate
End M500 to save the calibration settings.
Write

I know it’s massive exhausting, I have figured out specially for you, hope this helps