Bug Reports and Feedback for Snapmakerjs V2.5.X


The Image Preview Function in 3D Carving Modul runs into bug on Mac OS Mojave 10.14.3 on Mac Book Pro 13" Model 2017. Complete Application hang and quit with System Error Code (s. Attached Grafik)


Hello, does this happen frequently? Appreciate if you could send the detailed information to my e-mail:steve@snapmaker.com. We will try to locate the problem.
Thank you


Yes, I have tried more than one time. The Function does never work with the images I have tested. Is there a Limitation to Image Type or Size ?


Please add an option to chose automatic/manual preview.
I prefer placing the picture where I want to have it engraved and then generate the preview.

I’m missing the anchor function for the laser/CNC!
Maybe you can add a “free” funcion like the current behaviour.


There is no size limitation to the image.


hello, i’ve received my snapmaker enclausure, it have 2 doors and terminals at the midle that we must connect with a cable to the unit control of the snapmaker printer…


hello, i’m a new user of snapmaker, but i have a problem, when i try to print Something i get this error message, could someone help me?
Snapmakerjs 2.5.2
firmware 2.8
Windows 10 64bit

after slicing 100% i get this


This message seems to be quite common, it pops up by me as well.
It should however only show for a moment and then disappear again.

I see however from your Screenshot the message "Parsing G-Code"
and if the software hangs with this message that is a known issue and is apparently caused by large filesize. They are looking into this problem.


Thank you for your reply. So, for the moment there are nothing i can do to print my projects??


How large are your Projekts?

I can print STL files upto 72MB in Fast Print Quality with no problem.


Breaking News…

Snapmakerjs 2.5.3 just released.
With this you can turn off automatic preview which should "reduce calculations and memory usage when generating G-code from big images"
Not sure if this affects 3D printing or only CNC / laser (use of the term “images” is confusing).
Perhaps @parachvte can clarify. :wink:


@BriHar @JMDA
It’s only for laser and CNC. 3D Printing will take longer to complete. We temporarily increased the limit of software memory use (to 4G) and hope it can solve some of your problems. You might need another 3 weeks for the next version in which we optimize 3D printing part. :sweat_smile:

Downloaded a model from Thinkverse. it generates but not loading

Ok… Now I think I know my problem. In fact, my computer was too charged and old, so i bought a new one (a sheap one) only to use with my snapmaker but it has only 2 Gb of RAM… Maybe if i upgrade to 4 Gb the problem will disappear…


I only have little one’s… Less than 40 Mb


I’m running 2.5.2. every time i try and use greyscale in the CNC module, it crashes to desktop when i hit the preview button. Also, like with the laser module, will there potentially be added file types for vector? I like that i can imput a png and it vectorizes it and would love this functionality in the CNC as well.


SnapmakerJS 2.5.2 not working for me on Mojave 10.14.3. I can’t get past this pop-up that says server stopped working. No amount of “reloading” does anything.


Toggling developer console shows this error:


Also broken with 2.5.3:

Has anyone been able to use SnapmakerJS with a Mac?? I reported that 2.4.6 was not working for Mojave either a while back… Is anyone on the Snapmaker team actually testing this software with a Mac? It seems it has been broken for a long time…


@acwrightdesign Actually we are developing Snapmakerjs on macOS. Seems like your system blocks the websocket connection between Snapmakerjs client and its server. Did you configure the firewall or one of your applications is capturing the network?


@parachvte Hmm… Ok. Good to know. My system is “stock”. I have not set up any special firewall settings. The firewall is turned on in settings.

Wow. Ok. Thanks. You led me in the right direction. I just tried quitting Slack which is also an Electron app and sure enough that app was preventing SnapmakerJS from working correctly!