Bug Reports and Feedback for Snapmakerjs V2.5.X


Bug in CNC Carver

Adding two of the same image, one with “Outline” and the other with “Fill” do not compliment each other.

As you can see from the image (and yes, the resulting carved output is in fact just as crappy), the “Fill” carve extends OUTSIDE the Outline lines.

If I do a “Fill” at the resolution required for the round edges, the carving will take 8 hours, and the outline is pointless.

If I do an “Outline”, the carving takes 30 minutes, but there is “fill” left between the outer and inner lines. I can’t win.

I’m expecting the “Fill” to only carve within the “Outline” area. I think the problem is that the “Fill” path does not care about the Outline path and takes 8 hours to complete because it’s going up line by line rather than by the paths already established for “Outline” (just progressively closing in)

As a feature request, I would like a “Delete Infill” within the “Outline” area so that it follows the same path and can be completed in 1/8th the time of a “Fill” pathing.


I tried to edit the number of lines for the BRIM from 20 to 15 and it has no affect. The default is now 15 but it still prints 20 lines. Am I missing something? Is the calculation overriding the default number of Brim Lines?


Did you restart Snapmakerjs after you changed the value? (snapmakerjs only reads the file on start up).

The Brim count also has to do with the following parameters: “Support Brim Width”, “support_brim_line_count”, “skirt_brim_minimal_length”, “brim_width” (brim_width should be brim_line_count * 0,4)


Yup after restart the speed is slower but trying to figure out how to cut out the number of brim lines. Must be In the calculation so it’s still doing 20 or it’s somewhere else. Went thru the entire file and checked all spots. The brim so far has been exactly 20 lines for every print I have done even though the number is 15 in the config file.


It works for me if I change the “brim_line_count” parameter “default value” to 15 (line 4602) it works for me

…it seems to work even without restarting snapmakerjs



Found the issue. I use Notepad++ to edit GCode for my CNC machines and you have to be in Administrator Mode when you open a locked file to be able to edit it and save it. So I was changing the number to 15 saving it and then apparently it’s not really saved so 20 continued to show up. So I unlocked the file changed it to Brim 15 and BINGO… It’s now at 15… go figure.

Thanks for the help… ! ! !


Hi Al

Another issue with SnapmakerJS in using the laser function. I can upload a background picture frame then using theText feature add a name, such as

if I click outside the text box it is impossible to reacquire the text to move it as it selects the background picture. I have to move the background out of the way to get to the Text. Do you have a a smarter way of handling the layers?

Also when creating a Text box the widget on the right side appears so as to tailor the text. When you click outside the text box, this widget disappears



Dear Support

You need to update the SnapmakerJS User Manual to reflect recent changes such as the inclusion of TEXT and FILL feature




I just found that if you right-click an image you can send it to the background or bring it to the front… this solves my problem… this needs to be in the Help file.


When you pause a Laser job (tested with 1,6 W) the Laser turns off but it doesn’t come back on resume.


Updated from 2.5.4 to 2.5.5 on windows 10 64

  • All saved print settings once again lost on update
  • Custom material settings still not being saved
  • Can no longer click and drag models into snapmakerjs.
  • Copy and paste not working at all, both keyboard (ctrl-c and ctrl-v) and using edit menu do not work.

Things I tried to fix

  • Tried uninstall/reinstall, no fix
  • Removed all existing config data (that json file), no fix
  • Running as admin, no fix
  • rolled back to 2.5.4 (was difficult for some reason) at least copy paste and click and drag work again.

So new version appears less functional and breaks rollback to older version that works better.


Settings made to the program should be saved (auto-preview, widget settings open/closed/disabled,…)


Hi @Terra-Fy

Can you clarify what function you were using, the 3D print or Laser ?

I am using v2.5.5 on W10 64 and I was able to drag and drop an STL file into the 3D print function and an image into the laser function.

I agree copy and paste will not work

I have not tried save settings as yet



I was using the 3D print function. When I rolled back to 2.5.4 drag and drop worked fine suggesting its an issue in 2.5.5


Just downloaded and installed the newest version on my PC and it will not open. It is showing in Task Manager but never opens the program. I installed the 2.5.5 64 bit on my Windows 10 and all other previous versions did not do this. I uninstalled, restarted and installed again and it still shows as running within the task manger but no program opens up.


Loads OK on my W10 64 system… step through an Alt+Tab sequence and make sure the install is not waiting fro a reply.


Sorry the break we made in 2.5.5 (copy & paste).

  • We saved your settings on recommended configuration location of specific platform (Application Support/ on macOS, C:/ProgramData/ on Windows), from this version. Expecting your print settings are kept on next update s.
  • Custom material settings will be the same as print settings, on next version.


Continuing the discussion from Downloads and Updates:

Hi Snapmaker team,

can you explain why (for normal people) a bugfix release 2.5.x has major changes in it? Isn’t it better to show such major changes in a higher version number like 2.6 or 3.0 for adding new functions like support of Snapmaker 2.0 or a changed

Furthermore I’ve got graphic glitches in print settings when I use German as language in settings.


Thanks for your feedback.

We’ve just uploaded Snapmakerjs v2.6.0 Beta Testing for new features. You are right we were not strictly using the semver to denote patch versions, we used major version for breaking changes, minor version and patch version for big and small new features. And later on we will use only minor version for new features.

The glitches will be fixed when we release 2.6.0. :wink:



Iv been having problems with the both 200mw and the 1.6w laser modules. With firmware 2.11 the lasers don’t output any power, iv checked all the leads on the machine etc and lowered the power down to 70% but still wasn’t getting any output. I think I have narrowed it down to a problem within firmware 2.11 as I have reverted back to GD32Base-2.9 and now both laser modules are outputting power.